Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Luan Martins

RESOLVIDO estrutura de repetição

Recommended Posts

Galera eu estou fazendo tecnico em informatica, estou em algoritmos  começando mesmo, ja aprendi varias coisas, mais por questoes de saude tive de afastar do trabalho e dos estudos, agora tenho que fazer um trabalho sobre estrutura de repetições apresentando algumas questoés porém eu pesquisei na internet e nao consegui fazer nada, eu so copio, e isso nao vale d enada, como eu aprendo, alguem ai tem um metodo para me ensinar?? eu copiei um assim mais no fim tambem deu errado

 

1.      Escrever um algoritmo que leia o nome e o sexo de 56 pessoas e informe o nome e se ela é homem ou mulher. No final informe total de homens e de mulheres.

,

 

algoritmo "semnome"// Função :// Autor :// Data : 29/05/2014// Seção de Declarações varnome, sexo : caracterex, h, m : inteiroinicio// Seção de Comandos    para x de 1 ate 2 faca   limpatela   escreval ("Digite o nome:")   leia (nome)   escreval ("H - Homem ou M - Mulher")   leia (sexo)   escolha sexo           caso sexo                caso "H"                     H <- h + 1                caso "M"                     M <- m + 1                outrocaso                         escreval ("O sexo so pode ser H ou M!")   fimescolha   fimpara   limpatela   escreval ("Foram inseridos",h," Homens")   escreval ("Foram inseridos",m," Mulheres")fimalgoritmo
 
no final aparece que foram inseridos 0 homens e 0 mulheres o que tem de errado? e alguem tem alguma indicação de site ou video q eu possa ver para aprender ???????????
Editado por dif

Compartilhar este post


Link para o post
Compartilhar em outros sites

   escolha sexo           caso sexo                caso "H"                     H <- h + 1                caso "M"                     M <- m + 1                outrocaso                         escreval ("O sexo so pode ser H ou M!")   fimescolha

Olhe novamente esse trecho do seu código, apague apenas o comando "caso sexo" e deixe o resto, após testar comente novamente se resolveu.

10306622_247855018756570_404081125235649

Aqui funcionou!

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
Visitante
Este tópico está impedido de receber novos posts.





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×