Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Luan Martins

Faça um algoritmo que receba um número e mostre uma mensagem caso este número seja maior que 80, menor que 25 ou igual a 40.

Recommended Posts

Pessoal eu tenho que fazer a seguinte questão do trabalho

 

1.      Faça um algoritmo que receba um número e mostre uma mensagem caso este número seja maior que 80, menor que 25 ou igual a 40.

 

eu fiz ele, mais eu fiz usando o codigo SE, porém eu creio que o professor quer com o caso e escolha algo assim, porém por motivos de saude nao pude ir as aulas, 3 seguidas e estou perdido, eu fiz da seguinte maneira,

 

 

algoritmo "semnome"// Função :// Autor :// Data : 29/05/2014// Seção de Declarações var   num : realinicio// Seção de Comandos    escreval ("Informe um número")   leia (num)   se (num > 80) então      escreval ("O número: ",num," É maior que 80")      senao           se (num = 40) então              escreval ("O número informado é igual a: ", num)              senao                   se (num < 25) então                      escreval ("O número informado é menor que 25")                   fimse           fimse   fimsefimalgoritmo
deu certo até, so que eu queria implantar o caso nele, como faço????????
Editado por dif
Inserir a tag CODE

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá!

O que você chama de "caso" seria o switch..case?

Exemplo:switch( ano )          {            case 1: printf("És caloiro!\n");                break;            case 2: printf("És do segundo ano\n");                break;            case 3: printf("És do terceiro ano\n");                break;            case 4: printf("És do quarto ano\n");                break;            case 5: printf("És do quinto ano\n");                break;            default: printf("Escreve um ano entre 1 e 5\n");          }

Acho que ele só trabalha com valores exatos. Então tem que ser igual a 80, igual a 40 ou igual a 25.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×