Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
thomazrocha

Projeto de controle de luminosidade de led

Recommended Posts

thomazrocha    0

Olá pessoal,

 

Gostaria da ajuda de vocês para solucionar esse problema que atou a dias quebrando cabeça mas não consigo. Não sei como efetuar a ligação desse esquema para assim dar continuidade ao projeto gostaria de uma ajuda.

 

Grato desde ja.

 

 

 

post-563824-0-91661200-1403226373_thumb.

Projeto_GB1_PWM.pdf

Editado por thomazrocha

Compartilhar este post


Link para o post
Compartilhar em outros sites
aphawk    2.456

@thomazrocha,

 

Meu amigo, ajuda a gente, não conseguí advinhar o resto do circuito.... !!!

 

Poste todo o circuito.

 

Paulo

Compartilhar este post


Link para o post
Compartilhar em outros sites
thomazrocha    0
  • Autor do tópico
  • Ola Paulo,

     

    O restante do projetoja executei gostaria de saber apenas como fazer a ligação dos 7400 no up/dow do 74193.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
    aphawk    2.456

    @thomazrocha,

     

    Bom, pelo que eu estou vendo do seu circuito, nem sei prá que que serve essas duas portas 7400 ....  como disse, ainda não temos advinhos aqui, voce precisa forneçer as informações para que possa ser ajudado !

     

    É tão difícil assim colocar o circuito completo, e a descrição do que você quer que esse circuito faça ?

     

    Paulo

    • Curtir 1

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
    thomazrocha    0
  • Autor do tópico
  • Coloquei o anexo em pdf, o projeto em si paulo, se poder dar uma olhada para dar uma força, fico grato.

     

    Obrigado pela disponibilidade.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
    aphawk    2.456

    @thomazroch,

    Agora sim !

    Vou deixar voce mesmo pensar :

    O seu problema é o contador 74193, pois ele pode contar de 0 a 15 , e caso receba outro pulso, a contagem vai para 0 se for pulso tipo UP, ou pode de 0 ir para 15 se for pulso tipo DOWN.

    O que voce quer é que essa contagem fique sempre entre 0 e 9, isto é, tem de ter algum tipo de limitador, algum circuito que limite a contagem para cima, não deixando passar de 9 mesmo se receber outro pulso UP, e nem deixe diminuir abaixo de 0 se receber outro pulso DOWN.

    Agora, repare no 7442.

    Ele tem dez saídas, sendo que apenas uma delas tem nivel 0 conforme a entrada varie entre 0000 (0 decimal) e 1001 (9 decimal).

    E finalmente, repare que voce tem DUAS portas 7400 sobrando.... E tem justamente DOIS sinais que precisam ser "bloqueados", que são os sinais que saem das chaves de UP e DOWN, e que devem chegar aos pinos de entrada respectivamente Up e Down do 74193 !

    Essas duas portas lógicas funcionam justamente como o tal circuito limitador que te falei acima !

    Entendeu ?

    Veja se conseguiu matar, e poste a solução para outros poderem aprender também !

    Paulo

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
    thomazrocha    0
  • Autor do tópico
  • Ola Paulo,

     

    Executei o projeto em simulação e funcionou na hora de passar para protoboard, deu problema o display de 7 segmentos fica bem "doido". Vou postar meu esquema se poder dar uma analisada, fico grato. Pois ja estou sem saber o que possa ser.

    post-563824-0-17589600-1403272220_thumb.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
    aphawk    2.456

    @thomazrocha,

     

    Está certinho.... confira se voce ligou todos os outros pinos de alimentação e terra , pois o Proteus não mostra eles... deve ser esse o problema.

     

    Mas na simulação deu tudo certinho.

     

    Paulo

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
    thomazrocha    0
  • Autor do tópico
  • Paulo, 

     

    Aquela outras saídas dos do 7442 não preciso ligar em nada?

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
    MOR    798

    Dei uma olhada no 74LS193.

    Observei que a contagem só ocorre nos seguintes casos, segundo a nota B da figura dos tempos do manual:

    1 - Contagem UP. A entrada CNTDWN TEM que estar em '1'.

    2 - Contagem DOWN. A entrada CNTUP TEM que estar em '1'.

     

    Pelo que observei no circuito, as duas entradas CNTDWN e CNTUP ficam em '0' sem as chaves estarem pressionadas.

    Para que o contador possa contar, seria necessário que:

    CNTUP = UP (EBarrado) DOWNBarrado   e

    CNTDWN = UPBarrado (EBarrado) DOWN

     

    Nestas condições, ao se pressionar uma chave, a saída correspondente vai a '0' e ao soltá-la, ela vai a '1' alterando a contagem.

     

    Verifique se o contador está contando.

    MOR_AL

    Editado por MOR

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
    thomazrocha    0
  • Autor do tópico
  • Ola pessoal,

     

    Obrigado pela ajuda, sim fava errada a ligação das portas nand. Agora ta funcionando mas estou com um outro problema ele esta contando rápido demais. 

     

    Aperto o botão de up e quando solto vai direto para o 5 ou 9, gostaria de saber seda que tem haver com o clock gerado pelo 555?

     

    Mas muito obrigado pela ajuda de vocês 

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
    aphawk    2.456

    @thomazrocha,

    Não, não é o 555. Experimente usar um capacitor de maior valor, tipo umas 3 vezes maior, onde está o botão. Esse seu problema é causado por ruido do contato do botão, e o capacitor deveria conseguir segurar para não ter esse ruido todo.

    Paulo

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Crie uma conta ou entre para comentar

    Você precisar ser um membro para fazer um comentário






    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×