Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
TELEFONIA FIXA

RESOLVIDO Mostrar Idade no Excel se eu lançar a data de Nascimento , com Erro

Recommended Posts

Eu adicionei uma formula que retorna na célula ao lado a soma da idade.

Ex: em A1 eu coloco a data de nascimento 20/7/1967  em A2  retorna 47 Anos, até ai tudo bem, mas se eu deixar a célula A1 em branco vazia sem uma data retorna 114 em A2

 

Segue exemplo:fc hardware.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom dia teko

 

A fórmula está correta, pois da maneira que o Excel calcula as datas, o resultado é esse mesmo, pois o Excel começa a contar a data a partir de 0/0/1900.

Para resolver o problema da célula vazia, basta inserir uma função condicional SE no início da fórmula, veja:

 

=SE(A4="";"";INT((B4-A4)/365,25))

 

A melhor função para fazer esse tipo de cálculo é a função DATADIF,  veja como a fórmula ficará com essa nova função:

 

=SE(A4="";"";DATADIF(A4;B4;"Y"))

 

Veja como usar a formula:

 

=DATADIF(célula_datainicial; célula_datafinal;"D") conta os dias
=DATADIF(célula_datainicial; célula_datafinal;"M") conta os meses
=DATADIF(célula_datainicial; célula_datafinal;"Y") conta os anos.

 

Dê retorno.

 

[]s

Editado por Patropi
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • Bom dia teko

     

    A fórmula está correta, pois da maneira que o Excel calcula as datas, o resultado é esse mesmo, pois o Excel começa a contar a data a partir de 0/0/1900.

    Para resolver o problema da célula vazia, basta inserir uma função condicional SE no início da fórmula, veja:

     

    =SE(A4="";"";INT((B4-A4)/365,25))

     

    A melhor função para fazer esse tipo de cálculo é a função DATADIF,  veja como a fórmula ficará com essa nova função:

     

    =SE(A4="";"";DATADIF(A4;B4;"Y"))

     

    Veja como usar a formula:

     

    =DATADIF(célula_datainicial; célula_datafinal;"D") conta os dias

    =DATADIF(célula_datainicial; célula_datafinal;"M") conta os meses

    =DATADIF(célula_datainicial; célula_datafinal;"Y") conta os anos.

     

    Dê retorno.

     

    []s

    Vou testar ja, testado e aprovado, perfeito, muitissimo obrigado

    Editado por TELEFONIA FIXA

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
    Visitante
    Este tópico está impedido de receber novos posts.





    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×