Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
Entre para seguir isso  
Mr Burns

Instalação Da Nvidia...

Recommended Posts

Bem, to tentando instalar os drivers de vídeo da nVida no meu Slackware 10 (BOM DE MAIS!!!! :palmas: ) , só q acontece o seguinte:

Sem modo gráfico dou um ./NVIDIA-Linux-x86-1.0-6106-pkg1.run

Até aí tudo bem... Ele extrai os arquivos e vai para a tela da licença... Eu aceito e ele pergunta se quero conectar no site da Nvidia. Eu respondo Não e ele vai para a instalação... Aparece build, só q dá um erro não achando kernel pre compilado.. aí pede para rodar a instalação novamente, só q indicando onde o kernel source está instalado...

Alguem aí sabe qual é o comando para isso??? E onde fico sabendo onde esse carinha está?? :huh:

Compartilhar este post


Link para o post
Compartilhar em outros sites

veja se você tem as fontes do kernel instaladas na pasta /usr/src... depois disso, durante a instalação, diga para o instalador criar um módulo novo para o seu kernel (no slackware tem que ser assim)... beleza? falou! B)

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • Consegui!!! hahahahaha :palmas: :palmas:

    Só q foi digitando

    sh NVIDIA-Linux-x86-1.0-6106-pkg1.run

    Mas antes eu dei um

    ./NVIDIA-Linux-x86-1.0-6106-pkg1.run --diretorio do meu kernel source

    Tá funfando o OpenGl... Mas agora tenho uma perguta:

    É só OpenGl q ela funciona no Linux?? Não tem outra API não?? :huh:

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Po fui tentar instalar o driver da Nvidia e deu esse erro aqui:

    Alguem pode me ajudar?

    Obrigado

    nvidia-installer log file '/var/log/nvidia-installer.log'

    creation time: Fri Jul 23 15:44:39 2004

    option status:

    license pre-accepted : false

    update : false

    force update : false

    expert : false

    uninstall : false

    driver info : false

    no precompiled interface: false

    no ncurses color : false

    query latest driver ver : false

    OpenGL header files : false

    no questions : false

    silent : false

    X install prefix : /usr/X11R6

    OpenGL install prefix : /usr

    Installer install prefix: /usr

    kernel source path : (not specified)

    kernel install path : (not specified)

    proc mount point : /proc

    ui : (not specified)

    tmpdir : /root/tmp

    ftp site : ftp://download.nvidia.com

    Using: nvidia-installer ncurses user interface

    ERROR: An NVIDIA kernel module 'nvidia' appears to already be loaded in your

    kernel. This may be because it is in use (for example, by the X

    server). Please be sure you have exited X before attempting to upgrade

    your driver. If you have exited X but still receive this message, then

    an error has occured that has confused the usage count of the kernel

    module; the simplest remedy is to reboot your computer.

    ERROR: Installation has failed. Please see the file

    '/var/log/nvidia-installer.log' for details. You may find suggestions

    on fixing installation problems in the README available on the Linux

    driver download page at www.nvidia.com.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    ele tá falando que já tem um módulo da nvidia carregado... tenta sair do X antes (da um init 3 como root no console) e depois tenta instalar os drivers d novo... B)

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
    Postado Originalmente por k0d31n3@23 jul 2004, 16:46

    ele tá falando que já tem um módulo  da nvidia carregado... tenta sair do X antes (da um init 3 como root no console) e depois tenta instalar os drivers d novo...  B)

    beleza ccara, brigadao, tentarei e volto aqui para dizer

    muito obrigado

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • OH, eu estava tendo um série de travamentos depois q instalei esse driver...

    Se eu reiniciasse o servidor X , o Linux travava todo, inclusive dando Kernel Panic... :blink:

    Aí, tipo, eu reinstalei o meu Slackware... aí quando eu fui fazer a instalação do driver novamente, mostrou um aviso de que módulos da nvidia Riva estavam carregados e q o driver q eu ia instalar podia ocasionar incompatibilidades... Será q eram os módulos para Riva TNT q estavam causando esses travamentos?? :huh:

    E quando mandei instalar assim mesmo deu um erro e não instalou... :cry:

    Será q tenho e seria mais seguro recompilar o kernel, removendo esses módulos antes de instalar o driver?? :huh:

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • Agora instalei sem problema nenhum hehehehe !!! Meu Slack agora tá com kernel 2.6.7... ficou doido de mais!!!! B)

    Mas agora estou tendo um probleminha... :(

    quando habilito o frame buffer no lilo, fica tudo preto... Tipo, o framebuffer está habilitado no kernel, porém eu não estou usando o módulo nv riva... Eu retirei do kernel.

    Mas pelo q vi, o bootsplash é mais legal e eu tenho q desabilitar o framebuffer...

    Ah, mas só q tá acontecendo isso:

    Eu editei o xorg.conf tirando o linha com dri , deixando só o glx, como a nvidia pede... E troquei o driver de nv para nvidia... Lembro q no kernel 2.4.26 funionou ...

    Agora, com o 2.6.7, quando eu vou iniciar com o startx não vai, e aparece Not Screen found... :muro: Já refiz as configurações do monitor, e resoluções com o xorgcfg -textmode. Mas não adianta... Só com o xorgsetup, porém só posso ter freqüência de 60hz no monitor, o que tá regaçando a minha vista... :wacko:

    Será q é incompatibilidade com o kernel 2.6.7?

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • beleza!!! resolvi o problema!! Estava tudo no xorgconf. Eu apaguei o arquivo e fiz o setup do Xorg de novo. Agora tá bzl.

    Mas notei uma coisa. Tipo, toda vez q eu vou reiniciar o servidor X com o driver da nvida, o computador trava todo... :( Tipo, se eu saio do KDE, vou pro modo texto e dou um startx de novo, o Linux congela literalmente... :blink:

    Alguém aí sabe o q pode ser? Estou com o Slack10 com kernel 2.6.7, Xorg e driver mais novo da nvidia.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    provavelmente ele não tá matando o servidor x por completo, só fechar o KDE não resolve, antes de reiniciar o modo grafico, digite init3 e veja se ele trava....

    Obrigado

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Crie uma conta ou entre para comentar

    Você precisar ser um membro para fazer um comentário

    Entre para seguir isso  





    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×