Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Goriebir

Excel - reconhecer número no formato "0000.00.00"

Recommended Posts

Bom dia pessoal

Estou com uma dúvida aqui que não consigo resolver tenho vários produtos que são classificados de várias maneiras, uma delas é pelo NCM. Esses números são do formato 0000.00.00. Então por exemplo eu quero fazer uma funcão Se para fazer um tipo de cálculo de acordo com o NCM. Os números de meu interesse são: (7320.20.90 e 8302.50.00), ou seja, quando o produto apresentar esse NCM eu quero fazer um cálculo específico. Eu tentei usar essa funções sem sucesso.

1- =SE(A1="7320.20.90"; A1*1,302;A1)

1- =SE(A1=7320.20.90; A1*1,302;A1)
 

Já tentei colocar a célula A1 como texto, como número, como geral mas todas as fórmulas deram erro. Como faço para o excel "reconhecer" esse número nesse formato (0000.00.00)??

Agradeço muito a contribuição da comunidade

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa tardeGoriebir

 

Seja bem -vindo ao fórum!

 

Numa outra coluna copie e cole a fórmula abaixo e arraste até a linha desejada.

=SUBSTITUIR(A1;".";"")

 

Depois use a tua formula assim, ajuste a coluna, pois eu considerei como coluna B.

=SE(B1=73202090; B1*1,302;B1)

 

Se foi útil, clique em Curtir.

 

Dê retorno.

 

[]s

 

 

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Goriebir Bom dia.

 

Usando a formula que o colega @Patropi fez, pode usar esta em uma unica formula e obtêm o resultado

 

=SE(VALOR(SUBSTITUIR(A1;".";""))=73202090; VALOR(SUBSTITUIR(A1;".";""))*1,302;A1)

 

Decio

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • @Patropi e @deciog. Realmente funcionou, muito obrigado. Pelo que entendi a função substituir ela "retira" os pontos e rescreve o número sem eles né.

    Eu adicionei a função ou então eu consigo usar a mesma lógica e expandir para mais números, mas até agora não entendi por que o excel não reconheceu o número naquele formato. 

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    @Goriebir

     

    Se a célula que esta o numero com os pontos, então ela é texto, agora se a célula estive com numero porém formatada com o pontos, então é numero, a multiplicação só pode ser em numero, por isso a substituição tirando o ponto, para fazer o calculo.

     

    Espero ter ajudado

     

    Décio

     

    • Curtir 1

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Goriebir

     

    O Excel do Brasil, reconhece a virgula como separador de casas decimais.

    O ponto é utilizado pelo Excel em Inglês, por isso, dá esse problema.

     

    []s

    • Curtir 1

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    este NCM deve ser tratado como texto.

    insira aspas simples ao incluir o numero que o excel entende que aquela célula é texto.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    @Goriebir Consegui usando a seguinte formula.

     

    Exemplo Tenho o texto 12345678 na coluna A1, quero deixar ele assim 1234.56.78

     

    Faremos o seguinte, =TEXTO(A1;"000\.00\.00")

     

    Não me pergunte o porque, mas funciona o texto ficará 000.00.00.

     

    :D  

     

    Usei isso pra minha macro de inserir nota fiscal no SAP de forma automatizada.

    Editado por Panicguy

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Crie uma conta ou entre para comentar

    Você precisar ser um membro para fazer um comentário






    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×