Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Silvio232

Conversão portugol-java

Recommended Posts

Bom dia,

Preciso converter o seguinte código para Java,porém, estou tendo problemas,gostaria de ajuda.

 

var

nome:caracter
idade:inteiro
valhrtrab:real
diasmes:inteiro
d:caracter
n:caracter
turdiario:caracter
diastrabmes: inteiro
horasdia: inteiro
salario: real
inss: real
fgts:real
inicio
escreva("Digite o nome do funcionário: ")
leia(nome)
escreva("Digite a idade do funcionário: ")
leia(idade)
escreva("Digite quantos dias trabalhados no mês: ")
leia(diastrabmes)
repita
escreva("Regime de horas trabalhadas por dia. 6 ou 8 horas?: ")
leia(horasdia)
ate ((horasdia = 6) ou (horasdia = 8))
escreva("Digite o Turno. D para Diurno e N para Noturno ou Pressione S para Sair: ")
leia(turdiario)
se ((turdiario <> "D") e (turdiario <> "N")) então
escreval("Programa Finalizado!!")
fimse
se ((turdiario = "D") e (idade <=50)) então
valhrtrab:= 3
senao
se ((turdiario = "D") e (idade > 50)) então
valhrtrab:= 3 + (3*0.10)
fimse
se ((turdiario = "N") e (idade <=50)) então
valhrtrab:= 4
senao
se ((turdiario = "N") e (idade > 50)) então
valhrtrab:= 4 + (4*0.10)
fimse
fimse
fimse
salario:= (valhrtrab * horasdia* diastrabmes)+ (valhrtrab * horasdia* diastrabmes* 1.5)
fgts:= salario*0.08
se salario<= 1556.94 então
inss:= salario*0.08
senao
se ((salario >=  1556.95) e (salario <= 2594.92)) então
inss:= salario*0.09
senao
se ((salario >= 2594.93) e (salario <= 8189.82)) então
inss:= salario*0.11 senao
fimse fimse
fimse
escreval("O salario bruto é: ",salario)
escreval( "O Total do Depósito do FGTS é: ",fgts)
escreva( "O depósito do INSS é: ", inss)
fimalgoritmo
 

Muito Obrigado.

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá,

 

Em 1o lugar, qq program em java deve ser uma classe e ter um método principal, assim:

 

//Nome da classe deve estar em camel case e ser o mesmo do arquivo (ex MinhaClasse.java)

 

//Classe:

public class MinhaClasse{

    //Método principal (main)
    public static void main(String[] args){
      //Aqui você declara variáveis, código, etc

     }
}

 

Agora uma visão geral da sintaxe pro seu código seria:

 

//Declara variáveis: (Isso deve estar dentro do main) 

 String nome; //texto
  int idade       // inteiro
  float salario   //real

 

*pesquisa sobre tipo de dados em java e veja o que você precisa

 

Para printar no console (escreval) :

System.out.println("Olá, Mundo Java");

 

Para pegar dados do usuário (através do console):

String nome;
Scanner entrada = new Scanner(System.in)
System.out.println("Entre com seu nome");
nome = entrada.nextLine();

 

Condicional if fica:


 

if(nome == "Sergio Cabral"){
  System.out.println("Está em Bangu")
}else{
 // QQ outra coisa que você queira
}

 

 

 

  

 

Editado por nanquinote

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×