Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
willdelarosa

Atividade de lógica de programação Se Senão Então

Recommended Posts

Boa tarde amigos.

 

O professor passou uma atividade que não estou conseguindo fazer, de jeito maneira. Já li e reli todo o material já apresentado, pesquisei na internet, assisti vídeos, e não consigo desenvolver a atividade. Não sei mais o que fazer. Acho que esse é um daqueles problemas para espantar os alunos já no início da faculdade. Já tentei no Portugol Studio e no Visualg.

 

Por favor, vocês podem me ajudar a entender o que se pede, e como fazer?

 

Desenvolver um algoritmo que tenha como dado de entrada a data de nascimento de uma pessoa qualquer no formato dia, mês e ano. A partir dessa data, calcular a idade da pessoa em:

a) anos, meses e dias. Ex: a resposta seria a pessoa tem 38 anos 3 meses e 5 dias de vida

b) meses e dias. EX: a pessoa tem 459 meses e 5 dias

C) somente em dias. Ex: a pessoa tem 30.995 dias de vida

OBS: considerar o ano com 365 dias e o mês com 30dias.

 

Segue meu código:

 

algoritmo "idades"

var
diaAtual, mesAtual, anoAtual, diaNas, mesNas, anoNas, anos, meses, dias : INTEIRO

inicio

      escreval ("Digite dia, mês, e ano atuais")
      escreval ("Formato DD/MM/AAAA, separados com a tecla Enter: ")
      leia (diaAtual, mesAtual, anoAtual)

      escreval ("Digite dia, mês, e ano do nascimento")
      escreval ("Formato DD/MM/AAAA, separados com a tecla Enter: ")
      leia (diaNas, mesNas, anoNas)
      
      // ANO
      
      SE ((mesAtual = mesNas) E (diaAtual >= diaNas)) então             //JÁ FEZ ANIVERSARIO
         anos <- anoAtual - anoNas
      FIMSE

      SE ((mesAtual = mesNas) E (diaAtual < diaNas)) então              //AINDA NÃO FEZ ANIVERSARIO
         anos <- anoAtual - anoNas - 1
      FIMSE

      SE (mesAtual < mesNas) então                                      //AINDA NÃO FEZ ANIVERSARIO
         anos <- anoAtual - anoNas - 1
      FIMSE
      
      //MÊS
      
      SE ((mesAtual < mesNas) E (diaAtual >= diaNas)) então             //Se não fez aniversário mas completou mês corrente
         meses <- 12 - (mesNas - mesAtual)
      FIMSE
      
      SE ((mesAtual < mesNas) E (diaAtual < diaNas)) então             //Se não fez aniversário e nem completou mês corrente
         meses <- 12 (mesNas - mesAtual) - 1
      FIMSE
      
      SE ((mesAtual > mesNas) E (diaAtual < diaNas)) então
         meses <- (mesAtual - mesNas) - 1
      FIMSE
      
      //DIA
      
      SE (diaAtual < diaNas) então
         dias <- 30 - diaNas + diaAtual
      FIMSE
      
      SE (diaAtual >= diaNas) então
         dias <- diaAtual - diaNas
      FIMSE
      

fimalgoritmo

 

Desde já agradeço.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@willdelarosa      seu código está funcionando certo, você só não colocou os comandos para ele

mostrar os resultados.  coloque esses aqui no final antes do fimalgoritmo :

      escreva("Essa Pessoa Tem ---> ",anos," Anos e ")
      escreval(meses," Meses e ",dias," Dias De Vivo")
      escreva("Essa Pessoa Tem ---> ",anos*12+meses)
      escreval(" Meses e ",dias," Dias De Vivo")
      escreval("Essa Pessoa Tem ---> ",anos*365+dias," Dias De Vivo")

 

Editado por devair1010

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×