Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
JeHTSantos

como comparar duas celulas no excel e se for igual copiar uma outra celula

Recommended Posts

Bom dia Pessoal, preciso de ajuda

 

tenho duas abas Plan1 e Plan2

preciso comparar celula por celula da coluna B da plan1 com as celulas da coluna A da plan2, e se for igual, copiar a celula correspondente da coluna B plan2 para a coluna E plan1

 

Obrigada

Compartilhar este post


Link para o post
Compartilhar em outros sites

Simples, utiliza-se a função SE. A fórmula fica nas células da coluna E, plan1, e as células da coluna B, plan2, são argumentos caso VERDADEIRO.

 

Usarei a linha 1:

=SE(B1=Plan2!A1;Plan2!B1;"Não combina!")

Lembrando que "Não combina!" é o texto a ser mostrado caso não haja correspondência entre os valores comparados, ou seja, a resposta caso FALSO. Depois é só transpor a fórmula para as linhas seguintes até onde desejares.

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • Então.. nao deu certo..

     

    porque tem q procurar na coluna inteira da plan2 e quando achar copiar a celula da frente para o correspondente na plan1

     

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Nas células da Plan1, coluna E, tente esta fórmula:

     

    =SE(E(B:B=Plan2!A:A;B:B<>"";Plan2!A:A<>"");Plan2!B:B;"")

     

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    @JeHTSantos , funcionou com a fórmula que o colega @Edson Luiz Branco postou?

     

    @Edson Luiz Branco , poderias explicar como funciona a tua fórmula? Não tinha visto algo parecido até agora. Aprender sempre é bom.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    @Zeca Pagodinho, boa noite

     

    A fórmula faz o seguinte:

    Se cada célula de toda coluna B (B:B) desta planilha (planilha em que está a fórmula) for igual a cada célula correspondente na coluna A da Plan2 (Plan2!A:A)
       e também (função E) não for vazia (B:B<>"")
       e também (continuando função E) se cada célula de toda coluna A da Plan2 não for vazia (Plan2!A:A<>"")
    Então cada célula da coluna onde está a fórmula será igual à coluna B da Plan2 (Plan2!B:B)
    Senão será vazia ("")

    • Curtir 1

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Crie uma conta ou entre para comentar

    Você precisar ser um membro para fazer um comentário






    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×