Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
Guilherme Montelo

Conectar rede Wi-Fi Debian 9 Stretch modo texto

Recommended Posts

Prezados,

Estou tendo dificuldades em conectar uma instalação nova do Debian 9 Stretch sem interface gráfica a minha rede wi-fi, já instalei o firmware e o Debian reconhece a a placa de rede, porém quando tento usar o comando sudo apt-get update para testar a conexão apresenta erro, o mesmo não ocorre quando conectado através do cabo de rede.

Ao digitar o comando iwconfig a saída é


wlp6s0 IEEE 802.11 ESSID:off/any
Mode:Managed Aceess Point: Not-Associated Tx-Power=0 dBm
Retry short limit: 7 RTS thr=2347 B Fragment thr:off
Encryption key:off
Power Management:on

 

e meu /etc/network/interfaces

 

auto wlp6s0
iface wlp6s0 inet dhcp
wpa-ssid ********
wpa-psk ******************************************

 

quando digito ifup wlp6s0 apresenta o erro

 

ifup: unknow interface wlp6s0

 

lembrando que meu roteador está configurado como dhcp

Compartilhar este post


Link para o post
Compartilhar em outros sites

Recomendo usar o NetworkManager para isso. Plugue um cabo de rede temporariamente e instale-o caso necessário (pacote network-manager).

 

Depois, desative o ifupdown

 

systemctl disable --now networking.service

 

e habilite o NM

 

systemctl enable --now NetworkManager.service

 

Agora, em /etc/NetworkManager/NetworkManager.conf, na seção [ifupdown], troque managed=false por managed=true .

 

Por garantia, reinicie. Assim temos certeza que o NM estará no comando.

 

Por fim, use o nmcli para conectar à rede sem fio:

 

https://docs.ubuntu.com/core/en/stacks/network/network-manager/docs/configure-wifi-connections

 

Mais opções:

 

https://docs.fedoraproject.org/en-US/Fedora/25/html/Networking_Guide/sec-Connecting_to_a_Network_Using_nmcli.html

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • @Marcos FRM muito obrigado, funcionou perfeitamente!

    20170719_235914.jpg

    • Curtir 1

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Acho que o plugin ifupdown não salva as conexões em /etc/network/interfaces; apenas serve para o NM consultar quais interfaces estão listadas no arquivo e ignorá-las caso managed=false (que nós mudamos propositadamente para managed=true) . Portanto, se você quiser olhar onde o NM salva as conexões, olhe no diretório /etc/NetworkManager/system-connections.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Crie uma conta ou entre para comentar

    Você precisar ser um membro para fazer um comentário






    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×