Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Oliverrah Deleonn

VisuAlg Problema com código no Visualg

Recommended Posts

Bom galera, estou tentando fazer um programa para calcular imc no VisuAlg, quando eu executo o código dá problema na linha 26, (imagem do problema que dá mais abaixo), alguém poderia me ajudar, segue abaixo o código:

var
nome:caracter
peso,altura,imc2:real


inicio
// Seção de Comandos
escreval("Digite seu nome")
leia(nome)
escreval("Digite seu peso em KG")
leia(peso)
escreval("Digite sua altura em metros")
leia(altura)
imc2<-peso/(altura*altura)
escreval("Seu imc é de:" ,imc2)

se imc2 <18.5 então
   escreval("Você está abaixo do peso ideal")
fimse

se imc2 >=18.5 e imc2 <=24.9 então
   escreval("Você está no peso normal, parabéns!")
fimse

se imc2 >=25 e imc2 <=29.9 então
   escreval("Você está com sobrepeso")
fimse

se imc2 >=30 e imc2 <=34.9 então
   escreval("Você está com obesidade grau I")
fimse

se imc2 >=35 e imc2 <=39.9 então
   escreval("Você está com obesidade grau II")
fimse

se imc2 >=40 então
   escreval("Você está com obesidade grau III ou mórbida")
fimse


fimalgoritmo

 

Tela de erro:

96ivo4H.jpg

Editado por Simon Viegas
Inserir imagem na postagem
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
1 hora atrás, Oliverrah Deleonn disse:

se imc2 >=18.5 e imc2 <=24.9 então

Então cara , seu problema é o seguinte , o visualg identifica como erro a linha que contem duas condições quando elas então fora de parenteses , tente colocar assim se ((imc2>=........ )e (imc2......)) então ..... 
Caso o erro persista avise aqui .

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×