Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Marcela Zambrim Campanini

excel: seerro indice partes de um texto

Recommended Posts

Olá, tenho uma planilha (que chamo de "CAF") com o nome e a dosagem de medicamentos em uma coluna A e a quantidade na coluna B. O problema é que nao está escrito apenas o nome e a dosagem na coluna A, mas também outras informações como o lote.

Em outra aba (que chamo de "TESTE"), preciso somas as quantidades de cada medicamento IGNORANDO as informações como o lote. Ex: preciso somar os PARACETAMOL DE 500, que no exemplo daria 27 unidades. então para isso preciso buscar "PARACETAMOL" E "500" (que estão nas colunas A e B da aba "TESTE") na coluna A da aba CAF e somar as quantidades correspondentes na coluna B. Ao tentar a seguinte fórmula matricial na coluna C da aba "TESTE", ela fica em branco: =SEERRO(ÍNDICE(CAF!$B$1:$B$8;MENOR((CAF!$A$2:$A$8=$A$2&"*"&$B$2&"*")*LIN(CAF!$A$2:$A$8);SOMARPRODUTO(N((CAF!$A$2:$A$8=$A$2&"*"&$B$2&"*")*LIN(CAF!$A$2:$A$8)=0))+LIN()-1));"") . Cheguei a essa fórmula seguindo o seguinte tópico de um site: https://usuariosdoexcel.wordpress.com/2011/06/18/simulando-procv-com-multiplos-retornos/

 

E a falha está justamente nos trechos $A$2&"*"&$B$2&"*". Ou seja, ele nao me permite considerar as "abreviaturas".

 

Agradeço muito qualquer ajuda! 

Slide1.JPG

Slide2.JPG

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Marcela Zambrim Campanini Acho que deve ser mais simples que esta formula. Tenta colocar na célula C2 da aba TESTE a fórmula abaixo

 

=SOMASES(CAF!$B$2:$B$8;CAF!$A$2:$A$8;"*"&A2&"*";CAF!$A$2:$A$8;"*"&B2&"*")

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×