Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Gabriel Jansen

Exercício visualg não aparece o escreval

Recommended Posts

Escreva um programa que pergunte ao usuário dois números e diga se o primeiro é divisível pelo segundo ou não.

var
a,b :inteiro
inicio
escreval("indique dois números")
leia(a,b)
se a % b = 0  então
escreval(,a,"é divisível por ",b)
senao
escreval(,a,"não é divisível por ",b)
fimse
// Seção de Comandos 
fimalgoritmo

 

não aparece o escreva no comando

Editado por DiF
Botão CODE <>
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Gabriel Jansen

Você não pode ler dois valores ao mesmo tempo, sem o elemento ser um vetor e percorre-lo.

 

No seu caso declare  o leia duas vezes.

escreval("indique o número 1")
leia(a)

  escreval("indique o número 2")
leia(b)

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Gabriel Jansen    você colocou uma virgula dentro do parenteses no escreval  antes da variável e isso não permite que esse comando funcione, veja como ficaria seu código com algumas modificações :

Algoritmo "divisivel"
  var
    a,b :inteiro
  inicio
    escreval("indique dois números")
    leia(a,b)
    se a % b = 0  então
      escreval(a," é divisível por ",b)
    senao
      escreval(a," não é divisível por ",b)
    fimse
fimalgoritmo

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×