Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Gabriel S Muniz

VisualG Aceitando senha diferente da condição

Recommended Posts

Quando ponho nome = T e senha 9 o programa está aceitando. Por que está acontecendo isso ?

var
nome : caractere
senha, cont: inteiro
inicio
senha <- 0
cont <- 0

     enquanto cont< 3 faca
         escreval( "Digite seu login" )
         leia(nome)
         escreval ("Digite sua senha")
         leia(senha)

        se (nome <> "T") e (senha <> 99) então
           escreval("Senha invalida")
           cont <- cont+1;
        senao
           cont <- 3
        fimse

     fimenquanto
fimalgoritmo

 

Editado por DiF
Botão CODE <>

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá @Gabriel S Muniz. Seja bem vindo ao Fórum do Clube do Hardware.

Antes um aviso: para postar um código no Fórum, utilize a tag CODE. Basta clicar antes no botão "<>" e cola o código.

 

Vamos lá:

5 horas atrás, Gabriel S Muniz disse:

se (nome <> "T") e (senha <> 99) então

 

Resumidamente seria: você está usando o operador lógico "e", onde, deveria ser "ou".




 

Uma sugestão para uma verificação seria efetuar "testes de mesas". Poderia ser algo assim:
 

tabela_verdade.jpg

 

Fiz testes das 4 possibilidades possíveis. A coluna 5 é baseada na tabela verdade do "e", a coluna 6 seria "o que deveria acontecer"... ou seja, a "expressão lógica" contida no se (coluna 5) não está satisfazendo a sua necessidade (conferindo com o esperado). Ai teria que analisar o que está errado...

 

Então, quando deveria dar "Senha invalida"?

 

Deveria dar quando o "nome" está errado OU a "senha" está errada, ou seja, basta pelo menos um dos dois esteja errado para ser "senha inválida", mas no seu código você usou o e (quando ambos estão errados).

 

Sugiro que tente fazer essa mesma tabela no Excel (ou Word) usando o OU no lugar do E lá na coluna 5 e veja se vai conferir com a coluna 6.

 

 

Outro ponto importante é sempre manter o código bem indentado. Ex.:

 

var
   nome : caractere
   senha, cont: inteiro
inicio
senha <- 0
cont  <- 0
enquanto cont< 3 faca
   escreval( "Digite seu login" )
   leia(nome)
   escreval ("Digite sua senha")
   leia(senha)
   se (nome <> "T") e (senha <> 99) ENTÃO
      escreval("Senha invalida")
      cont <- cont+1;
   senao
      cont <- 3
   fimse
fimenquanto
fimalgoritmo


No aguardo.

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • 13 horas atrás, Simon Viegas disse:

    Olá @Gabriel S Muniz. Seja bem vindo ao Fórum do Clube do Hardware.

    Antes um aviso: para postar um código no Fórum, utilize a tag CODE. Basta clicar antes no botão "<>" e cola o código.

     

    Vamos lá:

     

    Resumidamente seria: você está usando o operador lógico "e", onde, deveria ser "ou".




     

    Uma sugestão para uma verificação seria efetuar "testes de mesas". Poderia ser algo assim:
     

    tabela_verdade.jpg

     

    Fiz testes das 4 possibilidades possíveis. A coluna 5 é baseada na tabela verdade do "e", a coluna 6 seria "o que deveria acontecer"... ou seja, a "expressão lógica" contida no se (coluna 5) não está satisfazendo a sua necessidade (conferindo com o esperado). Ai teria que analisar o que está errado...

     

    Então, quando deveria dar "Senha invalida"?

     

    Deveria dar quando o "nome" está errado OU a "senha" está errada, ou seja, basta pelo menos um dos dois esteja errado para ser "senha inválida", mas no seu código você usou o e (quando ambos estão errados).

     

    Sugiro que tente fazer essa mesma tabela no Excel (ou Word) usando o OU no lugar do E lá na coluna 5 e veja se vai conferir com a coluna 6.

     

     

    Outro ponto importante é sempre manter o código bem indentado. Ex.:

     

    
    var
       nome : caractere
       senha, cont: inteiro
    inicio
    senha <- 0
    cont  <- 0
    enquanto cont< 3 faca
       escreval( "Digite seu login" )
       leia(nome)
       escreval ("Digite sua senha")
       leia(senha)
       se (nome <> "T") e (senha <> 99) ENTÃO
          escreval("Senha invalida")
          cont <- cont+1;
       senao
          cont <- 3
       fimse
    fimenquanto
    fimalgoritmo


    No aguardo.

     

    13 horas atrás, Simon Viegas disse:

    Olá @Gabriel S Muniz. Seja bem vindo ao Fórum do Clube do Hardware.

    Antes um aviso: para postar um código no Fórum, utilize a tag CODE. Basta clicar antes no botão "<>" e cola o código.

     

    Vamos lá:

     

    Resumidamente seria: você está usando o operador lógico "e", onde, deveria ser "ou".




     

    Uma sugestão para uma verificação seria efetuar "testes de mesas". Poderia ser algo assim:
     

    tabela_verdade.jpg

     

    Fiz testes das 4 possibilidades possíveis. A coluna 5 é baseada na tabela verdade do "e", a coluna 6 seria "o que deveria acontecer"... ou seja, a "expressão lógica" contida no se (coluna 5) não está satisfazendo a sua necessidade (conferindo com o esperado). Ai teria que analisar o que está errado...

     

    Então, quando deveria dar "Senha invalida"?

     

    Deveria dar quando o "nome" está errado OU a "senha" está errada, ou seja, basta pelo menos um dos dois esteja errado para ser "senha inválida", mas no seu código você usou o e (quando ambos estão errados).

     

    Sugiro que tente fazer essa mesma tabela no Excel (ou Word) usando o OU no lugar do E lá na coluna 5 e veja se vai conferir com a coluna 6.

     

     

    Outro ponto importante é sempre manter o código bem indentado. Ex.:

     

    
    var
       nome : caractere
       senha, cont: inteiro
    inicio
    senha <- 0
    cont  <- 0
    enquanto cont< 3 faca
       escreval( "Digite seu login" )
       leia(nome)
       escreval ("Digite sua senha")
       leia(senha)
       se (nome <> "T") e (senha <> 99) ENTÃO
          escreval("Senha invalida")
          cont <- cont+1;
       senao
          cont <- 3
       fimse
    fimenquanto
    fimalgoritmo

    Boa noite, consegui entender... o se está entrando em verdade e ele entra no senao. Obrigado .

     

    meu primeiro post aqui tentei visualizar o CODE "<>" e não encontrei
    No aguardo.

     

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Crie uma conta ou entre para comentar

    Você precisar ser um membro para fazer um comentário






    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×