Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
George Rogner

VisualG Menor número digitado no Visualg

Recommended Posts

Boa noite alguém pode me ajudar com este algoritmo, onde está o erro

Algoritmo "O menor número digitado"

Var
   ContaNumero, NumeroDigitado, SomaNumero, MenorNumero: inteiro

Inicio
      ContaNumero <- 1
      Somanumero <- 0

      Enquanto ContaNumero <= 2 Faca
      Escreva("Digite o", ContaNumero,"º número: ")

      Leia(NumeroDigitado)

      Se ( NumeroDigitado < MenorNumero) então
     
      MenorNumero <- NumeroDigitado

      FimSe

      ContaNumero <- ContaNumero + 1
     
      SomaNumero <- SomaNumero + NumeroDigitado

      FimEnquanto

      EscrevaL("O menor número digitado foi ", MenorNumero)
      Escreva("Resultado da soma de todos os números é de ",SomaNumero)

Fimalgoritmo

 

Editado por DiF
Botão CODE <>

Compartilhar este post


Link para o post
Compartilhar em outros sites

Claro.

Boa noite. Use a lógica. Como vai haver comparação se não foi definido um valor inicial para a varável MenorNumero?

Ou você define um número impossível na inicialização ou guarda o primeiro elemento da entrada.

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • Achei a solução, muito grato
     

    Algoritmo "O menor número"
    
    Var
       ContaNumero, NumeroDigitado, SomaNumero, MenorNumero: inteiro
    
    Inicio
          ContaNumero <- 1
          MenorNumero <- 100000
          Enquanto ContaNumero <= 5 Faca
          Escreva("Digite o", ContaNumero,"º número: ")
          Leia(NumeroDigitado)
          Se ( NumeroDigitado < MenorNumero) então
          MenorNumero <- NumeroDigitado
          FimSe
          ContaNumero <- ContaNumero + 1
          SomaNumero <- SomaNumero + NumeroDigitado
          FimEnquanto
          EscrevaL("O menor número digitado foi ", MenorNumero)
          Escreva("Resultado da soma de todos os números é de ",SomaNumero)
    Fimalgoritmo
    Editado por Simon Viegas
    Inserir tag CODE e remoção de citação desnecessária

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Olá @George Rogner.

     

    Certinho! . Essa solução é justamente o @Math.Pi sugeriu...

     

    Apenas uns adendos:


    1) SOBRE "SOLUÇÕES"

    Em 09/09/2017 às 14:36, George Rogner disse:

    Achei a solução

    Na verdade seria "uma" solução... tecnicamente existem infinitas.

     

     


    2) ESTRUTURAS DE REPETIÇÕES
    A princípio o seu código está certo, mas levando pelas características do seu código e dos laços de repetições disponíveis na linguagem, talvez seja mais interessante trocar o enquanto por para, pois este último poderia controlar a variável ContaNumero automaticamente, ou seja, na própria estrutura do para.

     

     

    3) INDENTAÇÃO

    Um ponto importante na programação a indentação. Os códigos devem sempre está bem indentados. Ex.:

    Algoritmo "O menor número"
    Var
       ContaNumero, NumeroDigitado, SomaNumero, MenorNumero: inteiro
    
    Inicio
    ContaNumero <- 1
    MenorNumero <- 100000
    Enquanto ContaNumero <= 5 Faca
       Escreva("Digite o", ContaNumero,"º número: ")
       Leia(NumeroDigitado)
       Se (NumeroDigitado < MenorNumero) ENTÃO
          MenorNumero <- NumeroDigitado
       FimSe
       ContaNumero <- ContaNumero + 1
       SomaNumero <- SomaNumero + NumeroDigitado
    FimEnquanto
    EscrevaL("O menor número digitado foi ", MenorNumero)
    Escreva("Resultado da soma de todos os números é de ",SomaNumero)
    Fimalgoritmo

    Perceba que o quê está dentro do Enquanto fica um dente pra dentro, assim como o quê está dentro do se, vai um dente também...

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Crie uma conta ou entre para comentar

    Você precisar ser um membro para fazer um comentário






    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×