Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
LuisGCarv

VisualG Registro Dentro de Uma Matriz Bidimensional

Recommended Posts

Eu estou com alguns problemas pra fazer um programa que tenha um registro dentro de uma matriz com duas dimensões no VisualG. Eu consigo fazer registro com um vetor de boa, o problema só surge quando eu preciso de dois índices pra definir os elementos.

Segue o código do meu programa. O programa dá erro na linha que eu peço pra ler Automoveis.MAutomovel[i,j]

 

Algoritmo "MovimentacaoDeLocacao"
Tipo
Clientela = registro
     Codigo : inteiro
     NCliente : caractere
     Soma : real
fimregistro

Carros = registro
     MAutomovel : caractere
     ValorLoc : real
fimregistro

Var
// Seção de Declarações das variáveis 
Clientes : Vetor [1..100] de Clientela
Automoveis : Vetor [1..100,1..100] de Carros
i, j , n , p , class : inteiro

Inicio
// Seção de Comandos, procedimento, funções, operadores, etc...
escreval ("Digite o número de clientes a serem cadastrados :")
leia (n)
para i de 1 ate n faca
Clientes.Codigo[i] := i + 1000
escreval ("Digite o nome do cliente :")
leia (Clientes.NCliente[i])
escreval ("Digite o número de automóveis que o cliente pretende cadastrar :")
leia (p)
     para j de 1 ate p faca
     escreval ("Digite o nome da marca/modelo do ", j ,"° automóvel ")
     leia (Automoveis.MAutomovel[i,j])
     escreval ("Selecione a classificação do automóvel")
     escreval ("1 - Básico (R$ 80,00) ")
     escreval ("2 - Intermediário (R$ 150,00) ")
     escreval ("3 - Executivo (R$ 300,00) ")
     leia (class)
     escolha class
     caso 1
     Automoveis.ValorLoc[i,j] := 80,00
     caso 2
     Automoveis.ValorLoc[i,j] := 150,00
     caso 3
     Automoveis.ValorLoc[i,j] := 300,00
     outrocaso
     escreval ("Opção inválida!")
     j := j - 1
     fimescolha
     Clientes.Soma[i] := Clientes.Soma[i] + Automoveis.ValorLoc[i,j]
     limpatela
     fimpara
limpatela
fimpara
escreval ("CLIENTES CADASTRADOS")
escreval (" ")
para i de 1 ate n faca
escreval ("Código : C", Clientes.Codigo[i])
escreval ("Nome Do Cliente : ", Clientes.NCliente[i])
     para j de 1 ate p faca
     escreval ("Marca/Modelo do ", j ,"° Automóvel : ", Automoveis.MAutomovel[i,j])
     escolha Automoveis.ValorLoc[i,j]
     caso 80,00
     escreval ("Descrição Da Classificação : Básico ")
     escreval ("Valor Da Locação : R$ 80,00 ", )
     caso 150,00
     escreval ("Descrição Da Classificação : Intermediário ")
     escreval ("Valor Da Locação : R$ 150,00 ", )
     caso 300,00
     escreval ("Descrição Da Classificação : Executivo ")
     escreval ("Valor Da Locação : R$ 300,00 ", )
     fimescolha
     fimpara
escreval ("Valor Total Da Locação : R$ ", Clientes.Soma[i])
fimpara
Fimalgoritmo

 

É para um trabalho semestral que eu preciso entregar em no máximo duas semanas, então eu preciso resolver esse problema o mais rápido possível. Conto com a ajuda de vocês e agradeço desde já pela atenção.

Editado por LuisGCarv
Favor editar postagem e inserir o código utilizando a tag code (botão <>)
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá @LuisGCarv.

 

Você confundiu o vetor com um campo desse vetor (ou apenas está usando uma si). Ex.:

 

2 horas atrás, LuisGCarv disse:

Clientes.Codigo[i] := i + 1000
escreval ("Digite o nome do cliente :")
leia (Clientes.NCliente[i])
escreval ("Digite o número de automóveis que o cliente pretende cadastrar :")
leia (p)
     para j de 1 ate p faca
     escreval ("Digite o nome da marca/modelo do ", j ,"° automóvel ")
     leia (Automoveis.MAutomovel[i,j])

 

Veja como definiu:

Clientes : Vetor [1..100] de Clientela

Ou seja, Clientes é um vetor do tipo Clientela.  Na primeira linha, o Clientes é que é vetor. O NCliente é apenas um "campo", de uma posição desse vetor. Logo, serial algo assim:

Clientes[i].Codigo:=i + 1000

o mesmo para o restante, como por exemplo:

 

leia (Automoveis[i,j].MAutomovel)

A matriz está a esquerda.. uma posição dessa matriz tem o "campo" MAutomovel". Como tá lá no seu código, ficou como se Clientes fosse apenas uma variável comum, e um campo dele fosse uma matriz, entende?

 

 

ADENDO:

Sobre as nomenclaturas...

 

Para um campo de um registro, não precisa repetir a identificação... é implícita. Ex.:

Tipo
   Clientela = registro
      Codigo:inteiro
      Nome  :caractere //perceba que apenas se chamar de "Nome", para acessar usuário, por exemplo, "cliente[i].nome". Sei que esse nome é desse "objeto"
      Soma  :real
   fimregistro

   Carros = registro
      Nome     :caractere //aqui inserir propositalmente a mesma nomenclatura para demonstrar, mas ela não tema nada a ver com a outra... esse nome é do Carro... não vai haver duplicidade de variáveis, entende? Exemplo de acesso: "Carro[2].nome"
      Modelo   :caractere
      ValorLoc :real
   fimregistro

 

 

No aguardo.

  • Obrigado 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • @Simon Viegas , muito obrigado pelos esclarecimentos!

    O pior é que eu estava fazendo errado já faz algum tempo e eu nem sei porque, estou revendo na apostila e está da forma que você explicou, acho que foi pura falta de atenção. :mellow:

    adicionado 1 minuto depois

    Mas mesmo não tendo um vetor chamado NCliente, o programa aceitou daquela forma. Por quê?

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Crie uma conta ou entre para comentar

    Você precisar ser um membro para fazer um comentário






    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×