Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Gustavo vieirq

Duvidq em exercício sobre vetores

Recommended Posts

Boa tarde galera! 

Estou com duvida em uma questão espero que consigam me ajudar....tenho de fazer um algoritmo que  tenha 2 vetores;

Vet1[1..12]

Vet2 [1..12]

O usuario tem de inserir 12 numeros no vet 1 e no vet2.... depois de ler esses numeros preciso  identificar  se existe algum numero que ocupe a mesma posicao no  vet 1  e vet 2

Por exemplo ;

O numero 1 é um numero comum ao vet1 e vet2 e ocupa a posicao 10.

 

Espero que consigam me ajudar

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caro usuário,

 

Seja bem-vindo ao Fórum do Clube do Hardware.

 

No intuito de servir como fonte de pesquisa no caso de instituições de ensino, informamos que incorrer no resolvimento por completo de questões relacionadas a disciplinas escolares de cursos técnicos e faculdades podem ser revistas e removidas pela Equipe de Moderação do Clube do Hardware.

 

Para sanar dúvidas sobre esse tipo de problema, por gentileza, publique o passo a passo do desenvolvimento da questão, projeto, monografia ou conteúdo em dúvida para que possamos analisar se a resposta está correta ou não, ou para que possa ser auxiliado com a dúvida no desenvolvimento do exercício.

 

Infelizmente, não há como resolver os trabalhos pelos usuários. O objetivo do Fórum do Clube do Hardware é auxiliar seus usuários a encontrar soluções para que possam sanar suas dúvidas, e não de trazer soluções prontas para seus usuários.. Além disso, copiar e colar respostas que não são de autoria própria do qualquer usuário é considerado plágio, o que é ilegal.

 

Esperamos que compreenda.

 

Atenciosamente,

Equipe Clube do Hardware

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • Em 01/11/2017 às 14:18, Fabio Aragao disse:

    O que voce conseguiu fazer até agora ?

    Sim iniciei mais da erro e nao consigo udentifica o porque....to fazendo do jeito certo? o que ta errado?

    var:
    N; vetor [1..12] de inteiro
    N2:vetor [1..12] de inteiro
    I,x,i2;inteiro
    Para i de 1 ate 12 faca
    Escreval ("digite um numero")
    Leia (n
    Fimpara

    20171101_171529.thumb.jpg.452af3118d05312dd8de11c9f4ab4476.jpg

    adicionado 2 minutos depois
    Em 01/11/2017 às 14:58, Simon Viegas disse:

    Caro usuário,

     

    Seja bem-vindo ao Fórum do Clube do Hardware.

     

    No intuito de servir como fonte de pesquisa no caso de instituições de ensino, informamos que incorrer no resolvimento por completo de questões relacionadas a disciplinas escolares de cursos técnicos e faculdades podem ser revistas e removidas pela Equipe de Moderação do Clube do Hardware.

     

    Para sanar dúvidas sobre esse tipo de problema, por gentileza, publique o passo a passo do desenvolvimento da questão, projeto, monografia ou conteúdo em dúvida para que possamos analisar se a resposta está correta ou não, ou para que possa ser auxiliado com a dúvida no desenvolvimento do exercício.

     

    Infelizmente, não há como resolver os trabalhos pelos usuários. O objetivo do Fórum do Clube do Hardware é auxiliar seus usuários a encontrar soluções para que possam sanar suas dúvidas, e não de trazer soluções prontas para seus usuários.. Além disso, copiar e colar respostas que não são de autoria própria do qualquer usuário é considerado plágio, o que é ilegal.

     

    Esperamos que compreenda.

     

    Atenciosamente,

    Equipe Clube do Hardware

    Sim entendo....me expressei mal acho eu.... to fazendo o mesmo porém to com duvida se da maneira certa....agora ja postei o modo que fiz para ver se alguem me da uma luz...

    Editado por Simon Viegas
    Ao postar um código, antes pressione o botão "<>" na barra de ferramentas

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    voce está fazendo um PARA apenas e preenchendo 1 vetor

     

    voce tem que fazer um PARA dentro de outro PARA e com isso preenchendo os dois vetores.

     

    Depois de preencher os dois vetores voce faz uma busca comparada em ambos com o SE e pode armazenar o resultado em outro vetor.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • Em 01/11/2017 às 20:58, Fabio Aragao disse:

    voce está fazendo um PARA apenas e preenchendo 1 vetor

     

    voce tem que fazer um PARA dentro de outro PARA e com isso preenchendo os dois vetores.

     

    Depois de preencher os dois vetores voce faz uma busca comparada em ambos com o SE e pode armazenar o resultado em outro vetor.

     

    Mais eu usei  2x o para

    Para i de 1 ate 12 faca
    Escreval ("digite um numero")
    Leia (n )
    Fimpara
    Para i2 de 1 ate 12 faca
    Escreval ('digite um numero")
    Leia (n2 [i2]
    Fimpara
    Para x de 1 ate 12 faca
    Se (i=i2)e (n =n[i2])então
    Escreval(n ,n2 [i2])
    Finse
    Fimpara

     

     

    Editado por Simon Viegas
    Inserir tag CODE

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Use um PARA dentro do outro e preencha os vetores

    para i de 1 ate 12 faca

    para j de 1 ate 12 faca

    fimpara

    fimpara

    • Curtir 1

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • 12 horas atrás, Fabio Aragao disse:

    Use um PARA dentro do outro e preencha os vetores

    para i de 1 ate 12 faca

    para j de 1 ate 12 faca

    fimpara

    fimpara

    valeu consegui

    • Curtir 1

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Olá @Gustavo vieirq.

     

    Por favor, posta o código completo para analisarmos.

     

     

    obs.: favor usar a tag CODE. Basta clicar no botão <> e colar o código.

     

    No aguardo.

     

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Crie uma conta ou entre para comentar

    Você precisar ser um membro para fazer um comentário






    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×