Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Luiz Felippe Vieira

VisualG Erro sem motivo aparente

Recommended Posts

Algoritmo "bnct"

// Um banco concederá um crédito especial aos seus clientes,
//variável com saldo médio no último ano. Faça um algoritmo que leia
//o saldo médio de um cliente e calcule o valor do crédito de acordo com a
//tabela abaixo. Mostre uma mensagem informando o saldo médio e o valor de
//crédito (a porcentagem aplicada sobre o saldo médio).

Var
   // Seção de Declarações das variáveis

   sma:inteiro;
   zporct,vtporct,trtporct,qrtporcent:real;

Inicio
   // Seção de Comandos, procedimento, funções, operadores, etc...

   escreval("Qual o saldo médio anual do cliente?")
   leia(sma)

   se (sma <= 200) então
      zporct <- sma * 0.00
      escreval("Crédito total oferecido para o saldo de R$",sma," é ",zporct)
   senao

      se (sma => 201 e sma=<400) então
         vtporct <- sma * 0.20
         escreval("Crédito total oferecido para o saldo de R$",sma," é ",vtporct)
      senao

         se (sma => 401 e sma=<600) então
            trtporct <- sma * 0.30
            escreval("Crédito total oferecido para o saldo de R$",sma," é ",trtporct)
         senao

            se (sma => 601) então
               qrtporcent <- sma * 0.40
               escreval("Crédito total oferecido para o saldo de R$",sma," é ",qrtporcent)
            senao
            fimse
         fimse
      fimse
   fimse

Fimalgoritmo

 

Quando eu coloco valor acima de 201 da o erro.

erro.JPG

dsa.JPG

Editado por Simon Viegas
Favor ler tópico e seguir orientações sobre POSTAGEM DE CÓDIGOS: http://www.clubedohardware.com.br/announcement/27-poste-seus-c%C3%B3digos-corretamente/

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá @Luiz Felippe Vieira.

 

1) cada sentença do se tem que ficar entre parênteses. Algo como:

se (xxx) e (yyy) então

 

2) O correto seria ">=" e "<=". O igual vem depois.

 

No aguardo.

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • 2 minutos atrás, Simon Viegas disse:

    Olá @Luiz Felippe Vieira.

     

    1) cada sentença do se tem que ficar entre parênteses. Algo como:

    
    se (xxx) e (yyy) então

     

    2) O correto seria ">=" e "<=". O igual vem depois.

     

    No aguardo.

    Funcionou, valeu, nao sabia disso do = e dos parênteses.

    • Curtir 1

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Crie uma conta ou entre para comentar

    Você precisar ser um membro para fazer um comentário






    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×