Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Entre para seguir isso  
napadark

Função SE: Comparação

Recommended Posts

Quem for fera no excel me ajude:

Preciso utilizar a função SE nesta comparação:

até 700 = 8% (d4)

de 700,01 a 780,00 = 9%...(d5)

eu sei q para colocar a 1ª comparação é assim:

=se(C4<=700;D4*8%.....

mas para colocar 2 valores em um mesmo termo

já tentei assim:

=se(C4<>700,01a 780.....

e tentei de outras formas mas não deu certo

Nota: Eu quero colocar: Se a célula C4 possuir valor ENTRE 700,01 e 780,

D5*9%.

se alguem puder ajudar-me eu agradeço!!!!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom eu tentei.......mas você não precisa colocar D4 ou D5 vezes a porcentagem porque a célula que vai ser utilizada é a C4..., assim:

=SE(C4="";"";SE(C4<=700;C4*8%;SE(C4>780;" ";C4*9%))

A explicação é assim: SE C4 estiver em branco a célula do resultado vai ficar em branco, SE C4 FOR MENOR ou IGUAL a 700 o resultado vai ser C4*8%, SE C4 for MENOR que 780 a célula do resultado vai ficar me branco, SE C4 não for MENOR ou IGUAL a 700, nem MAIOR que 780, ou seja, C4 for ENTRE 700 e 780 o resultado vai ser C4*9%.

Eu coloquei essas condições pra célula ficar em branco pra não aparecer zero se não for colocado nada na célula. Eu entendi que você queria assim.

=SE(C4<=700;D4*8%;SE(C4>780;"";D5*9%)).....Essa é a Fórmula que você fez arrumada de acordo com o q você pediu... :tantan:

Se possível me dê um toque se deu certo ou não...para eu poder verificar....

mara.heart

:bye:

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • A tabela é a seguinte:

    é uma coluna de INSS desse modo:

    INSS

    Até R$ 700,00 7,65%

    De R$ 700,01 até R$ 780,00 8,65%

    De R$ 780,01 até R$ 1253,36 9,00%

    Acima de R$ 1253,37 11,00%

    Sendo a célula relacionada C4 Possuir um valor fictício: O salário do funcionário.

    Exemplo: se C4 está 745,00 a celula da coluna do INSS tem q fazer uma operação

    q seja o valor de C4 * 8,65%.

    Espero ter explicado melhor, qualquer dúvida poste ai!

    Nota: ainda não testei a sua proposta!!!!

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    considerando B15 a célula em análise, digite em C15:

    =SE(E(B15>0;B15<700,001);7,65%;SE(E(B15>=700,01;B15<780,001);8,65%;SE(E(B15>=780,01;B15<1253,361);9%;SE(B15>1253,36;11%;""))))

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Com base nos dados q você meu forneceu cheguei a essa fórmula.....

    =SE(E(C4>0;C4<=700);C4*7,65%;SE(E(C4>700;C4<=780);C4*8,65%;SE(E(C4>780;C4<=1253,36);C4*9%;SE(C4>=1253,37;C4*11%;""))))

    Tente...se não der me avise......

    Lembre-se: sempre q precisar estarei pronta para te ajudar, se puder;

    :bye:

    mara.heart

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • Obrigadão Mara.heart deu certo!!! :D

    Mas, à propósito o q significa a letra E na formula SE?

    Obrigado mais uma vez!!!

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
    Visitante

    Acho que posso responder a isso... a letra E na fórmula faz justamente aquilo que você pediu, permite a comparação entre dois parametros distintos, permitindo que a função SE desempenhe o seu papel da forma como você queria...

    Agora uma pequena correção de ordem legal a fórmula, de acordo com a legislação pertinente a tabela para calculo do INSS desde 1º de Maio de 2004 não é sobre estes valores e existe, ainda, um teto para recolhimento e/ou desconto da contibuição, ou seja, os dados para o calculo estão errados e por tal motivo a formula está incompleta... O limite de recolhimento atual é de R$ 275,96, independente do valor base, sendo assim, seria preciso incluir mais um item a fórmula sugerida. Abaixo trancrevo a formula sugerida com os valores adequados.

    =SE(E(A2>0;A2<=752,62);A2*7,65%;SE(E(A2>752,63;A2<=780);A2*8,65%;SE(E(A2>780,01;A2<=1254,36);

    A2*9%;SE(E(A2>=1254,37;A2<=2508,72);A2*11%;SE(A2>=2508,73;275,96)))))

    Contudo e apenas por curiosidade... não precisaria de uma fórmula como esta para esse calculo, apenas com o uso da função de condição (SE()) seria possivel ter o mesmo resultado, só é preciso seguir uma lógica na montagem dela... veja abaixo como seria:

    =SE(A3<=752,62;A3*7,65%;SE(A3<=780;A3*8,65%;SE(A3<=1254,36;A3*9%;SE(A3<=2508,72;

    A3*11%;SE(A3>=2508,73;275,96)))))

    Obs: Nos dois casos tive de quebrar a fórmula em duas linhas para preservar o layout do fórum...

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • Valeu pela dica José mas a coluna do INSS fazia parte de um trabalho meu num curso de informática, ou seja, era apenas fictícia mas agradeço novamente pelo lembrete!!!!

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
    Visitante

    No problems... é que sou contador, então já viu... e como você não havia especificado que eram apenas valores ficticios, fui logo colocando o que é correto...

    Bom, já que seu problema está resolvido. Tópico encerrado, o mesmo será reaberto caso seu originador ache necessário.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
    Visitante
    Este tópico está impedido de receber novos posts.
    Entre para seguir isso  





    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×