Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Entre para seguir isso  
jfscoelho

Formulas Excel

Recommended Posts

Ola a todos

Queria pedir a vossa ajuda para um problema com uma formula em excel que e o

seguinte:

Tenho um horario com os dias do mes em que no final na celula AM11 me

aparece o somatorio das horas do mes que neste caso corresponde a 126 horas

e o funcionario fez 162 horas que me aparece na celula AL11. Depois ha ainda

uma coluna AN11 em que podem existir horas atrasadas ou não. O funcionario

fez um excedente de 36 horas que queria transformar em turnos de 7,5 horas

que daria 4 turnos que iriam cair na celula AP11 (4 turnos que equivalem a

30 horas, e ficariam a sobrar 6 horas que não chegam para um turno e queria

que estas horas passassem para a celula AO11 e mostrar-me como horas so que

não sei como elaborar estas formulas. Se alguem puder ajudar, desde já os

meus agradecimentos.

Atenciosamente.

Fernando

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • Numa determinada celula cujo valor pode ser 36 horas transformar em turnos de 7.5 horas. Daria 4 turnos (4 x 7.5 =30) e ficariam a sobrar 6 horas que pretendia caissem numa outra celula

    Atenciosamente

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Ai vai.

    A1 = 36

    A2 = 7,5

    C1=((A1/A2)-INT(A1/A2))*A2

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • Ola.

    Desja já obrigado pela resposta

    já consegui parcialmente resolver o problema, mas ainda com uma duvida que passo a explicar:

    Coloquei na celula AP11 a formula com esta pequena alteraçao

    = SE(RESTO(AL11-AM11+AN11;7,5)>=0;QUOCIENTE(AL11-AM11+AN11;7,5);"")

    e na celula AO11 esta =RESTO(AL11-AM11+AN11;7,5)

    Faltava tambem instalar um suplemento o Analyses Toolpak.

    Agora surge-me uma outra duvida na celula AN11 podem existir horas que podem ser negativas ou positivas, se forem positivas faz a soma correctamente, mas se forem negativas não faz a devida subtracçao EX: -3.5 + 1.5 deveria dar -2 e não devolve o resultado de 5.

    Sera que me conseguem ajudar a contornar o problema.

    Desde já muito obrigado.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Olá.

    voce está complicando as coisas.

    Nesta expressão: = SE(RESTO(AL11-AM11+AN11;7,5)>=0;QUOCIENTE(AL11-AM11+AN11;7,5);"")

    a parte em cor azul SEMPRE será positiva.

    Logo voce não precisa usar a expressão condicional SE (está chovendo no molhado).

    Nesta outra expressão: "na celula AO11 esta =RESTO(AL11-AM11+AN11;7,5)"

    você está esperando algumas vezes dar resultado negativo.

    Isto NUNCA vai acontecer usando a expressão RESTO (pois mesmo que o resultado dentro da expressão RESTO seja negativo, esta expressão transforma-o em positivo).

    Espero ter ajudado.

    Abraços

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Crie uma conta ou entre para comentar

    Você precisar ser um membro para fazer um comentário

    Entre para seguir isso  





    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×