Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Entre para seguir isso  
antnoia

Ajuda com algoritmos

Recommended Posts

to com algumas duvidas sobre isso espero que possam me ajudar

1 Construa um algoritmo que receba a idade do usuário e verifique se ele tem mais de 21 anos.

2 Construa um algoritmo que receba três números inteiros e verifique qual o maior.

3 Construa um algoritmo que calcule o peso ideal de uma pessoa. Dados de entrada: altura e sexo. Fórmulas para cálculo do peso:

peso ideal de homem = (72,7 x altura) - 58

peso ideal da mulher = (62,1 x altura) - 44,7

nesse primeiro minha duvida é: no portugol se escreve "se" ou "if" e "senão" ou "ifelse" ?

1: início

inteiro: idade;

imprimir("Qual a sua idade ?");

ler(idade);

se(idade>=21)

imprimir("Você é de maior !!!.");

senão

imprimir("Você é de menor !!!.");

fimse;

fim

esse algoritmo esta mesmo correto? precisa desse "fimse" e depois "fim" de novo?

2. início

inteiro nr1, nr2, n3;

imprimir("Entre com o primeiro número :");

ler(nr1);

imprimir("Entre com o segundo número :");

ler(nr2);

imprimir("Entre com o terceiro número :");

ler(nr3);

se(nr1 > nr2)

se(nr2 > nr3)

imprimir("O ", nr1, " é o maior.");

senão se(nr1 > nr3)

imprimir("O", nr1, "é o maior.");

senão

imprimir("O", nr3, "é o maior.");

fimse;

senão se(nr2 > nr3)

imprimir("O", nr2, "é o maior.");

senão

imprimir("O", nr3, "é o maior.");

fimse;

fim

mesma coisa, precisa de tanto "fim"?

3. início

inteiro: sexo;

real: peso, altura;

imprimir("Sexo (1. Homem 2. Mulher) :");

ler(sexo);

se((sexo<1) ou (sexo>2)) /* analisa se escolha de sexo é válida */

imprimir("Opção de sexo inválida !!!");

senão

início

imprimir("Qual sua altura ?");

ler(altura);

se (sexo = 1) /* usuário é homem */

peso <== (72,7 * altura) -58;

senão /* usuário é mulher */

peso <== (62,1 * altura) - 44,7;

fimse;

imprimir("Seu peso ideal é ", peso);

fim;

fimse;

fim

Compartilhar este post


Link para o post
Compartilhar em outros sites

no portugol é SE e SENÃO

e tabém.. fique atenta que no exercício 1 ele pergunta se o individuo é MAIOR que 21.. então você não usa o sinal >= e sim somente >

by

and.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá pessoal eu estou com um pequeno problema.

Preciso de um fluxograma para esse algoritmo:

Se cRa > cR2 Então

Se cRa > cR3 Então

MsgBox "O valor maior "

Mostra cRa

Senão

MsgBox " Valor maior "

Mostra cR2

Fim Se

Senão

Se cR2 > cR3 Então

MsgBox "Valor maior "

Mostra Cr3

Senão

MsgBox "Valor maior "

Mostra Cr5

Fim Se

Fim Se

Se cR4 < cR7 Então

Se cRr < cR8 Então

MsgBox "Valor menor "

Mostra cR4

Senão

MsgBox " Valor menor "

Mostra cRf

Fim Se

Senão

Se cCc <cRa Então

MsgBox " Valor menor "

Mostra cFt

Senão

MsgBox "Valor menor "

Mostra iDr

Fim Se

Fim Se

Me ajude por favor

obrigado.

Editado por thonga

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • estou fazendo em c, usando o dev c++ esse ai agora eu já manjei como é, ta difícil agora estrutura de repetição em c, não to entendendo muito bem, se alguem souber onde posso baixar uma apostila sobre o assunto eu agradeço. valeu galera

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    1. Não! Com o próprio nome diz, é Portugol (aglutinação: Português + Algoritimos), então, todo e qualquer código deve ser escrito em português. Preste atenção nesse exemplo:

    Se <condição>
    então <comando>
    Senão se <condição>
    então <comando>
    Senão
    <comando>
    Fim_se

    Onde, Se = If, então = Then, Senão se = Elsif, Senão = Else.

    2. Sim, carece sim, pois toda condição deve ter um fim, senão, englobará o código inteiro, e todo código deve ter um fim, então, usa-se desses dois códigos.

    Mas, as coisas erradas que você fez foi:

    - Neglicenciar a partícula então.

    -

    Não se coloca ponto e vírgula numa estrutura que antecede o fim do código, pois não haverá continuação! Óbvio!

    3. Precisa sim, mesmo motivo anterior.

    PS: Comentários em Portugol se escreve com chaves {} e não com /* como no C.

    PS: Atribuição em Portugol é feita com <- ou := e não com <== que nos indicia a um sinal comparativo.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Pessoal como eu elaboro um algoritmo que leia o valor de tres numeros inteiros e verifique se sua soma é maior que 100. Se for, deve ser exibida uma mensagem informativa. como eu elabora esse algoritmo?

    Editado por Karenoliveyra

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • Pessoal como eu elaboro um algoritmo que leia o valor de tres numeros inteiros e verifique se sua soma é maior que 100. Se for, deve ser exibida uma mensagem informativa. como eu elabora esse algoritmo?

    var

    a,b,c :inteiro

    inicio

    escreva("Dê tres valores");

    leia(a,b,c);

    se (a+b+c>100)

    escreva("aviso!!");

    senao

    escreva("");

    fimse

    fim

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    pessoal como elaboro um algoritmo que leia o valor de um numero e , em seguida informe se esse numero é divisivel por 10, 5 , 2 ou se não é divisivel por nenhum desses numeros. Como eu elaboro ?

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Crie uma conta ou entre para comentar

    Você precisar ser um membro para fazer um comentário

    Entre para seguir isso  





    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×