Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Entre para seguir isso  
mutek

[Ajuda] Com Algoritmo

Recommended Posts


cafe,salgado,lanche,refrigerante,doce,torta : inteiro
Total : real
fimregistro

Var

mesas: vetor [1..5,1..6] de inteiro
it: vetor [1..5,1..6] de itens
op,x,y,cont,aux: inteiro
op2,op3,res: caracter

Inicio

repita
Escreval ("Digite a mesa a ser buscada")
Escreval ("Cordenada x:")
leia (x)
Escreval ("Cordenada y:")
leia(y)
se (x <= 5) e (y <= 6) então
Escreval ("1 - Adicionar Item")
Escreval ("2 - Fechar conta")
Escreval ("3 - Irpara outra mesa")
Leia (op3)
se (op3=1) então
repita
Escreval ("Lista")
Escreval ("1 - Café")
Escreval ("2 - Salgado")
Escreval ("3 - Lanche")
Escreval ("4 - Refrigerante")
Escreval ("5 - Doce")
Escreval ("6 - torta")
Escreval ("O que você deseja adicionar a lista?")
leia (op)
Escreval ("Qual a quantidade do item ",op," ?")
leia(aux)
Escolha (op)
Caso 1: it[x,y].total<- it[x,y].total+(aux*1.50)
it[x,y].cafe<- it[x,y].cafe + aux
Caso 2: it[x,y].total<- it[x,y].total+(aux*2.50)
it[x,y].salgado<- it[x,y].salgado + aux
Caso 3: it[x,y].total<- it.total[x,y] + (aux*5.50)
it[x,y].lanche<- it[x,y].lanche + aux
Caso 4: it[x,y].total<- it[x,y].total + (aux*2.00)
it[x,y].refrigerante<- it[x,y].refrigerante + aux
Caso 5: it[x,y].total<- it[x,y].total + (aux*2.50)
it[x,y].doce<- it[x,y].doce + aux
Caso 6: it[x,y].total<- it[x,y].total + (aux*4.30)
it[x,y].torta<- it[x,y].torta + aux
outrocaso: Escreval ("Codigo errado amigo, leia bem")
Escreval ("Deseja fazer outro pedido cara ? S/N")
leia (op2)
ate op2 = "N"
senao
se op=2 então
Escreval ("Itens pedidos da mesa",x,y)
Escreval ("Café: Unidade R$1,50 TOTAL:", it[x,y].cafe)
Escreval ("Salgado: Unidade R$2,50 TOTAL:", it[x,y].salgado)
Escreval ("Lanche: Unidade R$5,50 TOTAL:", it[x,y].lanche)
Escreval ("Refrigerante: Unidade R$2,00 TOTAL:", it[x,y].refrigerante)
Escreval ("Doce: Unidade R$2,50 TOTAL:", it[x,y].doce)
Escreval ("Torta: Unidade R$4,30 TOTAL:", it[x,y].torta)
Escreval ("TOTAL GERAL: ", it[x,y].total)
it[x,y].cafe <- 0
it[x,y].salgado <- 0
it[x,y].lanche <- 0
it[x,y].refrigerante <- 0
it[x,y].doce <- 0
it[x,y].torta <- 0
it[x,y].total <- 0
senao
se op3=3 então
ate op3 = 3
fimse
fimse
fimse
senao
Escreval ("Erro")
fimse
Escreval ("Deseja ir para conta de outra mesa ?S/N")
leia (res)
ate res="N"
fimalgoritmo
tipo itens = registro

Gostaria de saber se está totalmente correto?

Editado por Goliathvv
Utilize as tags [code] e [spoiler] para destacar o trecho de código e tornar o texto mais legível. Obrigado.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Entre para seguir isso  





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×