Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
gabriela_goes

Capacitor de botstrap e charge-pumping techniques

Recommended Posts

Bom dia pessoal, estou lendo um datasheet e alguns termos aparecem,

gostaria de saber o que é

-o que é capacitor de bootstrap?

-o que são charge-pumping techniques?

em termos fáceis por favor..

Obrigado

Compartilhar este post


Link para o post
Compartilhar em outros sites
Bom dia pessoal, estou lendo um datasheet e alguns termos aparecem,

gostaria de saber o que é

-o que é capacitor de bootstrap?

-o que são charge-pumping techniques?

em termos fáceis por favor..

Obrigado

bootstrap

Processo electronico que visa incrementar a impedancia de entrada de um circuito

usado tambem para aumentar amplitude dos sinais de saida

http://web.telia.com/~u43200663/blocks/bootstrapping.htm

charge-pumping techniques

tecnologia usada por exemplo em conversores dc-dc sem uso de elementos indutivos

veja por exemplo o max232

neste ic para se gerarem as tensoes necessarias as normas rs232

e usado este metodo

outro exemplo e o MAX1683

http://www.maxim-ic.com/appnotes.cfm/an_pk/725

http://en.wikipedia.org/wiki/Charge_pump

tambem usada em circuitos pll

phase frequency detector with charge pump

Editado por oceano

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • Obrigado pelas informações, já entendi o que é charge-pumping porém bootstrap ainda esta meio confuso. O link que você passou fala sobre seu uso em amplificadores, mas não consigo ver a relação disso com meu projeto.

    O texto abaixo extrai do datasheet do CI HIP4081AIP(que acabei encontrando)

    O CI serve de driver para pontes H com Mosfet

    pin1 = High-side Bootstrap supply. External bootstrap diode and capacitor are required. Connect cathode of bootstrap

    diode and positive side of bootstrap capacitor to this pin. Internal charge pump supplies 30mA out of this pin to maintain bootstrap supply. Internal circuitry clamps the bootstrap supply to approximately 12.8V.

    O texto menciona um capacitor e um diodo, porém não explica como calcular o valor dos mesmos, alguém tem alguma ideia? Imagino que os valores tenham alguma relação com o Mosfet que estou usando, no caso o IRF1404

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Vou tentar deixar mais fácil ...

    Bootstrap é uma técnica de realimentação, que acaba aumentando enormemente a imperdãncia de um circuito.

    Como exemplo , alguns circuitos de entrada de amplificadores ou pré-amplificadores possuem um capacitor ligado meio esquisito, que vai tipo entre a base e um arranjo de resistores ligados no coletor de um mesmo transistor, o efeito de realimentação que acaba ocorrendo diminui a corrente necessária na base do transistor, o que equivale à impedância de entrada ficar bem maior do que era sem o capacitor.

    Charge-pumping , funciona mais ou menos assim, a energia é enviada em " pacotes" para um capacitor, aos poucos, e ele vai armazenando essa energia, até que chega a um limite e ocorre a descarga completa dessa enenrgia de uma só vez.

    Normalmente existe um circuito chaveador, que a cada vez envia um pouco de carga. A tradução literal desse termo é "bombeando carga" ....

    Paulo

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
    Obrigado pelas informações, já entendi o que é charge-pumping porém bootstrap ainda esta meio confuso. O link que você passou fala sobre seu uso em amplificadores, mas não consigo ver a relação disso com meu projeto.

    O texto abaixo extrai do datasheet do CI HIP4081AIP(que acabei encontrando)

    O CI serve de driver para pontes H com Mosfet

    pin1 = High-side Bootstrap supply. External bootstrap diode and capacitor are required. Connect cathode of bootstrap

    diode and positive side of bootstrap capacitor to this pin. Internal charge pump supplies 30mA out of this pin to maintain bootstrap supply. Internal circuitry clamps the bootstrap supply to approximately 12.8V.

    O texto menciona um capacitor e um diodo, porém não explica como calcular o valor dos mesmos, alguém tem alguma ideia? Imagino que os valores tenham alguma relação com o Mosfet que estou usando, no caso o IRF1404

    julgo que vai ter de estudar bem o CI

    para isso recomendo o site da Intersil por exemplo e verificar se tem ANotes ou outra informaçao valida para o seu caso

    em ultimo caso pode mesmo ter que contactar o fabricante e pedor ajuda com as suas duvidas

    http://www.intersil.com/products/deviceinfo.asp?pn=HIP4081A

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • tudo bem, entendi as técnicas na teoria, mas como calcular os valores na pratica?

    e até agora nenhuma resposta do site da empresa..

    mandem qualquer coisa que acharem certo, mesmo que não tenham certeza, qualquer coisa ajuda, to pra ligar o primeiro diodo que me aparecer, (provavelmente o 1N4148) e o primeiro capacitor que me aparecer, depois vou mudando os valores e vendo o que acontece, é uma má ideia?

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    usei num ic semelhante esta combinaçao

    diodo MUR120

    cap- condensador de 22uf em paralelo com 0.1uF

    se bem vi para o seu ic é requerido

    MBRS1100T3 e condensador de 0.1uF

    mas confirme

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    No caso do HIP o circuito de bootstrap serve pra auxiliar o circuito de bombeamento de carga. Quando os mosfets inferiores da ponte H são ativados os diodos de bootstrap carregam os capacitores aos quais são ligados. Assim que estes mosfet entram no corte (juntamente com os mosfets superiores sendo ativados) o negativo dos capacitores é elevado até o potencial de alimentação dos fets (não o do HIP que geralmente é algo entre 12 e 15V). Desta forma é possível o HIP entregar aos gates uma tensão de cerca de 10V a mais que a alimentação dos fets, que é uma condição necessária pra manter Vgs =~ 10V, já que nesta situação a tensão do "source" vai pra um valor bem próximo dessa tensão de alimentação a que me referi...

    Ou seja, se essa alimentação é de 24V, Vs=~24V, e o HIP é capaz de entregar Vg =~ 34V. Assim Vgs = Vg - Vs =~ 10V.

    Edit: eu uso um capacitor eletrolítico de 1uF e um 1N4148 mesmo, já que estou chaveando o circuito a 2 KHz. Se a frequência do seu PWM for muito mais alta que isso vale a pena usar diodos schottky (por exemplo o 1n5822) e talvez uns capacitores cerâmicos.

    Editado por Lokasso

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • bom, coloquei o capacitor de 1uF e como diodo coloquei dois do 1N4007 em paralelo. O circuito funcionou e pode ser controlado pela lógica do pic, porém os mosfets estão esquentando muito. No meu teste os mosfets chavearam ~3A porém apos uns 30 segundos dava pra sentir o cheiro deles esquentando.

    Segui o projeto que tem no datasheet do HIP, porém coloquei resistores de Pull-Down de 1k nos mosfets, pra garantir que eles só conduzam quando receberem sinal, foi errado fazer isso? pode ser esse o problema do super-aquecimento?

    o que mais pode estar fazendo ele aquecer?

    obrigado a todos pela ajuda! sinto que to quase conseguindo

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Teria como você postar o circuito exato (detalhando os valores dos componentes e quais pinos do HIP você está acionando)?

    Os resistores não são necessários, a menos que você tire o HIP do circuito. Já queimei uns mosfets tirando o HIP e encostando o dedo nos gates, sem querer... não foi nada legal =/

    Ah, também não precisa de dois diodos em paralelo não, um dá e sobra.

    Editado por Lokasso

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    nao sei se o diodo 1N4007 funciona

    depende da aplicaçao e da frequencia de comutaçao

    no circuito que usei, membora com ci diferente, para fonte sps e com freq de 100kz nem pensar

    so com diodos fast recover

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
    nao sei se o diodo 1N4007 funciona

    depende da aplicaçao e da frequência de comutaçao

    no circuito que usei, membora com ci diferente, para fonte sps e com freq de 100kz nem pensar

    so com diodos fast recover

    Concordo com o oceano. Dependendo da frequência que você utilizar o 1N4007 pode não ser adequado.

    No meu caso a frequência era baixa (2 kHz), então o 1N4148 que usei deu conta fácil.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    correcto Lokasso

    realmente agora só mesmo com o circuito e carga como disse atras e isto esta nas maos da gabriela_goes

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Se o PWM que estiver usando for de frequencia elevada, esqueça, so diodos schottky para resolver, mas acho que nao é o caso, pois para acionar um motor nao é necessario um pwm de elevada frequencia, algo em torno de 600hz geralmente e o bastante, deve se verificar seo HIP esta respondendo aos comandos do PIC, veja a frequencia maxima de chaveamento deste!

    abs.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Segui o projeto que tem no datasheet do HIP, porém coloquei resistores de Pull-Down de 1k nos mosfets, pra garantir que eles só conduzam quando receberem sinal, foi errado fazer isso? pode ser esse o problema do super-aquecimento?

    o que mais pode estar fazendo ele aquecer?

    obrigado a todos pela ajuda! sinto que to quase conseguindo

    se usou o circuito do datasheet quais os valores de R21 R22 R23 e R24 que usou ?

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • Boa Tarde pessoal, desculpa a demora pra responder mas só hoje arrumei tempo pra desenhar o circuito. Ae esta

    post-301726-13884953185477_thumb.jpg

    Quanto ao uso de diversas tensões:

    A minha fonte de energia é uma bateria de 14.4V, coloquei um LM7805 pra fornecer a tensão para o pic (é também o nível lógico).

    O HIP trabalha com voltagens de 12v a 16v até poderia ligar a bateria diretamente a ele, porém logo que é retirada do carregador a bateria chega a fornecer 18v o que iria queimar o HIP, por isso o uso do LM7812

    O problema:

    O motor é acionado de maneira instavel, se ficar ligando e desligando o sinal que vem do Pic uma hora o motor começa a rodar normalmente, porém com as mosfets superiores esquentando muito.

    Como não faço ideia da freqüência do PWM, estava usando 6000Hz mas baixei para 2000Hz e continuou tudo na mesma.

    O HIP e as mosfets não estão funcionando independente do PIC, pois tentei acionar o HIP diretamente (sem o PWM) e mesmo assim tive o mesmo problema.

    Fatos(que eu não sei o que querem dizer):

    *Fiz testes isolados com as mosfets, percebi que uma delas(ao contrario das outras) para de conduzir(acender um led) depois que o sinal é retirado.

    Retirei a mosfet estranha e tentei usar o HIP para acionar uma "meia ponte H" e obtive os mesmos problemas

    *Assim que o motor é ligado a tensão cai bastante, as vezes para valores abaixo de 12v

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    qual as caractristicas do motor V e I ?

    penso que deve fazer isso passo a passo

    se esta a usar o IRF1404 retire os 1N1007 pois nao estão a fazer nada

    para ja verifique apenas a ponte isoladamente e se os mos comutam e se continumam a aquecer

    ao mesmo tempo verifique se a tensão do 7812 pemanece estavel e se nao nota oscilaçoes quando o motor arranca

    pois o 7812 pode nao ter capacidade para alimentar esse motor

    se o motor consumir mais de 1A pode estar ai o problema

    neste caso experimente a ponte com a bateria de 12v

    Editado por oceano

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • O motor retirei de um equipamento que funcionava em 12v, porém não acho que seja esse o problema.

    Consigo testar as mosfets individualmente, e sei que nesse caso elas conduzem bem, porém testar uma ponte H sem o HIP não é possivel já que não consigo fazer os mosfets superiores entratem em condução.

    pois o 7812 pode nao ter capacidade para alimentar esse motor

    O LM7812 não vai alimentar o motor, quem vai fazer isso são as mosfets. Ele alimenta apenas o HIP.

    se o motor consumir mais de 1A pode estar ai o problema

    Sim, o motor vai consumir muito mais de 1A, por isso optei por mosfets, e não transistores.

    Oceno, posso tirar os diodos mas acho que não vai resolver o problema ne..

    alguma ideia??

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    gabriela_goes

    como disse atras tem de fazer isso por partes

    de outra forma vai andar as voltas sem saber a causa

    O motor retirei de um equipamento que funcionava em 12v, porém não acho que seja esse o problema.

    12V e qual a corrente do motor ?

    ja o ligou e mediu a corrente por exemplo com a bateria

    Consigo testar as mosfets individualmente, e sei que nesse caso elas conduzem bem, porém testar uma ponte H sem o HIP não é possivel já que não consigo fazer os mosfets superiores entratem em condução.

    O LM7812 não vai alimentar o motor, quem vai fazer isso são as mosfets. Ele alimenta apenas o HIP.

    como alimenta a ponte ?

    pela bateria ?

    Sim, o motor vai consumir muito mais de 1A, por isso optei por mosfets, e não transistores.

    o mosfet tambem sao tansistores mas com tecnologia diferente dos bipolares

    ----------------------

    no outro post diz

    "porém logo que é retirada do carregador a bateria chega a fornecer 18v "

    algo esta errado aqui

    a bateria nao vai fazer isso de certeza

    por favor verifique

    Editado por Bcpetronzio
    Inserir tags quote

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • 12V e qual a corrente do motor ?

    ja o ligou e mediu a corrente por exemplo com a bateria

    Já medi sim, mas não tenho esse valor agora, posso postar aqui amanha.

    Nao consegue porque ?

    basta polarizar os mos 2 de cada vez de forma cruzada

    Os mosfets que estou utilizando são todos NPN, e em uma ponte H tanto o positivo quanto o negativo precisam ser chaveados. Essa é uma das funções do HIP ele usa as tecnicas de Charge-pumping para criar uma tensão superior aos 15v e aplicar isso apenas as mosfets superiores, fazendo-as entrar em condução.

    como alimenta a ponte ?

    pela bateria ?

    Sim, a ponte é alimentada diretamente da bateria, pois assim garanto uma tensão máxima no motor.

    no outro post diz

    "porém logo que é retirada do carregador a bateria chega a fornecer 18v "

    algo esta errado aqui

    a bateria nao vai fazer isso de certeza

    por favor verifique

    Realmente, esse comportamento da bateria é estranho. Mas tentei criar o circuito de uma maneira que a tensão da bateria não importasse, assim se futura mente eu decidir aumentar a tensão do motor, para ganhar mais rotação, ou torque, bastaria trocar a bateria.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Gabriela, você chegou a testar se as baterias realmente "aguentam o tranco" ? Pode ser que não estejam aguentando, e então a tensão cai bastante, diminuindo também a tensão no 7812 e consequentemente no HIP.

    Se o seu for o HIP4081 (sem o A no fim) e não o HIP4081A, acho importante você pensar na substituição dele pelo último citado, que possui proteção contra baixas tensões (que impedem o correto acionamento dos mosfets, fazendo-os esquentar mais que o normal).

    Off: sua equipe vai pro Eneca? Em caso positivo, essa ponte deve ser terminada até lá? Se sim, tente conseguir acesso a um osciloscópio, isso ajuda pra caramba na hora de "debugar" o circuito...

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Já medi sim, mas não tenho esse valor agora, posso postar aqui amanha.

    ok

    Os mosfets que estou utilizando são todos NPN, e em uma ponte H tanto o positivo quanto o negativo precisam ser chaveados. Essa é uma das funções do HIP ele usa as tecnicas de Charge-pumping para criar uma tensão superior aos 15v e aplicar isso apenas as mosfets superiores, fazendo-as entrar em condução.

    sei disso mas esses circuitos de Charge-pumping funcionam normalmente con frequencias elevadas. o diodo 1n1007 nao funcina para essas frequencias use algo como o indicadi pelo Lokasso 0 1n4148 0u bat85

    ------------

    Sim, a ponte é alimentada diretamente da bateria, pois assim garanto uma tensão máxima no motor.

    verifique bem a bateria

    ou é diferente detudo o que conheco ou deve ter em vazio 13,8V e claro tem que ter capacidade de corente

    -------------

    Realmente, esse comportamento da bateria é estranho. Mas tentei criar o circuito de uma maneira que a tensão da bateria não importasse, assim se futura mente eu decidir aumentar a tensão do motor, para ganhar mais rotação, ou torque, bastaria trocar a bateria.

    mas note aquilo que tanto o Lokasso como eu lhe vimos a dizer

    se a bateria não tiver capacidade suficiente tudo vai falhar

    tudo indica que os transistores do topo nao esta a entrar em saturaçao quando ligados ao hip e logo vão aquecer

    note que no post 9 disse ainda

    "Segui o projeto que tem no datasheet do HIP, porém coloquei resistores de Pull-Down de 1k nos mosfets, pra garantir que eles só conduzam quando receberem sinal, foi errado fazer isso? pode ser esse o problema do super-aquecimento?"

    essas resistencias neste caso so vão prejudicar o circuito do HIP que gera as tensoes de drive dos mosfet supriores

    já os retirou?

    --------------------------

    ja agora verifique se imediatamente a seguir a ligar o circuito os mos começao a aquecer ou se apenas depois de algumas comutaçoes

    outra questao use condensadores , aqueles que estap ligados a AHB e BHB, de boa qualidade e de baixas fugas

    ------------------

    agora pode tirar os 1N4007 que tem entre dreno e source dos mosfet IRF1404

    como pode ver no datasheet destes transistores

    estes já tem internamente diodo interno de protecçao

    pode testar a ponte de maneira simples veja esta montagem simples

    da figura e em vez dos leds coloque o motor

    Editado por Bcpetronzio
    Inserir tags quote

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • O motor estava rodando a 1.5A em 10v não tive oportunidade de aumetar mais a tensão.. estava rodando o motor com 1mosfet ligado diretamente( sem o HIP) funcionou muito bem, mas quando eu desliguei ele queimou.

    Quanto a usar outro diodo: Vou utilizar o UF1002DICT

    verifique bem a bateria

    ou é diferente detudo o que conheco ou deve ter em vazio 13,8V e claro tem que ter capacidade de corente

    Como assim "em vazio 13,8" ?? estou usando um Pack com 12 baterias de

    1.2V NiMH

    essas resistencias neste caso so vão prejudicar o circuito do HIP que gera as tensoes de drive dos mosfet supriores

    já os retirou?

    Sim! já retirei.

    Não testei a ponte H com o circuito que você propos, pois agora não tenho mosfets suficiente... acho que até o final do dia eu consigo fazer os testes.

    estes já tem internamente diodo interno de protecçao

    Então porque queimou?

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
    O motor estava rodando a 1.5A em 10v não tive oportunidade de aumetar mais a tensão.. estava rodando o motor com 1mosfet ligado diretamente( sem o HIP) funcionou muito bem, mas quando eu desliguei ele queimou.

    ok assim ja temos ums ideia da corrente em causa

    quando puder meça

    -------------------

    Quanto a usar outro diodo: Vou utilizar o UF1002DICT

    ok

    ---------------------

    Como assim "em vazio 13,8" ?? estou usando um Pack com 12 baterias de

    1.2V NiMH

    nao sou adivinho e como falou em bateria pensei nas normais de 12v de chumbo

    essas baterias de de 1.2V NiMH nao podem dar 18V algo se passa ai

    todas as que conheci em vazio tem cerca de 1,32v depois de carregadas

    Qual a capacidade dessas baterias em mA hora ?

    Quando experimentar ligar o motor a esse pack de baterias meça a tensão do pack de baterias em carga

    ----------------

    Sim! já retirei.

    ok

    -----------------------

    Não testei a ponte H com o circuito que você propos, pois agora não tenho mosfets suficiente... acho que até o final do dia eu consigo fazer os testes.

    ok assim sabe se a sua ponte esta a funcionar

    ----------------------------

    Então porque queimou?

    o transistor queimou ?

    pode ter feito algum curto ou ligaçao incorrecta

    baixe o datasheet do IRF e vai ver quetem diodo de protecçao

    note tanbem que mesmo que deseje usar diodos extra nao podem ser os

    1N4007 pois sao muito lentos para essa funçao

    dadas as caracteristicas desse mos a nivel de correntes a unica

    coisa que me parece possivel sera ter excedido o valor de Vdss

    pode tentar colocar condensador nos terminais do motor

    pode ainda usar transistor com maior valor de VDSS como os IRF840

    Editado por Bcpetronzio
    Inserir tags quote

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Crie uma conta ou entre para comentar

    Você precisar ser um membro para fazer um comentário






    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×