Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Zenner

Fazer funcionar um litebox carregado por jquery .load

Recommended Posts

Fala povão.. beleza??

Tenho um site de noticias... Nele possuo um div chamado conteúdo..

Ao abrir o site ele mostra algumas noticias (igual todo site). Ao clicar em qualquer noticia eu chamo via jquery .load o conteúdo que aparecerá dentro de minha div conteudo (abaixo um exemplo), porém quando o html vem e é anexo dentro da div, o link existente dentro das fotos ( que vem junto com o html importado e já tem o cod que chama o lytebox) não funciona.. Agora, se eu abro o tal link em uma outra página sem ser chamado por jquery ele funciona.

exemplo do conteúdo da div "conteudo"

<script src="js/jquery.js" type="text/javascript"></script>

<script type="text/javascript">

function carrega( url ) {

$('#conteudo').load(url);

}

</script>

<div id="conteudo">

<a href="java script:carrega('teste.html')">teste de noticia</a>

</div>

Quando abro o arquivo teste.html diretamente no browser, o lyteboix existente nele funciona perfeitamente.. quando ele é carregado via meu jquery pra dentro do div "conteudo" ele não funciona....

(Detalhe - O conteúdo do arquivo teste.html possui somente o conteúdo de dentro dos body´s, de forma a o ajax não importar as tags <html><body></body></html> pra dentro do div)

já coloquei o script q chama o lytebox tanto dentro de minha página original quanto dentro do teste.html e em nenhuma das fomas funciona..

"E agora José?"

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×