Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
MesquitBrasil

Portugol urgente

Recommended Posts

Pessoal Socorro

Alguem pode me ajudar

Tenho de fazer algoritimo em Portugol e não sei fazer

Tenho de adiiconar uma item no final de uma lista como faz isso????

É igual em C?

include <stdio.h>

#include <stdlib.h>

#define N 5

int main(void)

{

int Vet[N+1]; /* isto é para eu poder considerar

que o vetor inicia na posicao=1 */

int i, j;

int cont = 0;

// preencher o vetor

for(i = 1; i <= N ; i++)

{

printf(" Digite o %do valor inteiro: ",i);

scanf("%d",&Vet);

}

for(i = 1; i <= N ; i++)

{

if (Vet==Vet[N])

cont = cont + 1;

}

printf("\n O total de ocorrencuas do ultimo elemento é: %d",cont);

printf("\n\n");

system("pause");

return(0);

}

Obrigado

Claudio

Compartilhar este post


Link para o post
Compartilhar em outros sites

Amigo em portugol é mais ou menos assim(se for o que você quer):

Inicio

*declaração das variavei

inteiro Vet[N+1], i, j;

*incializacão das variavei

cont = 0;

*corpo do programa

PARA i = 1 ATE i <= N PASSO 1 FAÇA

ESCREVA( Digite o do valor inteiro)

ENTRAR Vet

e ai vai.......substitua as palavras pegando o exemplo acima

Flow..............

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • Amigo em portugol é mais ou menos assim(se for o que você quer):

    Inicio

    *declaração das variavei

    inteiro Vet[N+1], i, j;

    *incializacão das variavei

    cont = 0;

    *corpo do programa

    PARA i = 1 ATE i <= N PASSO 1 FAÇA

    ESCREVA( Digite o do valor inteiro)

    ENTRAR Vet

    e ai vai.......substitua as palavras pegando o exemplo acima

    Flow..............

    desculpe a demora. Meu micro deu problema e fiquei na mão.

    Como ficaria para adicionar um elemento qualquer no fim da lista em Portugol?

    eu não consegui captar sua logica no Portugol e´, é exatamente o que eu preciso fazer.

    A lista tem 100 elementos e tenho de entra com um elemento no final dela, usando o Portugol.

    Obrigado

    Claudio

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • Pessoal fiz esses Programas em Portugol, pediria pra que me ajudassem a verificar se esta certo, ou seja declaração deVariavel, inicio incrementação etc..:

    São cinco a lista tem 100 elementos.

    Adiciona um dado elemento no fim da Lista

    Vetor [100]

    Declarar

    Elemento: array [0..99] de inteiro;

    Novoelemento inteiro

    Inicio

    {inserindo em todo o vetor}

    Enquanto i=0 ate 99 faça

    Se i=vazio faça

    Inicio

    leia(Elemento:=Novoelemento);

    Fimse

    Senão i:=i+1

    Fimenquanto

    Adicionar um dado elemento em uma dada posição

    Vetor [100]

    Declarar

    Elemento: array [0..99] de inteiro;

    Funcao adiconaElementoDadaPosicao(nomeElemento,posicaoInsercao,TamanhoLista)

    Inicio

    Para i de tamanhoLista ate posicaoInsercao faca

    Listaelemento[i+1] := listaElementos

    fimPara

    //usa o para pegar todos os elementos da ultima posição até a posição em que se deseja inserir e avança com eles uma posição//

    listaElemento[posicaoInsercao] := nomeElemento //insere o elemento na posição determinada//

    tamanhoLista := tamanhoLista + 1 //atualiza o número de elementos da lista//

    Fimfuncao

    Pega o elemento de uma dada Posição

    Vetor [100]

    Declarar

    Elemento: array [0..99] de inteiro;

    Funcao pegaElementoDadaPosicao(posicaoElemento)

    Inicio

    nomeElemento := listaElemento[posicaoElemento]

    retorna nomeElemento //retorna o nome do elemento que corresponde a posição solicitada//

    Fimfuncao

    Remover o Elemento de uma posição

    Vetor [100]

    Declarar

    Elemento: array [0..99] de inteiro;

    Funcao removeElementoDadaPosicao(nomeElemento, posicaoRemocao, tamanhoLista)

    Para i de posicaoRemocao ate tamanhoLista faca

    listaElemento := listaElemento[i+1]

    fimPara

    tamanhoLista := tamanhoLista – 1

    Fimfuncao

    Fimalgoritmo

    Verifica se um dado elemento está contido na Lista

    Vetor [100]

    Declarar

    Elemento: array [0..99] de inteiro;

    Funcao verificaDadoelementoLista(nomeelemento, tamanhoLista)

    Contador := 0

    Enquanto listaElemento[contador] <> nomeelemento ou contador<tamanhoLista

    Contador := contador + 1

    fimEnquanto

    Fimalgoritmo

    Informa a quantidade de elementos da Lista

    Vetor [100]

    Declarar

    Elemento: array [0..99] de inteiro;

    Variaveis: Qnt, I

    Qnt:=0;

    Para i de 0 até 99 faça

    Inicio

    Se elemento <> vazio então

    Qnt:=qnt+1;

    Senão

    I:=99;

    Fim se;

    Fimpara;

    Fimalgoritmo

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Crie uma conta ou entre para comentar

    Você precisar ser um membro para fazer um comentário






    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×