Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Rozz01

Ajuda na formula - =D

Recommended Posts

Boa tarde a todos terráqueos do Excel....

Estou com uma duvida na seguinte formula...

=SOMA(SE((CHEQUES!$Y$2:$Y$1000="JAN2011");SE((CHEQUES!$G$2:$G$1000="FULANO")*E(CHEQUES!$N$2:$N$1000="Liquidado/Baixado");CHEQUES!$I$2:$I$1000;0)))

1° - Tenho uma planilha no qual seu nome é CHEQUES, e uma planilha de RESUMOS.

2° - Na planilha RESUMOS tenho esta formula acima que pega as informações nas células da planilha CHEQUES....essa formula acima pega o valor de acordo com as informações que eu queira.

3° - São 3 tipos de informações que eu quero, JAN2011 que representa o mês, FULANO que representa o titular do cheque e Liquidado/Baixado que representa o status.

4° - Eu só quero que some os valores de acordo com as informações que eu coloquei na formula.

Minha duvida é que nao deu certo com a formula que postei, onde estou errando?

Grato

Robert

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caro Rozz01, Boa Tarde.

Com uma pequena correção a sua fórmula irá funcionar conforme você deseja.

Utilize a seguinte fórmula:

=SOMA(SE(CHEQUES!$Y$1:$Y$1000="JAN2011";SE(CHEQUES!$G$1:$G$1000="FULANO";SE(CHEQUES!$N$1:$N$1000="Liquidado/Baixado";CHEQUES!$I$1:$I$1000;0))))

ATENÇÃO: Esta fórmula que você escreveu é uma fórmula MATRICIAL, logo, TEM que apertar CTRL + SHIFT + ENTER ao final da digitação da fórmula.

Eu sugiro a você uma função especialmente adequada para este tipo de pesquisa. FUNÇÃO SOMARPRODUTO.

É só digitar esta FÓRMULA:

=SOMARPRODUTO((CHEQUES!$Y$1:$Y$1000="JAN2011")*(CHEQUES!$G$1:$G$1000="FULANO")*(CHEQUES!$N$1:$N$1000="Liquidado/Baixado")*(CHEQUES!$I$1:$I$1000))

Era isto que você queria?

Espero ter ajudado.

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • Amigo Mazzaropi,

    Primeira mente obrigado por ajudar....

    1° FORMULA

    =SOMA(SE(CHEQUES!$Y$2:$Y$1000="JAN2011";SE(CHEQUES!$G$2:$G$1000="FULANO";SE(CHEQUES!$N$2:$N$1000="Liquidado/Baixado";CHEQUES!$I$2:$I$1000;0))))

    Estou ciente sobre a fórmula MATRICIAL, eu aperto CTRL + SHIFT + ENTER ao final da digitação da fórmula.

    O resultado foi o valor R$0,00 não obtive o valor total!

    2° FORMULA

    =SOMARPRODUTO((CHEQUES!$Y$2:$Y$1000="JAN2011")*(CHEQUES!$G$2:$G$1000="FG COMÉRCIO DE PEÇAS E SERVIÇOS DE MANUTENÇÃO LTDA.")*(CHEQUES!$N$2:$N$1000="Liquidado/Baixado")*(CHEQUES!$I$2:$I$1000))

    Coloquei a formula la da maneira que você posto aqui mas não deu certo, o resultado foi #valor!

    Estou errando algo?

    Mais uma vez obrigado.

    Robert

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Boa tarde Robert

    Esse é um problema da pessoa não postar um exemplo da planilha, fica díficil saber o que pode estar errado.

    Como eu sei que você tem o Excel 2010 você poderá usar a função SOMASES:

    Veja como usar: =SOMASES(Intervalo_soma;Intervalo_critério1;Intervalo_critério2;Intervalo_critério2) você pode usar muitos critérios.

    Veja se consegue, caso contrário seria bom você postar a tua planilha.

    Um abraço.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • Amigo Patropi,

    Primeiramente obrigado por ajudar....

    Meu Excel e 2007, achei engraçado....Fiz uma nova planilha so para teste e com a formula

    {=SOMA(SE(CHEQUES!$D$2:$D$1000="JAN2011";SE(CHEQUES!$A$2:$A$1000="FG COMÉRCIO DE PEÇAS E SERVIÇOS DE MANUTENÇÃO LTDA.";SE(CHEQUES!$C$2:$C$1000="Liquidado/Baixado";CHEQUES!$B$2:$B$1000;0))))}

    Ela pegou.

    Mas na minha planilha que uso a formula

    {=SOMA(SE(CHEQUES!$Y$2:$Y$1000="JAN2011";SE(CHEQUES!$G$2:$G$1000="FG COMÉRCIO DE PEÇAS E SERVIÇOS DE MANUTENÇÃO LTDA.";SE(CHEQUES!$N$2:$N$1000="Liquidado/Baixado";CHEQUES!$I$2:$I$1000;0))))}

    Não pega o valor vai pra R$0,00

    Em anexo as planilhas....

    Nova teste

    http://www.4shared.com/file/29pZnsdB/Nova_teste.html

    Minha planilha

    http://www.4shared.com/file/AmwWVNIZ/CONTROLE_GERAL_-_2011.html

    Planilhas CHEQUES e RESUMO-GERAL

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Robert

    Eu confundi você com um outro Robert que sempre posta aqui no fórum, isto aconteceu porque ele falou que iria trocar de Nick e o estranho é que ele é da Bahia também.

    Foi a partir do Excel 2007 que a função SOMASES foi implantada no Excel, portanto ela funciona no teu Excel 2007.

    Eu não consegui abrir os teus arquivo, eu consegui baixá-los mas aparece um aviso que o arquivo esta corrompido.

    Um abraço.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Crie uma conta ou entre para comentar

    Você precisar ser um membro para fazer um comentário






    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×