Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Ton Gunner

Ranking de Boxe?

Recommended Posts

Galera, preciso de uma ajuda.

Gosto de fazer simulação de esportes e gostaria de criar um "ranking" de boxe que se atualizasse sozinho.

Seria basicamente o nome do lutador na coluna A, pontos na coluna B, lutas na coluna C, vitórias na D e derrotas na E.

Só que preciso que quando os valores de pontos forem alterados a planilha se atualize sozinha.

Exemplo

Ali - 300 pontos - 3 vitórias 0 derrotas

Tyson - 250 pontos - 2 vitórias 1 derrota

Frazier - 200 pontos - 2 vitórias - 0 derrotas.

E ai quando mudasse a pontução seria

Frazier 350 pontos - 4 vitórias - 0 derrotas

Ali - 300 pontos 3 vitórias - 0 der..

Tyson - 200 pontos - 2 vitórias.. 2 derrotas.

Será que tem como? Sou totalmente leigo no Excel. E estou com a versão 2010 aqui.

Obrigado!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caro Tom Gunner, Bom Dia.

Existem muitas planilhas de campeonato de futebol automatizadas pelos fórums por aí. É só pesquisar.

Claro, que ao invés de times você troca pelo nome do lutador.

Fiz um modelo super básico apenas para você ter ideia de como funciona a parte de classificação automática.

Já que você disse que ainda não entende muito bem das funções do Excel é bem melhor você começar a ver processos bem simples antes de partir para planilha mais complexas.

O modelo está aquí: http://www.4shared.com/document/YHZQMFqX/09-04-2011_CLUBE_RANKING_BOXE_.html

Após você decidir como irá fazer vamos poder lhe ajudar com mais detalhes.

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • Boa noite, Mazzaropi.

    A ideia é essa mesmo. Alterar apenas a pontuação e o ranking se atualizar sozinho.

    Quando der empate eu gostaria de algum código desempate que calculasse em primeiro quem tem mais vitórias, se os dois tivessem o mesmo numero, ficaria na frente quem tem mais vitórias por nocaute.

    Uma dúvida BEM básica, eutenho que colocar aquelas fórmulas pra cada célula?

    Obrigado, novamente.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Caro Ton, Boa Noite.

    "...se os dois tivessem o mesmo numero, ficaria na frente quem tem mais vitórias por nocaute..."

    O nocaute é uma variável nova na questão.

    Então você deve criar uma coluna, e colocar o número de nocautes.

    "...Uma dúvida BEM básica, eutenho que colocar aquelas fórmulas pra cada célula? ..."

    Eu não entendí a pergunta.

    Você deve criar na classificação quantas linhas forem o número de lutadores no campeonato.

    Quanto às células na linha do lutador, elas são a indexação dos dados.

    G11 --> =MAIOR($B$2:$B$4;1)

    ...Ordena do maior para o menor em relação o número de pontos.

    F11 --> =ÍNDICE($A$2:$E$4;CORRESP(G11;$B$2:$B$4;0);1)

    ..."Pega" a primeira coluna referente ao valor máximo (Lutador)

    H11 --> =ÍNDICE($A$2:$E$4;CORRESP(G11;$B$2:$B$4;0);3)

    ..."Pega" a terceira coluna referente ao valor máximo (Lutas)

    I11 --> =ÍNDICE($A$2:$E$4;CORRESP(G11;$B$2:$B$4;0);4)

    ..."Pega" a quarta coluna referente ao valor máximo (Vitórias)

    J11 --> =ÍNDICE($A$2:$E$4;CORRESP(G11;$B$2:$B$4;0);5)

    ..."Pega" a quinta coluna referente ao valor máximo (Derrotas)

    Se você tiver 50 lutadores basta arrastar estas fórmulas por 50 linhas abaixo.

    Este quadro de classificação pode ficar em uma aba sozinho para ficar mais estético.

    Os dados podem ficar em outra aba perfeitamente.

    Veja só. Este é apenas um começo de automação da sua planilha.

    Ela pode conter muito mais coisas.

    Por exemplo, ao invés de resultado como você tem, a planilha de dados pode conter as lutas separadamente e a tabelinha de classificação somar e ordenar tudo.

    Era esta a sua dúvida?

    Espero ter ajudado.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • Tem me ajudado muito sim!

    Eu compreendi a planilha, simplesmente não sei montar. =/

    Quanto ao esquema de colocar as lutas e o excel calcular automaticamente, é muito interessante, mas daria muito mais trabalho, não é?

    Quando arrasto a fórmula aparece um erro, por isso perguntei se teria de digitar toda vez.

    E como faço pra colocar em outra aba?

    Obrigado, e desculpe tantas perguntas!

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Bom dia Tom

    Para facilitar tanto para o Mazzaropi quanto para você, sugiro que você poste a planilha num site gratuíto como:

    http://www.4shared.com/?signout=1

    Depois cole o link da planilha aqui no fórum.

    Assim o Mazza pode aplicar as fórmulas diretamente na tua planilha e te explicar como ele fez.

    Um abraço.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • Boa noite.

    Se o Mazzaropi não se importar, posso fazer isso sim.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Boa noite Ton

    Eu tenho certeza que ele não vai se importar e ele ainda vai ficar contente, pois,fica bem mais fácil te ajudar com a planilha em mãos, sem precisar fazer adivinhações e previsões de como estão os dados na tua planilha.

    Um abraço.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • Boa noite.

    Vou upar então a planilha como está pra deixar mais fácil.

    Obrigado pela atenção

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • Estou deixando de ser folgado e estou tentando montar a planilha com as fórmulas que o Mazzaropi postou, em relação aos pontos deu certo, mas quando eu arrasto ela copia a fórmula de cima ao invés de ir adiante, tipo, fica sempre a mesma pontuação, tive que digitar um a um =/

    As outras dão um erro "circular" algo assim, vou fazer de novo e copio aqui. Alguma ajuda no que pode ser?

    Obrigado!

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • "Aviso de referencia circular

    Uma ou mais fórmulas contem uma referencia circular e talvez não sejam calculadas corretamente. Referencias circulares são todas as referencias dentro de uma fórmula que dependam dos resultados dessa mesma fórmula. Por exemplo, uma célula que se refere ao seu próprio valor ou uma célula que se refere a outra célula, que dependa do valor da célula original contem referencias circulares."

    Não entendi nada =/

    Foi mal ai gente =/

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Caro Ton, Bom Dia.

    Pensei que você já tinha resolvido esta questão.

    Afinal, a planilha que lhe enviei estava pronta e expliquei as fórmulas na outra mensagem.

    Este tipo de planilha é simples.

    A única variável é o layout que muda a cada gosto pessoal.

    Tudo bem.

    Não vamos ficar tentando advinhar o que pode ser que está errado senão quando você acabar a planilha nem existe boxe mais como esporte.(hi hi hi)

    Faça como o colega Patropi lhe disse.

    Salve a sua planilha em algum site gratuito, ex.: www.4shared.com e coloque o link aquí.

    Você deve ter percebido que apesar das pessoas abrirem o post ninguém mais quis dar opinião.

    É bem complicado ficar discutindo possibilidades sem ver a planilha e poder verificar as fórmulas nela.

    Aguardamos a planilha.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • Boa noite Mazzaropi.

    Vou postar ela agora então, mais fácil! rs

    É que eu dei apenas um esboço do que eu queria pra você, pois eu dividi em oito categorias de peso por lutadores, sendo que algumas contam com mais de 100 lutadores.

    Tentei as fórmulas mas infelizmente obtive esse erro, o que me atrasou e fez com que eu continuasse torrando o tempo de vocês.

    Mais uma vez, obrigado pela atenção, vou terminar o esboço da planilha e coloco o link aqui.

    Obrigado!

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • Demorei mas upei a planilha.

    http://www.4shared.com/file/Xn8zB9No/FNC_Ranking.html

    Esse é o link pro download.

    Tem 8 abas (Heavyweight, Light-Heavyweight, Middleweight, Welterweight, Lightweight, Featherweight, Bantamweight e Flyweith), cada uma simboliza uma categoria de peso.

    Nas colunas M-V eu coloquei os dados, e gostaria que eles aparecessem da coluna A-J.

    Espero que tenham entendido.

    Muito obrigado novamente.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Caro Ton, Boa Noite.

    Abrí a planilha e apliquei as fórmulas conforme tinha falado anteriormente.

    Como você criou uma série de critérios para desempate, foi criada então uma coluna auxiliar que irá qualificar o lutador automaticamente segundo os seus critérios:

    Qtde de Pontos (Col N)

    Qtde de Vitórias (Col P)

    Quantidade de Nocautes (Col S)

    Na coluna auxiliar X tem: =VALOR(N2&P2&S2)

    Esta é a chave única para qualificação.

    Nas colunas de A até J foram selecionados os lutadores de acordo do maior para o menor qualificado pela coluna X.

    A2 --> =SE(M2="";"";ÍNDICE($Microsoft2:$V$108;CORRESP(MAIOR($X$2:$X$108;LIN(A1));$X$2:$X$108;0);1))

    B2 --> =SE(M2="";"";ÍNDICE($Microsoft2:$V$108;CORRESP(MAIOR($X$2:$X$108;LIN(A1));$X$2:$X$108;0);2))

    C2 --> =SE(M2="";"";ÍNDICE($Microsoft2:$V$108;CORRESP(MAIOR($X$2:$X$108;LIN(A1));$X$2:$X$108;0);3))

    D2 --> =SE(M2="";"";ÍNDICE($Microsoft2:$V$108;CORRESP(MAIOR($X$2:$X$108;LIN(A1));$X$2:$X$108;0);4))

    E2 --> =SE(M2="";"";ÍNDICE($Microsoft2:$V$108;CORRESP(MAIOR($X$2:$X$108;LIN(A1));$X$2:$X$108;0);5))

    F2 --> =SE(M2="";"";ÍNDICE($Microsoft2:$V$108;CORRESP(MAIOR($X$2:$X$108;LIN(A1));$X$2:$X$108;0);6))

    G2 --> =SE(M2="";"";ÍNDICE($Microsoft2:$V$108;CORRESP(MAIOR($X$2:$X$108;LIN(A1));$X$2:$X$108;0);7))

    H2 --> =SE(M2="";"";ÍNDICE($Microsoft2:$V$108;CORRESP(MAIOR($X$2:$X$108;LIN(A1));$X$2:$X$108;0);8))

    I2 --> =SE(M2="";"";ÍNDICE($Microsoft2:$V$108;CORRESP(MAIOR($X$2:$X$108;LIN(A1));$X$2:$X$108;0);9))

    J2 --> =SE(M2="";"";ÍNDICE($Microsoft2:$V$108;CORRESP(MAIOR($X$2:$X$108;LIN(A1));$X$2:$X$108;0);10))

    Apliquei as fórmulas na primeira aba.

    As outras são idênticas a aplicação.

    Tive que colocar uns dados quaisquer para poder testar.

    Veja só os 3 primeiros lutadores.

    Dê uma olhada e me diga se era isto que você queria.

    Espero ter ajudado.

    Modelo com fórmulas: http://www.4shared.com/document/nbQr14ef/14-04-2011_FNC_Ranking_Ton_V1-.html

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • Boa noite, Mazzaropi.

    Cara, muito obrigado, ficou perfeito! Exatamente o que eu queria! Muito obrigado!

    Só uma coisa, pensei que talvez a porcentagem de nocautes fosse mais justa como desempate.

    Que fórmula devo colocar pra que os critérios sejam pontos e depois porcentagem de nocautes???

    Obrigado!

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Caro Ton, Bom Dia.

    Fico feliz em ter ajudado você a resolver a sua questão.

    Caso você queira mudar o critério de desempate, a única parte que deve ser alterada é sempre a formação da Chave Única (coluna x)

    O restante da planilha funciona automaticamente baseado nesta coluna.

    ANTES:

    Total Pontos___Número Vitorias____Número de Nocautes

    ___Col N__________Col P______________Col S_______

    CHAVE=(N2&P2&S2)

    AGORA:

    Total Pontos___% Nocautes

    ___Col N_________Col S_______

    CHAVE=(N2&ARRED(S2/P2;2))

    Lembre-se sempre, que independente do critério de desempate, que pode ser o que você precisar que seja, o resultado TEM que ser um chave única para que a classificação funcione.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • Bom dia!

    Mazzaropi, você não me ajudou a resolver minha questão, você a fez pra mim! rs

    Muito obrigado novamente.

    Mas tenho uma nova questão, nessa sua ultima fórmula notei que acaba colocando quem tem uma porcentagem menor de nocautes primeiro.

    Exemplo.

    Lutador x tem 30 vitórias, sendo 25 por nocaute.

    Lutador y tem 30 vitórias, sendo 15 por nocaute.

    O certo seria o lutador x aparecer na frente da tabela, mas acontece o contrário.

    Será que fiz algo errado?

    Obrigado.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Caro Ton, Bom Dia.

    "...Mas tenho uma nova questão, nessa sua ultima fórmula notei que acaba colocando quem tem uma porcentagem menor de nocautes primeiro.Exemplo.

    Lutador x tem 30 vitórias, sendo 25 por nocaute.

    Lutador y tem 30 vitórias, sendo 15 por nocaute.

    O certo seria o lutador x aparecer na frente da tabela, mas acontece o contrário.

    Será que fiz algo errado?..."

    A alteração da fórmula é muito pequena para você ter feito algo errado.

    Deve ser outra coisa.

    A composição da chave eu já tinha explicado na mensagem anterior.

    Recapitulando o histórico da fórmula em X2:

    Antes:=VALOR(N2&P2&S2)

    Agora:=VALOR(N2&ARRED(S2/P2;2))

    Tomando como base a planilha anterior e simulando um resultado teríamos:

    _NOME_________Pontos___Vitórias___Vit. KO_____AUX_____

    Tomasz Adamek__150______30_______15________1500,50..........Significa 50% de performance

    Henry Akinwande_150______30_______25________1500,83..........Significa 83% de performance

    Muhammad Ali___ 350______10_______10________3501,00

    .

    .

    Na planilha de classificação ficaria assim:

    _NOME_________Pontos___Vitórias___Vit. KO

    Muhammad Ali___ 350______10_______10

    Henry Akinwande_150______30_______25

    Tomasz Adamek__150______30_______15

    Está aparecendo assim ou não?

    Qualquer coisa coloque a planilha disponível para que seja possível analisar o novo cenário.

    Não vale a pena ficar imaginando o que pode ser ou não.

    Aguardo resposta.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • Boa tarde, Mazzaropi.

    Fui conferir e ver que foi erro meu mesmo, ao invés de (S2/P2) eu fiz (P2/S2)

    Alterei e agora deu certinho.

    Obrigado e desculpe esse erro ridiculo! rs

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • Mazzaropi, boa tarde.

    Andei pensando e acho queum critério de desempate mais justo é a porcentagem de vitórias, seguido da porcentagem de nocautes.

    Será que tem como fazer isso?

    Tipo =VALOR(N2&ARRED(P2/O2;2)&ARRED(S2/P2;2))

    Existe isso? rs

    Obrigado novamente.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • Bom, tentei a fórmula que postei e não deu certo, Mazzaropi, você sabe a maneira certa?

    Desculpe novamente.

    Obrigado

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • Boa noite.

    Gostaria de perguntar novamente que fórmula devo usar pra que o desempate seja primeiro o numero de pontos... depois uma porcentagem de numero de vitórias e por fim a porcentagem de vitórias por nocaute?

    Obrigado.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Crie uma conta ou entre para comentar

    Você precisar ser um membro para fazer um comentário






    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×