Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Entre para seguir isso  
Talleyrand

Ajuda - Exercício de pascal

Recommended Posts

Bom to com ma dificuldade de fazer esse algoritmo aqui

se algué puder me ajudar.. valeu acho que to com algum erro em sitaxe mas não to vendo onde!

valeu

ah e outra coisa como eu poderia fazer para finalizar o programa dá a opção de um comando para o usuário pra ele finalizar?

valeu²

Desejamos efetuar uma análise estatística a respeito dos livros vendidos por uma livraria 
em um determinado mês. Para cada livro são fornecidas as seguintes informações: título
do livro, tipo (F=Ficção / N=Não-Ficção / T= Técnico-Científico), preço unitário de venda
e quantidade de exemplares vendidos no mês.
Elabore um algoritmo em que leia as informações sobre os livros e ao final, mostre o
seguinte relatório:
a) quantidade de exemplares de cada tipo tipo (Ficção, Não-Ficção, Técnico-Científico)
vendidos no mês;
média de preços de venda de livros por tipo;

o programa...

solução 1
algoritmo "semnome"
// Função :
// Autor :
// Data : 9/4/2011
// Seção de Declarações
var
tipo,nome:caracter
contf,contnf,conttc,somaf,somanf,somatc:inteiro
precof,preconf,precotc:real
inicio
somaf<-0
somaf<-0
somatc<-0
escreva("Digite o nome do livro: ")
leia(nome)
escreval("Digite o tipo do livro.")
escreva("(ficição=f; não-ficição=nf; tecnico-cientifico=tc): ")
leia(tipo)
enquanto( (tipo="f") ou (tipo="nf") ou (tipo="tc"))faca
se (tipo="f") então
contf<-contf+1
escreva("Digite o preço do livro:")
leia(precof)
somaf<-somaf+precof
senao
se (tipo="nf")então
contnf<-contnf+1
escreva("Digite o preço do livro: ")
leia(preconf)
somanf<-somanf+preconf
senao
conttc<-conttc+1
escreva("Digite o preço do livro: ")
leia(precotc)
somatc<-somatc+precotc
fimse
fimse
escreva("Digite o nome do livro: ")
leia(nome)
escreva("Digite o tipo do livro.")
leia(tipo)
fimenquanto
escreval(contf," livros cientificos, ",contnf," livros não-cientifícos e ",conttc," livros tecnicos-cientificos")
escreva("Os livros de ficção custam em média ",somaf/contf,)
escreva("; os livros de não ficção custem em média ",somanf/contnf,)
escreva(" e os livros tecnicos-cientificos custem em média ",somatc/conttc)
fimalgoritmo

Editado por Talleyrand

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Entre para seguir isso  





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×