Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
cleyton.bretas

formula do excel

Recommended Posts

Boa tarde.

Estou com a seguinte dúvida: Tenho 2 colunas no excel (Coluna A e Coluna B) preenchidas em várias linhas. Gostaria de comparar os textos da coluna B com a coluna A, e se tiverem o mesmo texto, na coluna C marcar um "X" na frente, e caso nao tenha apareça "n/a".

Exemplo:

COLUNA A COLUNA B COLUNA C

(Nomes) (partes de nomes) (verificação)

Alexandre "xand" " X"

Anderson "ria " " X"

José "nato" " n/a "

Renato "fael " " X"

Luiz "ton" "n/a"

João "aldo" "n/a"

Maria "son" "X"

** Explicando: Na frente de Alexandre tem o "X" porque na coluna B tem o texto "xand", no nome Renato tem o X porque na coluna B tem o texto 'nato', no nome Luiz tem o 'n/a' porque na coluna B nao tem nenhum trecho do nome LUIZ.

Caso consegui explicar mina duvida, espero que alguem consiga me ajudar.

Obrigado!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Prezado Cleiton, Bom dia.

Atenção: Não coloque as partes da palavra que você está procurando entre aspas.

Ex.:

A1 --> Cleyton.Bretas

B1 --> .Br

C1 --> =SE(ÉERROS(LOCALIZAR(B1;A1));"N/A";"X")

Era isto que você queria?

Espero ter ajudado.

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • Na verdade não Mazzaropi.

    Talvez eu não tenha explicado corretamente minha dúvida.

    Eu quero ver se as palavras que estão na coluna B contém na coluna A, se contem, é para marcar um X na frente dos nomes que contem e se não contem marcar N/A(ou deixar em branco ou escrever qq outra coisa, tipo NAO TEM, algo assim..), isso na coluna C.

    Segue exemplo na IMG:

    excelp.jpg

    Obrigado.

    Cleyton

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Boa noite Cleyton

    Mas que critério você usa???

    Anderson---> Não tem nada a ver com "nato"

    Alexandre --> não tem nada a ver com "Erme"

    Renato ----> não tem nada a ver com "bricio"

    você deveria postar uma planilha de exemplo com explicações mais claras do que você deseja, em um site gratuito como:

    www.sendspace.com

    Depois disponibilize aqui no fórum.

    Um abraço.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Boa noite galera!

    acho que entendi o que ele quer!

    é quase o q o amigo Mazzaropi fe, so que, nao é procurar so na celula,

    e sim na coluna inteira....

    com base na formula do Mazzaropi, seria +ou- isso!

    =SE(ÉERROS(LOCALIZAR(B1;A1:A8));"N/A";"X")

    pelo menos foi isso q entendi no ex dele:

    Alexandre "xand" " X"

    Anderson "ria " " X"

    José "nato" " n/a "

    Renato "fael " " x"

    Luiz "ton" "n/a"

    João "aldo" "n/a"

    Maria "son"

    quanto ao Renato "fael " " x"

    ele deve ter copiado da planilha e no ex fico faltando a linha que tem o rafael

    bom! acho que é isso, tentei algumas mudanças na formula do mazzaropi mas nao funcionou nao.....

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • Caro deejaywesley,

    A formula que você indicou funciona somente quando o trecho do nome está na frente do proprio nome que contem esse trecho, por exemplo:

    Anderson "son" -> X

    Alexandre "xand" -> X

    Caso fique como está no modelo original não funciona, por exemplo:

    Anderson "ria"

    Maria "son"

    José "nato"

    Renato "fael "

    Dessa forma acima fica td parecendo o "N/A" na frente, mas somente era para ser no 'JOSÉ'.

    Obrigado pela atenção e no aguardo de uma ajuda! :)

    Abraço.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Se quiser experimentar esta UDF, instale o código abaixo em um módulo comum, assim:

    1. copie o código daqui

    2. a partir da planilha de interesse tecle Alt+F11

    3. no menu Inserir >> Módulo

    4. cole o código na janela em branco que vai se abrir

    5. feito! Alt+Q para retornar para a planilha

    6. em 'C1' coloque a função =ParteDoNome() e arraste para baixo

    Function ParteDoNome()
    Application.Volatile
    Dim LR As Long, k As Long, m As Long
    LR = Cells(Rows.Count, 1).End(xlUp).Row
    k = Application.Caller.Row
    For m = 1 To LR
    If InStr(Cells(k, 1), Cells(m, 2)) > 0 Then
    ParteDoNome = "X"
    Exit Function
    End If
    Next m
    ParteDoNome = "n/a"
    End Function

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Crie uma conta ou entre para comentar

    Você precisar ser um membro para fazer um comentário






    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×