Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Entre para seguir isso  
odlile

[Resolvido] Função MÁXIMO não quer funcionar!

Recommended Posts

Boa tarde, pessoal!

Estou preparando uma planilha que "decidirá" qual o percentual de redução de carga horária os professores efetivos do quadro de pessoal poderão ter, de acordo com dois critérios: idade e tempo de serviço.

Já consegui fazer o Excel calcular as idades (considerando dia, mês e ano) e tempos de serviço, e o Excel já está calculando também o percentual correspondente em cada critério (10 ou 25%), utilizei para isso a fórmula SE. Até aí, tudo OK nas fórmulas. Deu trabalho, mas funcionou.

Vou postar a planilha pra vocês verem.

Em alguns casos, segundo um critério, o professor tem direito a 10% de redução, mas segundo o outro critério, tem direito a 25%. Então eu queria usar a função MÁXIMO para o Excel retornar o maior percentual, nesses casos de conflito. ACONTECE QUE A FUNÇÃO MÁXIMO NÃO ESTÁ FUNCIONANDO (coluna H). Alguém tem alguma dica de por que não funciona e o que tenho de alterar?

Detalhe: do lado direito, no mesmo arquivo, bolei uma planilha menor, com números quaisquer, e lá a função MÁXIMO funcionou normalmente. Não é loucura? Não tem razão pro Excel fazer isso...

Se alguém puder ajudar, ficarei muito grato.

Links:

(formato xlsx) - http://www.4shared.com/file/fYzxizU8/CALCULO_IDADE.html

(formato xls) - http://www.4shared.com/office/2a2KlWrT/CALC_IDADE.html

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá. ao invés de usar a formula: Máximo(F2;G2),... por que nao use a função Se?

ai ficaria: =SE(F2>G2;F2;G2)

acho que resolveria o problema e seria mais fácil! aí é so arrastar até o final da coluna H

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa tarde Odile

O fórmula MÁXIMO só funciona com números e na fórmula da coluna F, vocêcolocou o resultado entre "Aspas", fazendo com que o excel retornasse um número no formato texto, portanto, basta você tirar as aspas desta fórmula da coluna "F" que o máximo funciona normalmente.

=SE(D2<15;"0";SE(D2<20;"10";"25"))

O correto da fórmula é assim =SE(D2<15;0;SE(D2<20;10;25)), sem aspas.

Só use aspas quando estiver trabalhando com texto.

Dê retorno.

Um abraço.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Odli,

Boa noite!

Tentando contribuir....

Coloque esta formula na célula F2.

=SE(E(D2<15);0;SE(D2<20;10;25))

Em preto : Dica do Patropi.

Em vermelho : Minha dica.

Praticamente não faz diferença nenhuma mais só estou querendo mostrar uma outra solução.

Tomara que eu tenha sido útil?

:D

Editado por Trafix
Formula
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa noite Trafix

Você se enganou rsrsrss.

Tentando contribuir....

Coloque esta formula na célula F2.

=SE(ÉNÚM(D2)<15;0;SE(ÉNÚM(D2)<20;10;25))

Em preto : Dica do Patropi.

Em vermelho : Minha dica.

A minha dica não foi essa, eu apenas sugeri para ele tirar as aspas da fórmula que funciona perfeitamente, sem necessidade de mudar a fórmula ou acrescentar alguma coisa.

Abraço.

Editado por Patropi

Compartilhar este post


Link para o post
Compartilhar em outros sites

Patropi,

Boa noite!

O correto da fórmula é assim =SE(D2<15;0;SE(D2<20;10;25)), sem aspas.

a partir do momento que você diz que a formula é assim, já estar indicando algo.

Mais enfim também me confundir na formula e estou me corrigindo.

Abraços,

Compartilhar este post


Link para o post
Compartilhar em outros sites

Trafix

Eu disse que não sugeri nenhuma fórmula, apenas sugeri que fosse retirado as aspas da fórmula.

Um abraço.

Editado por Patropi

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • Obrigado, Patropi, Ethies e Trafix. Todas as sugestões de vocês deram certo aqui. Isso resumirá manhãs inteiras de trabalho. Valeu mesmo, gente! :)

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Odle,

    Boa tarde!

    Fico contente em ter te ajudado quando precisar já sabe né ?

    Abraços,

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Caso o autor do tópico necessite, o mesmo será reaberto, para isso deverá entrar em contato com a moderação solicitando o desbloqueio.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
    Visitante
    Este tópico está impedido de receber novos posts.
    Entre para seguir isso  





    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×