Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.

mateus costa r

Membros Juniores
  • Total de itens

    8
  • Registro em

  • Última visita

  • Qualificações

    N/D

Reputação

6

Sobre mateus costa r

  1. C arquivo em c, leitura

    obg , fiquei travadão nessa parte e nem sabia o que fazer... estou aprendendo ainda. Você teria algum site ou canal de youtube que ensina-se alguns códigos ai que nunca vi ,tipo: >strcmp; >fflush(stdin); >fflush; agradeço mesmo xD , agora vou estudar esse código , teria algum problema em mudar as ordens de procedimento ? *******EDITADO***** Testei o programa rodou liso, porém quando eu fechei o programa para ver se o login e a senha que eu digitei ainda seriam validos, eu percebi que ele aceita qualquer senha. :/
  2. C arquivo em c, leitura

    Olá eu estou fazendo um programa de cadastro com login e senha, algo simples. Porém na hora de ler o que tem dentro do arquivo para ver se o login e a senha são verdadeiro igual do cadastro , eu simplesmente travei ai.... =============================================================================================================================== #include <stdio.h> #include <stdlib.h> #include <locale.h> #include <windows.h> void cadastro() { setlocale(LC_ALL,"PORTUGUESE"); FILE * arq; arq = fopen("cadastro.txt", "a"); char login[50], senha[50], email[50]; if (arq == NULL) { printf("O arquivo não pode ser gerado"); system("pause"); } printf("=============cadastro============\n"); fprintf(arq, "-------------cadastro-----------\n"); printf("Escreva seu Login: "); scanf("%s", &login); fprintf(arq, "Login: %s \n", login); printf("Escreva sua senha: "); scanf("%s", &senha); fprintf(arq, "Senha: %s \n", senha); printf("Escreva seu email: "); scanf("%s", &email); fprintf(arq, "Email: %s \n\n", email); printf("\n"); printf("Cadastro gerado com sucesso!\n"); fclose(arq); } void menunaoincial() { char c; setlocale(LC_ALL,"PORTUGUESE"); printf("Se você nao tiver uma conta aperte 'F' maiusculo\n"); printf("Se já tiver uma conta aperte qualquer tecla!!!\n\n"); c = getch(); printf(" "); system("cls"); switch(c) { case 'F': cadastro(); getchar(); Sleep(3000); printf("retornando aguarde..."); system("cls"); return main(); } } void menu() { setlocale(LC_ALL,"PORTUGUESE"); menunaoincial(); char r; FILE * arq; arq = fopen("cadastro.txt", "r"); printf("=======Menu de Acesso=========\n"); printf("login: "); scanf("%s", &r); printf("senha: "); } main() { setlocale(LC_ALL,"PORTUGUESE"); menu(); printf("Acessando...\n"); Sleep(3000); system("cls"); printf("====programa====\n"); printf("Instruçôes do programa ...."); }
  3. C o problema e simples ( eu acho)

    Olá, eu queria saber como eu faço para aparece a pergunta novamente tipo: int: x; char: resp; printf("Você quer responde isso:? (s/n): scanf("%c", &resp); foi um exemplo tosco, mas, eu queria saber como fazer essa pergunta aparece novamente quando a pessoas colocar "S"
  4. C Erro no programa, if else

    Vou direto ao ponto, to fazendo um programa para trabalho , porém, ele ta dando erro na linha 43 com o seguinte erro: "error: 'else' without a previous 'if' " #include <stdio.h> #include <stdlib.h> #include <locale.h> int main() { float nt1, nt2, nt3, nt4, mediafinal, x; setlocale(LC_ALL, "portuguese"); printf("_____________________________________________\n"); printf("Calcule a sua média:\n"); printf("_____________________________________________\n"); printf("\n Digite a sua primeira nota :"); scanf("%f", &nt1); printf("\n Digite a sua segunda nota :"); scanf("%f", &nt2); printf("\n Digite a sua terceira nota :"); scanf("%f", &nt3); printf("\n Digite a sua quarta nota:"); scanf("%f", &nt4); printf("\n____________________________________________\n"); x= nt1+nt2+nt3+nt4; mediafinal = (nt1+nt2+nt3+nt4)/4; if (mediafinal < 4) { printf("Sua nota total: %.1f \n", x); printf("Sua media: %.1f \n", mediafinal); printf("Você nao foi aprovado, pessimo"); printf("\n____________________________________________\n"); } else { if ( (mediafinal >=4) || (mediafinal < 6)) printf("Sua nota total: %.1f \n", x); printf("Sua media: %.1f\n", mediafinal); printf("Você nao foi aprovado, ruim"); printf("\n____________________________________________\n"); } else { if( (mediafinal >=6) || (mediafinal < 8)) printf("Sua nota total: %.1f \n", x); printf("Sua media: %.1f\n", mediafinal); printf("Você foi aprovado, bom"); printf("\n____________________________________________\n"); } } eu irei continuar so com mais um else e depois finaliza com "voce deseja continuar?", acho que deu para entender
  5. Visualg- erro no algoritmo calculadora

    olá, irei colocar a raiz do delta... um pequeno erro de matemática :/ . Eu estou usando esse site para a formula de bhaskara> http://brasilescola.uol.com.br/matematica/formula-bhaskara.htm < o exemplo que to usando ta nele. aqui ta o código : Algoritmo "calculadora" // objeitvo: para estudos // criador: mateus Costa // 10/07/2017 Var num_1, num_2, num, desconto, juros, A, B, C, j, i, op: real operacao, resp, opcao, enter, x: caracter Inicio repita limpatela escreval ("____________________________________________________________") escreval ("calculadora") escreval ("Digite o tipo da operação exemplo: (-),(+),(x),(/),(%) (!)") escreval ("(bhaskara)") escreval ("____________________________________________________________") leia(operacao) escolha (operacao) caso "bhaskara" escreval ("formula: (b)2 - 4.a.c") escreval ("digite a letra A:") leia(A) escreval ("digite a letra B:") leia(B) escreval ("digite a letra c:") leia(C) escreval ("..............................") escreval ("Reposta:",B*B - 4*A*c) escreval("...............................") escreval("Aperter Enter para continuar") leia(enter) escreval ("Segunda formula:– b ± delta") escreval (" X= -----------") escreval (" 2.A") j <- 0 i <- 0 enquanto (j * i <= B*B - 4*A*c ) faca escreva (j, " ") j <- j + 0.1 i <- i + 0.1 fimenquanto escreval ("resposta fatorial do delta:", j ) escreval ("resposta fatorial do delta:", i ) escreval (" ",-B + j:1:0 ) escreval("x=----") escreval (" ",2*A) escreval ("resposta da Primeira opção de X:",(-B+j)/(2*A):1:0 ) escreval ("resposta da segunda opção X:",(-B-j)/(2*A):1:0 ) escreval ("--------------------------") escreval ("Portanto, as raízes da equação:") escreval ((A),"+",(B),"x",(C),"=","0"," são ",(-B+j)/(2*A):1:0," e ",(-B-j)/(2*A):1:0) escreval ("--------------------------") caso "!" escreval("digite o número desejado para a raiz quadrada:") leia(num) escreval("resultado é:", num * num) caso "+" escreval ("digite o primeiro numero") leia(num_1) escreval ("digite o segundo numero") leia(num_2) escreval ("Resultado:",num_1 + num_2) caso "-" escreval ("digite o primeiro numero") leia(num_1) escreval ("digite o segundo numero") leia(num_2) escreval ("Resultado:",num_1 - num_2) caso "x" escreval ("digite o primeiro numero") leia(num_1) escreval ("digite o segundo numero") leia(num_2) escreval ("Resultado:",num_1 * num_2) caso "/" escreval ("digite o primeiro numero") leia(num_1) escreval ("digite o segundo numero") leia(num_2) escreval ("Resultado:",num_1 / num_2) caso "%" escreval ("digite UM numero:") leia (num) escreval ("escolha opção 1, para:desconto") escreval ("escolha opção 2, para:juros") leia(opcao) escolha (opcao) caso "1" escreval ("digite o desconto:") leia(desconto) escreval ("resultado é:", num - num * (desconto) / 100) escreval ("desconto:", num * (desconto) / 100) caso "2" escreval ("digite o juros:") leia(juros) escreval ("resultado é:", num + num *(juros) / 100) escreval ("Juros:", num * (juros) / 100) fimescolha fimescolha fimescolha Escreval ("voce deseja continuar sim ou não:?") leia(resp) ate(resp <> "sim") e (resp <> "s") limpatela Fimalgoritmo
  6. Visualg- erro no algoritmo calculadora

    acho que entenderá melhor com imagens o "J" e "I" foi a maneira que encontrei de acha o numero da raiz tipo raiz de 25 e 5, porque ? 5x5 = 25 entendeu , J x I = 25 ... opa, o final da imagem o resultado se repeti 2 vezes... (foi mal) acabei repetindo o (-B+j)/(2*A) ...rs.
  7. Visualg- erro no algoritmo calculadora

    olá amigo, obg por ter respondido. primeiro: a parte da "formula" seria só para lembrar ... tanto a mim e ao usuário. Só um detalhe irei explicar o problema com maiores detalhes agora... eu estou fazendo a equação do 2 grau inteira, consegui fazer ela funcionar só que , quando chegar na parte de dividir (é onde estar o problema) ele não dividi... porque? eu fiz isso: j <- 0 i <- 0 enquanto (j * i <= B*B - 4*A*c ) faca escreva (j, " ") j <- j + 0.1 i <- i + 0.1 quando o delta aparece por exemplo 196 que é 14 x 14. porém, eu não sabia como fazer para acha esse 14 x 14 entende? para chegar nessa parte > escreval ("Segunda formula:– b ± delta") escreval (" X= -----------") escreval (" 2.A") como você pode ver, essa parte você precisa saber qual e o numero que dar a raiz, essa foi a maneira que eu consegui usando o "enquanto", ate chegar no numero que dar na raiz multiplicando 0,1 + 0,1 ate chegar no resultado.... porém quando chega ele dar numero quebrado, com virgula e o resultado final fica diferente, então eu usei o "1:0" para aproximar, e isso funcionou e faltava só dividir... ai que veio minha tristeza ele dar o erro... não consigo solucionar isso. espero que tenha entendido :/ qualquer coisa envio print dos erros e dos algoritmos.
  8. Olá, estou praticando um pouco a linguagem no visualg, nos meus tempos livres eu fico estudando, porém quando eu estava fazendo o algoritmo esta dando erro e não consigo sair dali já tem 2 dias...vou mostra o algoritmo o problema ta no "Bhaskara" não consigo dividir , problema é esse "escreval ("resposta da Primeira opção:", -B + j:1:0(/2*A) )"......... simplesmente não vai Algoritmo "calculadora" // objeitvo: para estudos // criador: mateus Costa // 10/07/2017 Var num_1, num_2, num, desconto, juros, A, B, C, j, i, op : real operacao, resp, opcao, x, enter: caracter Inicio repita limpatela escreval ("calculadora") escreval ("Digite o tipo da operação exemplo: (-),(+),(x),(/),(%) (!)") escreval ("mais exemplo: (bhaskara)") leia(operacao) escolha (operacao) caso "bhaskara" escreval ("formula: (b)2 - 4.a.c") escreval ("digite a letra A:") leia(A) escreval ("digite a letra B:") leia(B) escreval ("digite a letra c:") leia(C) escreval ("....") escreval ("Reposta:",B*B - 4*A*c) escreval("....") escreval("Aperter Enter para continuar") leia(enter) escreval ("Segunda formula:– b ± delta") escreval (" X= -----------") escreval (" 2.A") j <- 0 i <- 0 enquanto (j * i <= B*B - 4*A*c ) faca escreva (j, " ") j <- j + 0.1 i <- i + 0.1 fimenquanto escreval ("resposta fatorial do delta:", j ) escreval ("resposta fatorial do delta:", i ) escreval (" ",-B + j:1:0 ) escreval("x=--") escreval (" ",2*A) escreval ("resposta da Primeira opção:", -B + j:1:0(/2*A) ) caso "!" escreval("digite o número desejado para a raiz quadrada:") leia(num) escreval("resultado é:", num * num) caso "+" escreval ("digite o primeiro numero") leia(num_1) escreval ("digite o segundo numero") leia(num_2) escreval ("Resultado:",num_1 + num_2) caso "-" escreval ("digite o primeiro numero") leia(num_1) escreval ("digite o segundo numero") leia(num_2) escreval ("Resultado:",num_1 - num_2) caso "x" escreval ("digite o primeiro numero") leia(num_1) escreval ("digite o segundo numero") leia(num_2) escreval ("Resultado:",num_1 * num_2) caso "/" escreval ("digite o primeiro numero") leia(num_1) escreval ("digite o segundo numero") leia(num_2) escreval ("Resultado:",num_1 / num_2) caso "%" escreval ("digite UM numero:") leia (num) escreval ("escolha opção 1, para:desconto") escreval ("escolha opção 2, para:juros") leia(opcao) escolha (opcao) caso "1" escreval ("digite o desconto:") leia(desconto) escreval ("resultado é:", num - num * (desconto) / 100) escreval ("desconto:", num * (desconto) / 100) caso "2" escreval ("digite o juros:") leia(juros) escreval ("resultado é:", num + num *(juros) / 100) escreval ("Juros:", num * (juros) / 100) fimescolha fimescolha fimescolha Escreval ("voce deseja continuar sim ou não:?") leia(resp) ate(resp <> "sim") limpatela Fimalgoritmo

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×