• Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.

mateus costa r

Membros Juniores
  • Total de itens

    4
  • Registro em

  • Última visita

  • Qualificações

    N/D

Reputação

2

Sobre mateus costa r

  1. olá, irei colocar a raiz do delta... um pequeno erro de matemática :/ . Eu estou usando esse site para a formula de bhaskara> http://brasilescola.uol.com.br/matematica/formula-bhaskara.htm < o exemplo que to usando ta nele. aqui ta o código : Algoritmo "calculadora" // objeitvo: para estudos // criador: mateus Costa // 10/07/2017 Var num_1, num_2, num, desconto, juros, A, B, C, j, i, op: real operacao, resp, opcao, enter, x: caracter Inicio repita limpatela escreval ("____________________________________________________________") escreval ("calculadora") escreval ("Digite o tipo da operação exemplo: (-),(+),(x),(/),(%) (!)") escreval ("(bhaskara)") escreval ("____________________________________________________________") leia(operacao) escolha (operacao) caso "bhaskara" escreval ("formula: (b)2 - 4.a.c") escreval ("digite a letra A:") leia(A) escreval ("digite a letra B:") leia(B) escreval ("digite a letra c:") leia(C) escreval ("..............................") escreval ("Reposta:",B*B - 4*A*c) escreval("...............................") escreval("Aperter Enter para continuar") leia(enter) escreval ("Segunda formula:– b ± delta") escreval (" X= -----------") escreval (" 2.A") j <- 0 i <- 0 enquanto (j * i <= B*B - 4*A*c ) faca escreva (j, " ") j <- j + 0.1 i <- i + 0.1 fimenquanto escreval ("resposta fatorial do delta:", j ) escreval ("resposta fatorial do delta:", i ) escreval (" ",-B + j:1:0 ) escreval("x=----") escreval (" ",2*A) escreval ("resposta da Primeira opção de X:",(-B+j)/(2*A):1:0 ) escreval ("resposta da segunda opção X:",(-B-j)/(2*A):1:0 ) escreval ("--------------------------") escreval ("Portanto, as raízes da equação:") escreval ((A),"+",(B),"x",(C),"=","0"," são ",(-B+j)/(2*A):1:0," e ",(-B-j)/(2*A):1:0) escreval ("--------------------------") caso "!" escreval("digite o número desejado para a raiz quadrada:") leia(num) escreval("resultado é:", num * num) caso "+" escreval ("digite o primeiro numero") leia(num_1) escreval ("digite o segundo numero") leia(num_2) escreval ("Resultado:",num_1 + num_2) caso "-" escreval ("digite o primeiro numero") leia(num_1) escreval ("digite o segundo numero") leia(num_2) escreval ("Resultado:",num_1 - num_2) caso "x" escreval ("digite o primeiro numero") leia(num_1) escreval ("digite o segundo numero") leia(num_2) escreval ("Resultado:",num_1 * num_2) caso "/" escreval ("digite o primeiro numero") leia(num_1) escreval ("digite o segundo numero") leia(num_2) escreval ("Resultado:",num_1 / num_2) caso "%" escreval ("digite UM numero:") leia (num) escreval ("escolha opção 1, para:desconto") escreval ("escolha opção 2, para:juros") leia(opcao) escolha (opcao) caso "1" escreval ("digite o desconto:") leia(desconto) escreval ("resultado é:", num - num * (desconto) / 100) escreval ("desconto:", num * (desconto) / 100) caso "2" escreval ("digite o juros:") leia(juros) escreval ("resultado é:", num + num *(juros) / 100) escreval ("Juros:", num * (juros) / 100) fimescolha fimescolha fimescolha Escreval ("voce deseja continuar sim ou não:?") leia(resp) ate(resp <> "sim") e (resp <> "s") limpatela Fimalgoritmo
  2. acho que entenderá melhor com imagens o "J" e "I" foi a maneira que encontrei de acha o numero da raiz tipo raiz de 25 e 5, porque ? 5x5 = 25 entendeu , J x I = 25 ... opa, o final da imagem o resultado se repeti 2 vezes... (foi mal) acabei repetindo o (-B+j)/(2*A) ...rs.
  3. olá amigo, obg por ter respondido. primeiro: a parte da "formula" seria só para lembrar ... tanto a mim e ao usuário. Só um detalhe irei explicar o problema com maiores detalhes agora... eu estou fazendo a equação do 2 grau inteira, consegui fazer ela funcionar só que , quando chegar na parte de dividir (é onde estar o problema) ele não dividi... porque? eu fiz isso: j <- 0 i <- 0 enquanto (j * i <= B*B - 4*A*c ) faca escreva (j, " ") j <- j + 0.1 i <- i + 0.1 quando o delta aparece por exemplo 196 que é 14 x 14. porém, eu não sabia como fazer para acha esse 14 x 14 entende? para chegar nessa parte > escreval ("Segunda formula:– b ± delta") escreval (" X= -----------") escreval (" 2.A") como você pode ver, essa parte você precisa saber qual e o numero que dar a raiz, essa foi a maneira que eu consegui usando o "enquanto", ate chegar no numero que dar na raiz multiplicando 0,1 + 0,1 ate chegar no resultado.... porém quando chega ele dar numero quebrado, com virgula e o resultado final fica diferente, então eu usei o "1:0" para aproximar, e isso funcionou e faltava só dividir... ai que veio minha tristeza ele dar o erro... não consigo solucionar isso. espero que tenha entendido :/ qualquer coisa envio print dos erros e dos algoritmos.
  4. Olá, estou praticando um pouco a linguagem no visualg, nos meus tempos livres eu fico estudando, porém quando eu estava fazendo o algoritmo esta dando erro e não consigo sair dali já tem 2 dias...vou mostra o algoritmo o problema ta no "Bhaskara" não consigo dividir , problema é esse "escreval ("resposta da Primeira opção:", -B + j:1:0(/2*A) )"......... simplesmente não vai Algoritmo "calculadora" // objeitvo: para estudos // criador: mateus Costa // 10/07/2017 Var num_1, num_2, num, desconto, juros, A, B, C, j, i, op : real operacao, resp, opcao, x, enter: caracter Inicio repita limpatela escreval ("calculadora") escreval ("Digite o tipo da operação exemplo: (-),(+),(x),(/),(%) (!)") escreval ("mais exemplo: (bhaskara)") leia(operacao) escolha (operacao) caso "bhaskara" escreval ("formula: (b)2 - 4.a.c") escreval ("digite a letra A:") leia(A) escreval ("digite a letra B:") leia(B) escreval ("digite a letra c:") leia(C) escreval ("....") escreval ("Reposta:",B*B - 4*A*c) escreval("....") escreval("Aperter Enter para continuar") leia(enter) escreval ("Segunda formula:– b ± delta") escreval (" X= -----------") escreval (" 2.A") j <- 0 i <- 0 enquanto (j * i <= B*B - 4*A*c ) faca escreva (j, " ") j <- j + 0.1 i <- i + 0.1 fimenquanto escreval ("resposta fatorial do delta:", j ) escreval ("resposta fatorial do delta:", i ) escreval (" ",-B + j:1:0 ) escreval("x=--") escreval (" ",2*A) escreval ("resposta da Primeira opção:", -B + j:1:0(/2*A) ) caso "!" escreval("digite o número desejado para a raiz quadrada:") leia(num) escreval("resultado é:", num * num) caso "+" escreval ("digite o primeiro numero") leia(num_1) escreval ("digite o segundo numero") leia(num_2) escreval ("Resultado:",num_1 + num_2) caso "-" escreval ("digite o primeiro numero") leia(num_1) escreval ("digite o segundo numero") leia(num_2) escreval ("Resultado:",num_1 - num_2) caso "x" escreval ("digite o primeiro numero") leia(num_1) escreval ("digite o segundo numero") leia(num_2) escreval ("Resultado:",num_1 * num_2) caso "/" escreval ("digite o primeiro numero") leia(num_1) escreval ("digite o segundo numero") leia(num_2) escreval ("Resultado:",num_1 / num_2) caso "%" escreval ("digite UM numero:") leia (num) escreval ("escolha opção 1, para:desconto") escreval ("escolha opção 2, para:juros") leia(opcao) escolha (opcao) caso "1" escreval ("digite o desconto:") leia(desconto) escreval ("resultado é:", num - num * (desconto) / 100) escreval ("desconto:", num * (desconto) / 100) caso "2" escreval ("digite o juros:") leia(juros) escreval ("resultado é:", num + num *(juros) / 100) escreval ("Juros:", num * (juros) / 100) fimescolha fimescolha fimescolha Escreval ("voce deseja continuar sim ou não:?") leia(resp) ate(resp <> "sim") limpatela Fimalgoritmo