Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.

vinifla81

Membros Juniores
  • Total de itens

    11
  • Registro em

  • Última visita

  • Qualificações

    N/D

Reputação

1

Sobre vinifla81

  1. Java programa em java dando erro

    Eu entendi que o problema é no for, mas ainda não vi nenhuma solução sobre isso. Eu sou iniciante nisso, então não sou obrigado a saber sobre isso. Você não em deu uma dica, você apenas disse que o problema é no incremento e pronto. Não teve ajuda sobre isso, apenas li ignorâncias, enfim, coisas de seres humanos adicionado 1 minuto depois Pode fechar o tópico, admin... Vou ver se encontro em outro lugar algo sobre isso
  2. Java programa em java dando erro

    eu fiz um código no java para agendamento de salas, porém, quando coloco para rodar ele aparece as opções, porém, o programa não da continuidade. por exemplo, caso eu aperte para agendar uma sala, ele diz que foi agendada. quando eu quero verificar se a sala foi agendado eu não consigo,pois o programa fica parado. alguém consegue resolver isso para mim? package nasa; import java.util.Scanner; public class Nasa { public static void main(String[] args) { // TODO Auto-generated method stub // Algoritmo "Agendamento" // Var @SuppressWarnings("resource") Scanner sc = new Scanner (System.in); String[] vet_nome = new String[8]; int[] vet_poltrona = new int[8]; String nome; int opcao,poltrona,i,confirma; // inicio System.out.println ("==================================================================="); System.out.println ("|| OLÁ, SEJA BEM VINDO(A) AO SISTEMA DE AGENDAMENTO DA N.A.S.A ||"); System.out.println ("==================================================================="); System.out.println(""); System.out.println(""); System.out.println("# 1 - Realizar reservas de sala #"); System.out.println("# 2 - Verificar disponibilidade de salas #"); System.out.println("# 3 - Liberar sala escolhida #"); System.out.println("# 4 - Finalizar o programa #"); System.out.println("Digite a opção"); opcao = Integer.parseInt(sc.nextLine()); switch (opcao) { case 1: System.out.println("Qual seu nome?"); nome = sc.nextLine(); System.out.println("Qual a sala desejada?"); poltrona = sc.nextInt() -1; if (vet_poltrona[poltrona] == 0) { vet_nome[poltrona] = nome; vet_poltrona[poltrona] = 1; System.out.println("Reserva de sala feita com sucesso"); } else { System.out.println("Desculpe, esta sala já está ocupada."); } break; case 2: for (i = 1; i <= 8; ) { if (vet_poltrona[i] == 0) { System.out.println("A sala" + i + " está desocupada"); System.out.println("A sala" + (i+1) + " está desocupada"); System.out.println("A sala" + (i+2) + " está desocupada"); System.out.println("A sala" + (i+3) + " está desocupada"); System.out.println("A sala" + (i+4) + " está desocupada"); System.out.println("A sala" + (i+5) + " está desocupada"); System.out.println("A sala" + (i+6) + " está desocupada"); System.out.println("A sala" + (i+7) + " está desocupada"); } break; } case 3 : System.out.println("Qual reserva de sala você deseja excluir?"); poltrona = Integer.parseInt(sc.nextLine()); if ( vet_poltrona[poltrona] == 1) { System.out.println("Tem certeza de que deseja excluir esta reserva? SIM = 1 NAO = 0"); confirma = Integer.parseInt(sc.nextLine()); if (confirma == 1) { vet_poltrona[poltrona] = 0; vet_nome[poltrona] = " "; System.out.println("Reserva de sala excluida com sucesso"); } else { System.out.println("Reserva de sala não alterada"); } } else { System.out.println("Esta sala já está desocupada"); } break; case 4: System.out.println("Programa finalizado com sucesso"); default: System.out.println("Código invalido"); } } }
  3. Java programa em java dando erro

    valeu cara, consegui ajeitar. o meu único problema agora é dar continuidade ao código, pois, quando coloco ele para rodar e faço a escolha de algumas opções ele fala que a sala 1 esta desocupada por exemplo e o código fica parado aí
  4. Java programa em java dando erro

    package nasa; import java.util.Scanner; public class Nasa { public static void main(String[] args) { // TODO Auto-generated method stub // Algoritmo "Agendamento" // Var Scanner sc = new Scanner (System.in); String[] vet_nome = new String[8]; int[] vet_poltrona = new int[8]; String nome; int opcao = 0,poltrona,i,confirma,one; // inicio while (opcao != 5) { System.out.println ("==================================================================="); System.out.println ("|| OLÁ, SEJA BEM VINDO(A) AO SISTEMA DE AGENDAMENTO DA N.A.S.A ||"); System.out.println ("==================================================================="); System.out.println(""); System.out.println(""); System.out.println("# 1 - Realizar reservas de sala #"); System.out.println("# 2 - Verificar disponibilidade de salas #"); System.out.println("# 3 - Liberar sala escolhida #"); System.out.println("# 4 - Finalizar o programa #"); System.out.println("Digite a opção"); opcao = Integer.parseInt(sc.nextLine()); switch (opcao) { case 1: System.out.println("Qual seu nome?"); nome = sc.nextLine(); System.out.println("Qual a sala desejada?"); poltrona = Integer.parseInt(sc.nextLine()); if (vet_poltrona == null) { nome = vet_nome[poltrona]; one = vet_poltrona[poltrona]; System.out.println("Reserva de sala feita com sucesso"); } else { System.out.println("Desculpe, esta sala já está ocupada."); } break; case 2: for (i = 1; i <= 8;) { if (vet_poltrona == null) { System.out.println("A sala"+ i + " está desocupada"); } } break; case 3 : System.out.println("Qual reserva de sala você deseja excluir?"); poltrona = Integer.parseInt(sc.nextLine()); if ( vet_poltrona[poltrona] == 1) { System.out.println("Tem certeza de que deseja excluir esta reserva? SIM = 1 NAO = 0"); confirma = Integer.parseInt(sc.nextLine()); if (confirma == 1) { System.out.println("Reserva de sala excluida com sucesso"); } else { System.out.println("Reserva de sala não alterada"); } } else { System.out.println("Esta sala já está desocupada"); } break; case 4: System.out.println("Programa finalizado com sucesso"); default: System.out.println("Código invalido"); } } } } O que está errado nesse meu código? adicionado 2 minutos depois O código no visual g é esse aqui var vet_nome:vetor[1..8] de caracter vet_poltrona:vetor[1..8] de inteiro nome:caracter opcao,poltrona,i,confirma:inteiro inicio enquanto opcao<>5 faca escreval ("===================================================================") escreval ("|| OLÁ, SEJA BEM VINDO(A) AO SISTEMA DE AGENDAMENTO DA N.A.S.A ||") escreval ("===================================================================") escreval("") escreval("") escreval("# 1 - Realizar reservas de sala #") escreval("# 2 - Verificar disponibilidade de salas #") escreval("# 3 - Liberar sala escolhida #") escreval("# 4 - Finalizar o programa #") escreval escreval("Digite a opção") leia(opcao) escolha opcao caso 1 escreval("Qual o seu nome?") leia(nome) escreval("Qual a sala desejada?") leia(poltrona) se vet_poltrona[poltrona]=0 então vet_nome[poltrona]<-nome vet_poltrona[poltrona]<-1 escreval("Reserva de sala feita com sucesso.") senao escreval("Desculpe, esta sala já está ocupada.") fimse caso 2 para i de 1 ate 8 faca se vet_poltrona[i]=0 então escreval("A sala",i," está desocupada.") fimse fimpara caso 3 escreval("Qual reserva de sala você deseja excluir?") leia(poltrona) se vet_poltrona[poltrona]=1 então escreval("Tem certeza de que deseja excluir esta reserva? SIM = 1 NAO = 0") leia(confirma) se confirma=1 então vet_poltrona[poltrona]<-0 vet_nome[poltrona]<-" " escreval("Reserva de sala excluida com sucesso.") senao escreval("Reserva de sala não alterada") fimse senao escreval("Esta sala já está desocupada.") fimse caso 4 escreval("Programa finalizado com sucesso.") outrocaso escreval("Código invalido.") fimescolha fimenquanto fimalgoritmo
  5. Java Preciso passar para java

    Ok, como passo isso para java vet_nome[poltrona]<-nome vet_poltrona[poltrona]<-1 adicionado 0 minutos depois Essa parte tambem nao sei
  6. Java Preciso passar para java

    algoritmo "semnome" // Autor : eu // Data : 12/09/2017 var vet_nome:vetor[1..8] de caracter vet_poltrona:vetor[1..8] de inteiro nome:caracter opcao,poltrona,i,confirma:inteiro inicio enquanto opcao<>5 faca escreval ("===================================================================") escreval ("|| OLÁ, SEJA BEM VINDO(A) AO SISTEMA DE AGENDAMENTO DA N.A.S.A ||") escreval ("===================================================================") escreval("") escreval("") escreval("# 1 - Realizar reservas de sala #") escreval("# 2 - Verificar disponibilidade de salas #") escreval("# 3 - Liberar sala escolhida #") escreval("# 4 - Finalizar o programa #") escreval escreval("Digite a opção") leia(opcao) escolha opcao caso 1 escreval("Qual o seu nome?") leia(nome) escreval("Qual a sala desejada?") leia(poltrona) se vet_poltrona[poltrona]=0 então vet_nome[poltrona]<-nome vet_poltrona[poltrona]<-1 escreval("Reserva de sala feita com sucesso.") senao escreval("Desculpe, esta sala já está ocupada.") fimse caso 2 para i de 1 ate 8 faca se vet_poltrona[i]=0 então escreval("A sala",i," está desocupada.") fimse fimpara caso 3 escreval("Qual reserva de sala você deseja excluir?") leia(poltrona) se vet_poltrona[poltrona]=1 então escreval("Tem certeza de que deseja excluir esta reserva? SIM = 1 NAO = 0") leia(confirma) se confirma=1 então vet_poltrona[poltrona]<-0 vet_nome[poltrona]<-" " escreval("Reserva de sala excluida com sucesso.") senao escreval("Reserva de sala não alterada") fimse senao escreval("Esta sala já está desocupada.") fimse caso 4 escreval("Programa finalizado com sucesso.") outrocaso escreval("Código invalido.") fimescolha fimenquanto fimalgoritmo Alguém poderia passar esse código que esta no visual G para o java para mim, por favor?
  7. VisualG organização algoritmo

    Eu sou bem amador em programação e não estou entendendo isso da repetição. Se puder me dar uma ajuda eu agradeço
  8. VisualG organização algoritmo

    Fiz algumas modificações, não sei se melhorou. algoritmo "Tijolando 2.0" // Função : // Autor : // Data : 29/08/2017 // Seção de Declarações var d,op,cm,am,qtd,area1,area2,area3:real inicio // Entradas escreval("Escolha uma das opções de tijolo") escreval("Tijolo 6 furos de dimensões 9x14x19 -> OPÇÃO 1") escreval("Tijolo 8 furos de dimensões 9x19x24 -> OPÇÃO 2") escreval("Tijolo 12 furos de dimensões 14x19x29 -> OPÇÃO 3") leia (op) escreval("Agora escolha a forma de colocação do tijolo") escreval("1/2 vez (Tijolos em pé) -> OPÇÃO 1") escreval("1 vez (Tijolos deitados) -> OPÇÃO 2") leia (d) escreval("Informe o comprimento desejado do muro em metros a ser construído") leia (cm) escreval("Informe a altura desejada do muro em metros a ser construído") leia (am) // Processamento qtd<-(cm * am) area1<-0.0266 area2<-0.0456 area3<-0.0551 // Saidas se (op = 1) e (d = 1) então escreval("Você precisará de:",qtd/area1," tijolos para constuir o muro") escreval("Para não faltar, compre:",1.1 * qtd/area1+1:2:0, " tijolos ") escreval("Você precisará também de:",(qtd/area1)/250+1:2:0," saco(s) de cimento") escreval("O custo médio é de: R$" ,((qtd/area1) * 0.35) + 35 * ((qtd/area1)/250)+1:5:2, " ") fimse se (op = 2) e (d = 1) então escreval("Você precisará de:",qtd/area2," tijolos para constuir o muro") escreval("Para não faltar, compre:",1.1 * qtd/area2+1:2:0, " tijolos ") escreval("Você precisará também de:",(qtd/area2)/250+1:2:0," saco(s) de cimento") escreval("O custo médio é de: R$" ,((qtd/area2) * 0.50) + 35 * ((qtd/area2)/250)+1:5:2, " ") fimse se (op = 3) e (d = 1) então escreval("Você precisará de:",qtd/area3," tijolos para constuir o muro") escreval("Para não faltar, compre:",1.1 * qtd/area3+1:2:0, " tijolos ") escreval("Você precisará também de:",(qtd/area3)/250+1:2:0," saco(s) de cimento") escreval("O custo médio é de: R$" ,((qtd/area3) * 0.80) + 35 * ((qtd/area3)/250)+1:5:2, " ") fimse se (op = 1) e (d = 2) então escreval("Você precisará de:",(qtd/area1)*2 ," tijolos para constuir o muro") escreval("Para não faltar, compre:",1.1 * (qtd/area1)*2 +1:2:0, " tijolos ") escreval("Você precisará também de:",((qtd/area1)*2)/250+1:2:0," saco(s) de cimento") escreval("O custo médio é de: R$" ,(((qtd/area1)*2) * 0.35) + 35 * (((qtd/area1)*2)/250)+1:5:2, " ") fimse se (op = 2) e (d = 2) então escreval("Você precisará de:",(qtd/area2)*2," tijolos para constuir o muro") escreval("Para não faltar, compre:",1.1 * (qtd/area2)*2 +1:2:0, " tijolos ") escreval("Você precisará também de:",((qtd/area2)*2)/250+1:2:0," saco(s) de cimento") escreval("O custo médio é de: R$" ,(((qtd/area2)*2) * 0.50) + 35 * (((qtd/area2)*2)/250)+1:5:2, " ") fimse se (op = 3) e (d = 2) então escreval("Você precisará de:",(qtd/area3)*2," tijolos para constuir o muro") escreval("Para não faltar, compre:",1.1 * (qtd/area3)*2 +1:2:0, " tijolos ") escreval("Você precisará também de:",((qtd/area3)*2)/250+1:2:0," saco(s) de cimento") escreval("O custo médio é de: R$" ,(((qtd/area3)*2) * 0.80) + 35 * (((qtd/area3)*2)/250)+1:5:2, " ") fimse fimalgoritmo
  9. Eu fiz um algoritmo no visual g, porém, o meu professor me disse que eu deveria organizar ele para que ficasse mais fácil quando for passar para Android. Não entendi muito bem e o questionei várias vezes sem sucesso. Ele me disse que na entrada só poderia ter ler e escreva e na saída não poderia existir se então. Fiquei confuso e agradeceria se alguém puder me ajudar. O algoritmo é esse: algoritmo "sem nome" // Função : // Autor : // Data : 29/08/2017 // Seção de Declarações var d,op,cm,am,qtd,qtd1,qtd2,qtd3,qtd4,qtd5:real inicio // Entradas escreval("Escolha uma das opções de tijolo") escreval("Tijolo 6 furos de dimensões 9x14x19 -> OPÇÃO 1") escreval("Tijolo 8 furos de dimensões 9x19x24 -> OPÇÃO 2") escreval("Tijolo 12 furos de dimensões 14x19x29 -> OPÇÃO 3") leia (op) escreval("Agora escolha a forma de colocação do tijolo") escreval("1/2 vez (Tijolos em pé) -> OPÇÃO 1") escreval("1 vez (Tijolos deitados) -> OPÇÃO 2") leia (d) escreval("Informe o comprimento desejado do muro em metros a ser construído") leia (cm) escreval("Informe a altura desejada do muro em metros a ser construído") leia (am) // Processamento qtd<-(cm * am)/(0.2394) qtd1<-(cm * am)/(0.4104) qtd2<-(cm * am)/(0.7714) qtd3<-((cm * am)/(0.2394)) * 2 qtd4<-((cm * am)/(0.4104)) * 2 qtd5<-((cm * am)/(0.7714)) * 2 // Saidas se (op = 1) e (d = 1) então escreval("Você precisará de:",qtd," tijolos para constuir o muro") escreval("Para não faltar, compre:",1.1 * qtd+1:2:0, " tijolos ") escreval("Você precisará também de:",qtd/250+1:2:0," saco(s) de cimento") escreval("O custo médio é de: R$" ,(qtd * 0.35) + 35 * (qtd/250)+1:5:2, " ") fimse se (op = 2) e (d = 1) então escreval("Você precisará de:",qtd1," tijolos para constuir o muro") escreval("Para não faltar, compre:",1.1 * qtd1+1:2:0, " tijolos ") escreval("Você precisará também de:",qtd1/250+1:2:0," saco(s) de cimento") escreval("O custo médio é de: R$" ,(qtd1 * 0.50) + 35 * (qtd1/250)+1:5:2, " ") fimse se (op = 3) e (d = 1) então escreval("Você precisará de:",qtd2," tijolos para constuir o muro") escreval("Para não faltar, compre:",1.1 * qtd2+1:2:0, " tijolos ") escreval("Você precisará também de:",qtd2/250+1:2:0," saco(s) de cimento") escreval("O custo médio é de: R$" ,(qtd2 * 0.80) + 35 * (qtd2/250)+1:5:2, " ") fimse se (op = 1) e (d = 2) então escreval("Você precisará de:",qtd3," tijolos para constuir o muro") escreval("Para não faltar, compre:",1.1 * qtd3+1:2:0, " tijolos ") escreval("Você precisará também de:",qtd3/250+1:2:0," saco(s) de cimento") escreval("O custo médio é de: R$" ,(qtd3 * 0.35) + 35 * (qtd3/250)+1:5:2, " ") fimse se (op = 2) e (d = 2) então escreval("Você precisará de:",qtd4," tijolos para constuir o muro") escreval("Para não faltar, compre:",1.1 * qtd4+1:2:0, " tijolos ") escreval("Você precisará também de:",qtd4/250+1:2:0," saco(s) de cimento") escreval("O custo médio é de: R$" ,(qtd4 * 0.50) + 35 * (qtd4/250)+1:5:2, " ") fimse se (op = 3) e (d = 2) então escreval("Você precisará de:",qtd5," tijolos para constuir o muro") escreval("Para não faltar, compre:",1.1 * qtd5+1:2:0, " tijolos ") escreval("Você precisará também de:",qtd5/250+1:2:0," saco(s) de cimento") escreval("O custo médio é de: R$" ,(qtd5 * 0.80) + 35 * (qtd5/250)+1:2:0, " ") fimse fimalgoritmo
  10. VisualG horários

    olá, fiz um algoritmo no visual g que você pode escolher uma das salas que existem num certo local para permanecer nela. Eu preciso colocar algum código que mostre o tempo restante que a pessoa ainda tem dentro dessa sala. Cada pessoa pode ficar 3 horas dentro da sala... Alguém sabe como posso botar essa espécie de relógio que diga quanto tempo ainda resta? quando faltar 10 minutos por exemplo, ele exibir uma mensagem dizendo que resta apenas 10 minutos. obrigado
  11. Olá, estou tentando fazer um algoritmo para o visual g ao qual preciso saber a quantidade de blocos necessários para a construção de um navio, porém, eu preciso dar uma opção de escolha de 3 tipos de blocos(tamanhos diferentes), se estão deitados ou em pé, e ao fim calcular a quantidade de blocos para construir esse navio. A minha dificuldade está sendo referente a conseguir associar essas duas escolhas(em pé ou deitado junto com o tipo do bloco). Afinal, se eu colocar o bloco deitado terei que utilizar mais bloco do que se colocar em pé para ganhar altura no navio.Alguém tem alguma dica?

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×