Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.

LuisGCarv

Membros Juniores
  • Total de itens

    10
  • Registro em

  • Última visita

  • Qualificações

    N/D
  1. C Sistema de locadora em C

    Eu to passando pelo mesmo problema, você já começou a fazer o seu?
  2. C Variável string com espaço

    Ah, valeu pela dica, @MassakiMsk Se caso eu precisar usar esse tipo de scanf do primeiro exemplo mais de uma vez, eu vou ter que repetir o getchar em todos eles?
  3. C Como uso FOR nessa questão ???

    Eu usaria dois laços for, um para a linha e outra para a coluna. E usaria o comando if para decidir quando é " " e quando é "*", mas eu não sei qual condição você poderia utilizar.
  4. C Variável string com espaço

    Então, a minha dúvida é super simples. Eu só gostaria de saber se existe algum comando no Dev C++ que permite que você coloque um texto/frase com espaços entre as palavras em uma variável do tipo string. Eu sei que no programa não existe variável desse tipo, e eu já tenho a biblioteca string.h no meu código, mas toda vez que eu tento acrescentar um texto com espaços, o Dev C++ divide as palavras espaçadas em variáveis diferentes, ou seja, cada palavra da frase vai pra uma variável diferente do meu programa, entendem? Vocês poderiam me tirar essa dúvida? Agradeço desde já pela atenção.
  5. @Simon Viegas , muito obrigado pelos esclarecimentos! O pior é que eu estava fazendo errado já faz algum tempo e eu nem sei porque, estou revendo na apostila e está da forma que você explicou, acho que foi pura falta de atenção. adicionado 1 minuto depois Mas mesmo não tendo um vetor chamado NCliente, o programa aceitou daquela forma. Por quê?
  6. @Simon Viegas, já editei, muito obrigado pela dica.
  7. Eu estou com alguns problemas pra fazer um programa que tenha um registro dentro de uma matriz com duas dimensões no VisualG. Eu consigo fazer registro com um vetor de boa, o problema só surge quando eu preciso de dois índices pra definir os elementos. Segue o código do meu programa. O programa dá erro na linha que eu peço pra ler Automoveis.MAutomovel[i,j] Algoritmo "MovimentacaoDeLocacao" Tipo Clientela = registro Codigo : inteiro NCliente : caractere Soma : real fimregistro Carros = registro MAutomovel : caractere ValorLoc : real fimregistro Var // Seção de Declarações das variáveis Clientes : Vetor [1..100] de Clientela Automoveis : Vetor [1..100,1..100] de Carros i, j , n , p , class : inteiro Inicio // Seção de Comandos, procedimento, funções, operadores, etc... escreval ("Digite o número de clientes a serem cadastrados :") leia (n) para i de 1 ate n faca Clientes.Codigo[i] := i + 1000 escreval ("Digite o nome do cliente :") leia (Clientes.NCliente[i]) escreval ("Digite o número de automóveis que o cliente pretende cadastrar :") leia (p) para j de 1 ate p faca escreval ("Digite o nome da marca/modelo do ", j ,"° automóvel ") leia (Automoveis.MAutomovel[i,j]) escreval ("Selecione a classificação do automóvel") escreval ("1 - Básico (R$ 80,00) ") escreval ("2 - Intermediário (R$ 150,00) ") escreval ("3 - Executivo (R$ 300,00) ") leia (class) escolha class caso 1 Automoveis.ValorLoc[i,j] := 80,00 caso 2 Automoveis.ValorLoc[i,j] := 150,00 caso 3 Automoveis.ValorLoc[i,j] := 300,00 outrocaso escreval ("Opção inválida!") j := j - 1 fimescolha Clientes.Soma[i] := Clientes.Soma[i] + Automoveis.ValorLoc[i,j] limpatela fimpara limpatela fimpara escreval ("CLIENTES CADASTRADOS") escreval (" ") para i de 1 ate n faca escreval ("Código : C", Clientes.Codigo[i]) escreval ("Nome Do Cliente : ", Clientes.NCliente[i]) para j de 1 ate p faca escreval ("Marca/Modelo do ", j ,"° Automóvel : ", Automoveis.MAutomovel[i,j]) escolha Automoveis.ValorLoc[i,j] caso 80,00 escreval ("Descrição Da Classificação : Básico ") escreval ("Valor Da Locação : R$ 80,00 ", ) caso 150,00 escreval ("Descrição Da Classificação : Intermediário ") escreval ("Valor Da Locação : R$ 150,00 ", ) caso 300,00 escreval ("Descrição Da Classificação : Executivo ") escreval ("Valor Da Locação : R$ 300,00 ", ) fimescolha fimpara escreval ("Valor Total Da Locação : R$ ", Clientes.Soma[i]) fimpara Fimalgoritmo É para um trabalho semestral que eu preciso entregar em no máximo duas semanas, então eu preciso resolver esse problema o mais rápido possível. Conto com a ajuda de vocês e agradeço desde já pela atenção.
  8. C Mesmo erro em dois programas diferentes

    Valeu pela dica! Uma dúvida que estou tendo é se tem como colocar um char pra definir as opções do switch/case. E se é possível colocar um if/else dentro de um switch/case.
  9. C Mesmo erro em dois programas diferentes

    @VictorFreitasKing e @erique , obrigado pelo esclarecimento . Eu não acredito que esqueci esse conceito, já estou estudando ponteiros e já tinha aprendido que & direcionava ao endereço da variável. @Benjamin Breeg , eu ainda não conhecia essas regras, muito obrigado pelas dicas!
  10. C Mesmo erro em dois programas diferentes

    Sou iniciante na linguagem C e estou passando por uns maus bocados no momento que os meus programas entram em uma estrutura condicional ou laço de repetição. O programa para de funcionar e vem aquela mensagem chata que o windows sempre dá quando encontra um erro, mas até agora eu não consegui identificar onde está o erro. São programas simples, porque eu estou revendo apenas alguns conceitos que já aprendi. Precisa urgentemente da ajuda de vocês, porque estarei realizando provas nesse fim de semana e esses conceitos com certeza irão cair! O erro só aparece nesse programa quando eu digito o segundo número do laço: #include <stdio.h> #include <stdlib.h> #include <locale.h> #include <cstdlib> int main (void) { int num[5]; int soma = 0; setlocale (LC_ALL, "portuguese"); for (int i= 0; i <= 4 ; i++ ) { printf ("\nDigite o %d ° número = ", i+1); scanf ("%d",num); } for (int i=0;i<=4;i++) { soma += num; } printf ("A soma dos 5 números é %d", soma); system ("pause"); return 0; } Esse é mais complicado e dá erro logo que eu digito o número #include <stdio.h> #include <cstdlib> #include <locale.h> #include <conio.h> int main (void) { int c, num; setlocale(LC_ALL, "Portuguese"); printf ("Digite um número = "); scanf ("%d",num); int cont = 1; for (c=2;c<=num;c++) { if (num % c != 0) { cont ++; if (cont == num) { printf ("\n%d é um número primo", num); } } else { printf ("\nO número %d é múltiplo de %d", num , c); break; } } if (num % 2 == 1) { printf ("\nO número %d é impar!",num); } else { printf ("\nO número %d é par!",num); } system ("pause"); return 0; }

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×