Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.

mosiah santos

Membros Plenos
  • Total de itens

    27
  • Registro em

  • Última visita

  • Qualificações

    N/D

Reputação

11

Sobre mosiah santos

  1. como faço na parte da var ? adicionado 7 minutos depois Algoritmo "centro automotivo" Var a,b,opcao,op:inteiro c,d, soma: inteiro desconto: inteiro //--------------------------------------------------------------------- procedimento menu_principal Inicio //menu principal limpatela escreval ("centro automotivo") escreval("Selecione uma opção") escreval ("1 - Motor") escreva("=> ") Fimprocedimento //--------------------------------------------------------------------- //funcao da opcao 1 procedimento menu_motor inicio limpatela escreval ("Opcao Motor") escreval ("1- Alto consumo de óleo lubrificante") escreval ("2- Excesso de fumaça sendo expelida pelo escapamento") escreval ("3- Baixa potencia") escreval ("4- voltar") escreval ("selecione uma opção") escreva("=> ") fimprocedimento //--------------------------------------------------------------------- //--------------------------------------------------------------------- procedimento alto_consumo inicio escreval("esta aqui no alto consumo") escreval ("valor por horas/atividades é de R$ 100,00 , por hora") escreval ("digite o valor da atividade:") leia (c) escreval ("Em quantas horas vai resolver o problema: ") leia (d) escreval ("o problema vai ser resolvido por R$",c*d) leia (desconto) se (desconto =>200) e (desconto<=1000) então desconto:=5/100 escreval("voce recebeu desconto de 5%") escreval("o valor final da mão de obra :", ) fimse se (ele>1000) então desconto:=5/100 escreval("voce recebeu desconto de 5%") escreval("o valor final da mão de obra :", ) fimse escreval(" Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento excesso_de_fumaca inicio escreval("esta aqui no excesso de fumaça") escreval ("valor por horas/atividades é de R$ 100,00 , por hora") escreval(" Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento baixa_potencia inicio escreval("esta aqui no baixa potencia") escreval ("valor por horas/atividades é de R$ 100,00 , por hora") escreval(" Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- Inicio repita menu_principal leia(Opcao) limpatela escolha opcao caso 1 repita menu_motor leia(op) escolha op caso 1 alto_consumo caso 2 excesso_de_fumaca caso 3 baixa_potencia caso 4 escreval("voltando . . . Tecle Enter") leia(a) fimescolha ate op=4 ate opcao=4 Fimalgoritmo mas ele não gera um resultado de desconto
  2. Algoritmo "centro automotivo" Var a,b,opcao,op:inteiro c,d, soma: inteiro desconto: inteiro //--------------------------------------------------------------------- procedimento menu_principal Inicio //menu principal limpatela escreval ("centro automotivo") escreval("Selecione uma opção") escreval ("1 - Motor") escreva("=> ") Fimprocedimento //--------------------------------------------------------------------- //funcao da opcao 1 procedimento menu_motor inicio limpatela escreval ("Opcao Motor") escreval ("1- Alto consumo de óleo lubrificante") escreval ("2- Excesso de fumaça sendo expelida pelo escapamento") escreval ("3- Baixa potencia") escreval ("4- voltar") escreval ("selecione uma opção") escreva("=> ") fimprocedimento //--------------------------------------------------------------------- //--------------------------------------------------------------------- procedimento alto_consumo inicio escreval("esta aqui no alto consumo") escreval ("valor por horas/atividades é de R$ 100,00 , por hora") escreval ("digite o valor da atividade:") leia (c) escreval ("Em quantas horas vai resolver o problema: ") leia (d) escreval ("o problema vai ser resolvido por R$",c*d) leia (desconto) se desconto >= 1000 então escreval("voce recebeu desconto de 10%") escreval("o valor final da mão de obra :", ) fimse se( desconto > 200) e (desconto < 1000) então escreval("voce recebeu desconto de 5%") escreval("o valor final da mão de obra :", ) fimse escreval(" Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento excesso_de_fumaca inicio escreval("esta aqui no excesso de fumaça") escreval ("valor por horas/atividades é de R$ 100,00 , por hora") escreval(" Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento baixa_potencia inicio escreval("esta aqui no baixa potencia") escreval ("valor por horas/atividades é de R$ 100,00 , por hora") escreval(" Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- Inicio repita menu_principal leia(Opcao) limpatela escolha opcao caso 1 repita menu_motor leia(op) escolha op caso 1 alto_consumo caso 2 excesso_de_fumaca caso 3 baixa_potencia caso 4 escreval("voltando . . . Tecle Enter") leia(a) fimescolha ate op=4 ate opcao=4 Fimalgoritmo não sei como fazer com que o programa faça desconto se ele passar de 200 e for menor qur 1000 será de 5% e se for acima de 1000 10% help
  3. Algoritmo "centro automotivo" Var a,b,opcao,op:inteiro //--------------------------------------------------------------------- procedimento menu_principal Inicio //menu principal limpatela escreval ("centro automotivo") escreval("Selecione uma opção") escreval ("1 - Motor") escreval ("2 - Suspenção") escreval ("3 - Freio") escreval ("4 - sair") escreva("=> ") Fimprocedimento //--------------------------------------------------------------------- //funcao da opcao 1 procedimento menu_motor inicio limpatela escreval ("Opcao Motor") escreval ("1- Alto consumo de óleo lubrificante") escreval ("2- Excesso de fumaça sendo expelida pelo escapamento") escreval ("3- Baixa potencia") escreval ("4- voltar") escreval ("selecione uma opção") escreva("=> ") fimprocedimento //--------------------------------------------------------------------- //funcao opcao 2 procedimento menu_suspencao inicio limpatela escreval ("Opcao Suspenção") escreval ("1- Ruidos e batidas nas rodas") escreval ("2- Vibrações e direção puxando") escreval ("3- Desgaste irregular dos pneus") escreval ("4- voltar") escreval ("selecione uma opção") escreva("=> ") fimprocedimento //--------------------------------------------------------------------- // funcao opcao 3 procedimento menu_freio inicio limpatela escreval ("Opcao Freio") escreval ("1- O carro ou pedal vibra ao pisar no pedal do freio") escreval ("2- O carro puxa para algum lado quando freia") escreval ("3- Chiado ou ronco quando pisa no freio") escreval ("4- voltar") escreval ("selecione uma opção") escreva("=> ") fimprocedimento //--------------------------------------------------------------------- procedimento alto_consumo inicio escreval("esta aqui no alto consumo") escreval ("valor por horas/atividades é de R$ 100,00 , por hora") escreval(" Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento excesso_de_fumaca inicio escreval("esta aqui no excesso de fumaça") escreval ("valor por horas/atividades é de R$ 100,00 , por hora") escreval(" Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento baixa_potencia inicio escreval("esta aqui no baixa potencia") escreval ("valor por horas/atividades é de R$ 100,00 , por hora") escreval(" Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento Ruidos_e_batidas_nas_rodas inicio escreval("está aqui no procedimento ruido e batidas nas rodas") escreval ("valor por horas/atividades é de R$ 200,00 , por hora") escreval(" Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento Vibracoes_e_direcao_puxando inicio escreval("eata aqui no procedimento vibrações e direção puxando") escreval ("valor por horas/atividades é de R$ 200,00 , por hora") escreval(" Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento desgaste_irregular_dos_peneus inicio escreval("esta aqui no prcedimento desgaste irregular dos peneus") escreval ("valor por horas/atividades é de R$ 200,00 , por hora") escreval(" Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento carro_ou_pedal_vibra_ao_pisar inicio escreval("esta aqui no procedimento carro ou pedal vibra ao pisar no freio") escreval ("valor por horas/atividades é de R$ 300,00 , por hora") escreval(" Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento carro_puxa_para_algum_lado inicio escreval("esta aqui no procedimento carro puxa para algum lado") escreval ("valor por horas/atividades é de R$ 300,00 , por hora") escreval(" Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento Chiado_ou_ronco_quando_pisa inicio escreval("esta aqui no procedimento chiado ou ronco quando pisa") escreval ("valor por horas/atividades é de R$ 300,00 , por hora") escreval(" Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- Inicio repita menu_principal leia(Opcao) limpatela escolha opcao caso 1 repita menu_motor leia(op) escolha op caso 1 alto_consumo caso 2 excesso_de_fumaca caso 3 baixa_potencia caso 4 escreval("voltando . . . Tecle Enter") leia(a) fimescolha ate op=4 caso 2 repita menu_suspencao leia(op) escolha op caso 1 Ruidos_e_batidas_nas_rodas caso 2 Vibracoes_e_direcao_puxando caso 3 desgaste_irregular_dos_peneus caso 4 escreval("voltando . . . Tecle Enter") leia(a) fimescolha ate op=4 caso 3 repita menu_freio leia(op) escolha op caso 1 carro_ou_pedal_vibra_ao_pisar caso 2 carro_puxa_para_algum_lado caso 3 Chiado_ou_ronco_quando_pisa caso 4 escreval("voltando . . . Tecle Enter") leia(a) fimescolha ate op=4 caso 4 escreval("você pediu para sair, saindo . . . !") fimescolha ate opcao=4 Fimalgoritmo como criar um calculo que seja de valor de mao de obra mais a soma de horas trabalhadas se a hora é 100 reais e eu trabalho 3 horas = 300 e com isso o desconto se for acima de 200 e abaixo de 1000 seja 5% de desconto se for acima de 1000 tenha 10% de desconto help
  4. C da erro ao calcular o desconto do valor total com corrigir ?

    #include <stdio.h> #include <stdlib.h> int main (void) { float val,produto,valor; int x=0,esc,car=0,sn,a; int desconto = 5; char y,n; system ("cls"); printf ("\t Escolha a categoria do problema do carro : \n\n"); printf ("\t 1- Motor \n"); printf ("\t 2- Suspencao \n"); printf ("\t 3- Freio \n"); scanf ("%i",&esc); system ("cls"); printf (" \t 1- Confirmar e prosseguir. \n"); printf (" \t 2- Voltar as escolhas. \n"); printf (" \t 3- Sair da locacao de carros. \n"); scanf ("%i",&car); if (car==1) { switch(esc) { // categoria de motor case 1: system ("cls"); printf ("\t Categoria Motor.\n"); printf(" 1 - Alto consumo de oleo lubrificante\n"); printf(" 2 - Excesso de fumaca sendo expelida pelo escapamento\n"); printf(" 3 - Baixa potencia\n"); printf("selecione uma opcao\n"); scanf("%i",&sn); scanf("%f",&valor); if (sn == 1) { printf("t Em quantas horas voce ira resolver o problema ?\n"); printf("o valor por hora : R$ 100,00\n"); scanf("%f",&val); produto = 100*val; // valor=10*produto/100; printf("o valor da mao de obra e : R$ %.2f \n\n",produto); printf("o valor do desconto é: R$ %.2f\n",valor); printf("O Total Com Desconto é: R$ %.2f\n",produto-valor); // printf("o valor da mao de obra e : R$%.000f \n\n",produto); // printf("o valor do desconto :%f\n",desconto); } else if (sn == 2) { printf("Em quantas horas voce ira resolver o problema ?\n"); printf("o valor por hora :R$ 100,00\n"); scanf("%f",&val); produto = 100*val; printf("o valor da mao de obra e :R$%.000f \n",produto); printf("o valor do desconto :%f\n",valor); } else if (sn == 3) { printf("Em quantas horas voce ira resolver o problema ?\n"); printf("o valor por hora : R$ 100,00\n"); scanf("%f",&val); produto = 100*val; printf("o valor da mao de obra e :R$%.000f \n",produto); printf("o valor do desconto :%f\n",valor); } system("pause"); break; //categoria de suspenчуo case 2: system ("cls"); printf ("\t Categoria Suspencao\n"); printf(" 1 - Alto consumo de oleo lubrificante\n"); printf(" 2 - Excesso de fumaca sendo expelida pelo escapamento\n"); printf(" 3 - Baixa potencia\n"); printf("selecione uma opcao\n"); scanf("%i",&sn); if (sn == 1) { printf("Em quantas horas voce ira resolver o problema ?\n"); printf("o valor por hora : R$ 200,00\n"); scanf("%f",&val); produto = 200*val; printf("\t o valor da mao de obra e :R$%.000f \n",produto); printf("o valor do desconto :%f\n",valor); } else if (sn ==2) { printf("Em quantas horas voce ira resolver o problema ?\n"); printf("o valor por hora não‰ R$ 200,00\n"); scanf("%f",&val); produto = 200*val; printf("o valor da mao de obra e :R$%.000f \n",produto); printf("o valor do desconto :%f\n",valor); } else if (sn == 3) { printf("Em quantas horas voce ira resolver o problema ?\n"); printf("o valor por hora : R$ 200,00\n"); scanf("%f",&val); produto = 200*val; printf("o valor da mao de obra e :R$%.000f \n",produto); printf("o valor do desconto :%f\n",valor); } system("pause"); break; // categoria de freio case 3: system ("cls"); printf ("\t Categoria Freio.\n"); printf(" 1 - Alto consumo de oleo lubrificante\n"); printf(" 2 - Excesso de fumaca sendo expelida pelo escapamento\n"); printf(" 3 - Baixa potencia\n"); printf("selecione uma opcao\n"); scanf("%i",&sn); if (sn == 1) { printf("Em quantas horas voce ira resolver o problema ?\n"); printf("o valor por hora : R$ 300,00\n"); scanf("%f",&val); produto = 300*val; printf("o valor da mao de obra :R$%.000f \n",produto); printf("o valor do desconto :%f\n",valor); } else if (sn ==2) { printf("Em quantas horas voce ira resolver o problema ?\n"); printf("o valor por hora : R$ 300,00\n"); scanf("%f",&val); produto = 300*val; printf("o valor da mao de obra e :R$%.000f \n",produto); printf("o valor do desconto:%f\n",valor); } else if (sn ==3) { printf("Em quantas horas voce ira resolver o problema ?\n"); printf("o valor por hora :R$ 300,00"); scanf("%f",&val); produto = 300*val; printf("o valor da mao de obra e :R$%.000f \n\n",produto); printf("o valor do desconto :%f\n",valor); } if (produto > 200 && produto < 1000){ printf("O desconto para ser aplicado será de 5%") ; /* desconto /= 100; desconto *= valor; */ valor =produto*5/100; } else if(produto > 1000){ /* desconto /= 100; desconto *= valor; */ valor = produto*10/100; } printf("o desconto sera de %.2f\n",valor); printf("O Total Com Desconto eh %.2f\n",produto-valor); system("pause"); break; } } return (0); } dê uma olhada para ver com ficou
  5. C da erro ao calcular o desconto do valor total com corrigir ?

    @devair1010 #include <stdio.h> #include <stdlib.h> int main (void) { float val,produto,valor; int x=0,esc,car=0,sn,a; int desconto = 5; char y,n; system ("cls"); printf ("\t Escolha a categoria do problema do carro : \n\n"); printf ("\t 1- Motor \n"); printf ("\t 2- Suspencao \n"); printf ("\t 3- Freio \n"); scanf ("%i",&esc); system ("cls"); printf (" \t 1- Confirmar e prosseguir. \n"); printf (" \t 2- Voltar as escolhas. \n"); printf (" \t 3- Sair da locacao de carros. \n"); scanf ("%i",&car); if (car==1) { switch(esc) { // categoria de motor case 1: system ("cls"); printf ("\t Categoria Motor.\n"); printf(" 1 - Alto consumo de oleo lubrificante\n"); printf(" 2 - Excesso de fumaca sendo expelida pelo escapamento\n"); printf(" 3 - Baixa potencia\n"); printf("selecione uma opcao\n"); scanf("%i",&sn); scanf("%f",&valor); if (sn == 1) { printf("t Em quantas horas voce ira resolver o problema ?\n"); printf("o valor por hora : R$ 100,00\n"); scanf("%f",&val); produto = 100*val; printf("o valor da mao de obra e : R$%.000f \n\n",produto); printf("o valor do desconto :%f\n",desconto); } else if (sn == 2) { printf("Em quantas horas voce ira resolver o problema ?\n"); printf("o valor por hora :R$ 100,00\n"); scanf("%f",&val); produto = 100*val; printf("o valor da mao de obra e :R$%.000f \n",produto); printf("o valor do desconto :%f\n",valor); } else if (sn == 3) { printf("Em quantas horas voce ira resolver o problema ?\n"); printf("o valor por hora : R$ 100,00\n"); scanf("%f",&val); produto = 100*val; printf("o valor da mao de obra e :R$%.000f \n",produto); printf("o valor do desconto :%f\n",valor); } system("pause"); break; //categoria de suspenчуo case 2: system ("cls"); printf ("\t Categoria Suspencao\n"); printf(" 1 - Alto consumo de oleo lubrificante\n"); printf(" 2 - Excesso de fumaca sendo expelida pelo escapamento\n"); printf(" 3 - Baixa potencia\n"); printf("selecione uma opcao\n"); scanf("%i",&sn); if (sn == 1) { printf("Em quantas horas voce ira resolver o problema ?\n"); printf("o valor por hora : R$ 200,00\n"); scanf("%f",&val); produto = 200*val; printf("\t o valor da mao de obra e :R$%.000f \n",produto); printf("o valor do desconto :%f\n",valor); } else if (sn ==2) { printf("Em quantas horas voce ira resolver o problema ?\n"); printf("o valor por hora não‰ R$ 200,00\n"); scanf("%f",&val); produto = 200*val; printf("o valor da mao de obra e :R$%.000f \n",produto); printf("o valor do desconto :%f\n",valor); } else if (sn == 3) { printf("Em quantas horas voce ira resolver o problema ?\n"); printf("o valor por hora : R$ 200,00\n"); scanf("%f",&val); produto = 200*val; printf("o valor da mao de obra e :R$%.000f \n",produto); printf("o valor do desconto :%f\n",valor); } system("pause"); break; // categoria de freio case 3: system ("cls"); printf ("\t Categoria Freio.\n"); printf(" 1 - Alto consumo de oleo lubrificante\n"); printf(" 2 - Excesso de fumaca sendo expelida pelo escapamento\n"); printf(" 3 - Baixa potencia\n"); printf("selecione uma opcao\n"); scanf("%i",&sn); if (sn == 1) { printf("Em quantas horas voce ira resolver o problema ?\n"); printf("o valor por hora : R$ 300,00\n"); scanf("%f",&val); produto = 300*val; printf("o valor da mao de obra :R$%.000f \n",produto); printf("o valor do desconto :%f\n",valor); } else if (sn ==2) { printf("Em quantas horas voce ira resolver o problema ?\n"); printf("o valor por hora : R$ 300,00\n"); scanf("%f",&val); produto = 300*val; printf("o valor da mao de obra e :R$%.000f \n",produto); printf("o valor do desconto:%f\n",valor); } else if (sn ==3) { printf("Em quantas horas voce ira resolver o problema ?\n"); printf("o valor por hora :R$ 300,00"); scanf("%f",&val); produto = 300*val; printf("o valor da mao de obra e :R$%.000f \n\n",produto); printf("o valor do desconto :%f\n",valor); } if (valor > 200 && valor < 1000){ printf("O desconto para ser aplicado será de 5%") ; desconto /= 100; desconto *= valor; valor -= desconto; } else if(valor > 1000){ desconto /= 100; desconto *= valor; valor -= desconto; } system("pause"); break;} } return (0); } da maneira que eu fiz ainda causa erro ao calcular o desconto adicionado 19 minutos depois como é que eu faria para que o valor que fosse de 200 até 1000 ficasse em 5% e de 1000 para cima ficasse de 10% ?
  6. C refiz um programa em linguagem c agora estou com o seguinte erro WinMain@16

    desculpa, não compreendi muito bem , consegue me demonstrar com um exemplo ?
  7. #include <stdio.h> #include <stdlib.h> int main (void) { float val,produto,valor; int x=0,esc,car=0,sn,a; char y,n; system ("cls"); printf ("\t Escolha a categoria do problema do carro : \n\n"); printf ("\t 1- Motor \n"); printf ("\t 2- Suspencao \n"); printf ("\t 3- Freio \n"); scanf ("%i",&esc); system ("cls"); printf (" \t 1- Confirmar e prosseguir. \n"); printf (" \t 2- Voltar as escolhas. \n"); printf (" \t 3- Sair da locacao de carros. \n"); scanf ("%i",&car); if (car==1) { switch(esc) { // categoria de motor case 1: system ("cls"); printf ("\t Categoria Motor.\n"); printf(" 1 - Alto consumo de oleo lubrificante\n"); printf(" 2 - Excesso de fumaca sendo expelida pelo escapamento\n"); printf(" 3 - Baixa potencia\n"); printf("selecione uma opcao\n"); scanf("%i",&sn); scanf("%f",&valor); if (sn == 1) { printf("Em quantas horas voce ira resolver o problema ?"); printf("o valor por hora щ R$ 100,00"); scanf("%f",&val); produto = 100*val; printf("o valor da mao de obra e :R$%.000f \n\n",produto); printf("o valor do desconto é:%f",valor); } else if (sn == 2) { printf("Em quantas horas voce ira resolver o problema ?"); printf("o valor por hora щ R$ 100,00"); scanf("%f",&val); produto = 100*val; printf("o valor da mao de obra e :R$%.000f \n",produto); printf("o valor do desconto é:%f",valor); } else if (sn == 3) { printf("Em quantas horas voce ira resolver o problema ?"); printf("o valor por hora щ R$ 100,00"); scanf("%f",&val); produto = 100*val; printf("o valor da mao de obra e :R$%.000f \n",produto); printf("o valor do desconto é:%f",valor); } system("pause"); break; //categoria de suspenчуo case 2: system ("cls"); printf ("\t Categoria Suspenчуo .\n"); printf(" 1 - Alto consumo de oleo lubrificante\n"); printf(" 2 - Excesso de fumaca sendo expelida pelo escapamento\n"); printf(" 3 - Baixa potencia\n"); printf("selecione uma opcao\n"); scanf("%i",&sn); if (sn == 1) { printf("Em quantas horas voce ira resolver o problema ?"); printf("o valor por hora щ R$ 200,00"); scanf("%f",&val); produto = 200*val; printf("\t o valor da mao de obra e :R$%.000f \n",produto); printf("o valor do desconto é:%f",valor); } else if (sn ==2) { printf("Em quantas horas voce ira resolver o problema ?"); printf("o valor por hora щ R$ 200,00"); scanf("%f",&val); produto = 200*val; printf("o valor da mao de obra e :R$%.000f \n",produto); printf("o valor do desconto é:%f",valor); } else if (sn == 3) { printf("Em quantas horas voce ira resolver o problema ?"); printf("o valor por hora щ R$ 200,00"); scanf("%f",&val); produto = 200*val; printf("o valor da mao de obra e :R$%.000f \n",produto); printf("o valor do desconto é:%f",valor); } system("pause"); break; // categoria de freio case 3: system ("cls"); printf ("\t Categoria Freio.\n"); printf(" 1 - Alto consumo de oleo lubrificante\n"); printf(" 2 - Excesso de fumaca sendo expelida pelo escapamento\n"); printf(" 3 - Baixa potencia\n"); printf("selecione uma opcao\n"); scanf("%i",&sn); if (sn == 1) { printf("Em quantas horas voce ira resolver o problema ?"); printf("o valor por hora щ R$ 300,00"); scanf("%f",&val); produto = 300*val; printf("o valor da mao de obra e :R$%.000f \n",produto); printf("o valor do desconto é:%f",valor); } else if (sn ==2) { printf("Em quantas horas voce ira resolver o problema ?"); printf("o valor por hora щ R$ 300,00"); scanf("%f",&val); produto = 300*val; printf("o valor da mao de obra e :R$%.000f \n",produto); printf("o valor do desconto é:%f",valor); } else if (sn ==3) { printf("Em quantas horas voce ira resolver o problema ?"); printf("o valor por hora щ R$ 300,00"); scanf("%f",&val); produto = 300*val; printf("o valor da mao de obra e :R$%.000f \n\n",produto); printf("o valor do desconto é:%f",valor); } if (valor > 200 && valor < 1000){ printf("O desconto para ser aplicado será de 5%") ; } else if(valor > 1000){ printf("O desconto para ser aplicado será de 10%"); } system("pause"); break;} } return (0); }
  8. C refiz um programa em linguagem c agora estou com o seguinte erro WinMain@16

    #include <stdio.h> #include <stdlib.h> int main (void) { float val,produto,valor; int x=0,esc,car=0,sn,a; char y,n; system ("cls"); printf ("\t Escolha a categoria do problema do carro : \n\n"); printf ("\t 1- Motor \n"); printf ("\t 2- Suspensуo \n"); printf ("\t 3- Freio \n"); scanf ("%i",&esc); system ("cls"); printf (" \t 1- Confirmar e prosseguir. \n"); printf (" \t 2- Voltar as escolhas. \n"); printf (" \t 3- Sair da locacao de carros. \n"); scanf ("%i",&car); if (car==1) { switch(esc) { // categoria de motor case 1: system ("cls"); printf ("\t Categoria Motor.\n"); printf(" 1 - Alto consumo de oleo lubrificante\n"); printf(" 2 - Excesso de fumaca sendo expelida pelo escapamento\n"); printf(" 3 - Baixa potencia\n"); printf("selecione uma opcao\n"); scanf("%i",&sn); scanf("%f",&valor); if (sn == 1) { printf("Em quantas horas voce ira resolver o problema ?"); printf("o valor por hora щ R$ 100,00"); scanf("%f",&val); produto = 100*val; printf("o valor da mao de obra e :R$%.000f \n\n",produto); printf("o valor do desconto é:%f",valor); } else if (sn == 2) { printf("Em quantas horas voce ira resolver o problema ?"); printf("o valor por hora щ R$ 100,00"); scanf("%f",&val); produto = 100*val; printf("o valor da mao de obra e :R$%.000f \n",produto); printf("o valor do desconto é:%f",valor); } else if (sn == 3) { printf("Em quantas horas voce ira resolver o problema ?"); printf("o valor por hora щ R$ 100,00"); scanf("%f",&val); produto = 100*val; printf("o valor da mao de obra e :R$%.000f \n",produto); printf("o valor do desconto é:%f",valor); } system("pause"); break; //categoria de suspenчуo case 2: system ("cls"); printf ("\t Categoria Suspenчуo .\n"); printf(" 1 - Alto consumo de oleo lubrificante\n"); printf(" 2 - Excesso de fumaca sendo expelida pelo escapamento\n"); printf(" 3 - Baixa potencia\n"); printf("selecione uma opcao\n"); scanf("%i",&sn); if (sn == 1) { printf("Em quantas horas voce ira resolver o problema ?"); printf("o valor por hora щ R$ 200,00"); scanf("%f",&val); produto = 200*val; printf("\t o valor da mao de obra e :R$%.000f \n",produto); printf("o valor do desconto é:%f",valor); } else if (sn ==2) { printf("Em quantas horas voce ira resolver o problema ?"); printf("o valor por hora щ R$ 200,00"); scanf("%f",&val); produto = 200*val; printf("o valor da mao de obra e :R$%.000f \n",produto); printf("o valor do desconto é:%f",valor); } else if (sn == 3) { printf("Em quantas horas voce ira resolver o problema ?"); printf("o valor por hora щ R$ 200,00"); scanf("%f",&val); produto = 200*val; printf("o valor da mao de obra e :R$%.000f \n",produto); printf("o valor do desconto é:%f",valor); } system("pause"); break; // categoria de freio case 3: system ("cls"); printf ("\t Categoria Freio.\n"); printf(" 1 - Alto consumo de oleo lubrificante\n"); printf(" 2 - Excesso de fumaca sendo expelida pelo escapamento\n"); printf(" 3 - Baixa potencia\n"); printf("selecione uma opcao\n"); scanf("%i",&sn); if (sn == 1) { printf("Em quantas horas voce ira resolver o problema ?"); printf("o valor por hora щ R$ 300,00"); scanf("%f",&val); produto = 300*val; printf("o valor da mao de obra e :R$%.000f \n",produto); printf("o valor do desconto é:%f",valor); } else if (sn ==2) { printf("Em quantas horas voce ira resolver o problema ?"); printf("o valor por hora щ R$ 300,00"); scanf("%f",&val); produto = 300*val; printf("o valor da mao de obra e :R$%.000f \n",produto); printf("o valor do desconto é:%f",valor); } else if (sn ==3) { printf("Em quantas horas voce ira resolver o problema ?"); printf("o valor por hora щ R$ 300,00"); scanf("%f",&val); produto = 300*val; printf("o valor da mao de obra e :R$%.000f \n\n",produto); printf("o valor do desconto é:%f",valor); } if (valor > 200 && valor < 1000){ printf("O desconto para ser aplicado será de 5%") ; } else if(valor > 1000){ printf("O desconto para ser aplicado será de 10%"); } system("pause"); break;} } return (0); } fiz dessa seguinte maneira o codigo roda mas não dá o valor certo do desconto
  9. C refiz um programa em linguagem c agora estou com o seguinte erro WinMain@16

    muito obrigado pela sua ajuda
  10. C refiz um programa em linguagem c agora estou com o seguinte erro WinMain@16

    agora so vou criar um float e incluir esse codigo no programa certo ? if (valor > 200 && valor < 1000) aplicaDesconto5(); else if(valor > 1000) aplicaDesconto10();
  11. C refiz um programa em linguagem c agora estou com o seguinte erro WinMain@16

    para poder fazer da seguinte maneira , se um valor for acima de 200 reais e menor que 1000 deve ter 5% de desconto, se o valor passar de 1000 reais deve ter o desconto de 10% preciso de salve
  12. C refiz um programa em linguagem c agora estou com o seguinte erro WinMain@16

    muito obrigado , tenho uma pergunta se eu quisesse colocar um desconto passando de 100 reais como eu faria ? exemplo abaixo if (sn == 1) { printf("Em quantas horas voce ira resolver o problema ?"); printf("o valor por hora é R$ 300,00"); scanf("%f",&val); produto = 300*val; printf("o valor da mao de obra e :R$%.000f \n",produto); }
  13. #include <stdio.h> #include <stdlib.h> int pecascarros (void) { float val,produto; int x=0,esc,car=0,sn,a; char y,n; system ("cls"); printf ("\t Escolha a categoria do problema do carro : \n\n"); printf ("\t 1- Motor \n"); printf ("\t 2- Suspensão \n"); printf ("\t 3- Freio \n"); scanf ("%i",&esc); system ("cls"); printf (" \t 1- Confirmar e prosseguir. \n"); printf (" \t 2- Voltar as escolhas. \n"); printf (" \t 3- Sair da locacao de carros. \n"); scanf ("%i",&car); if (car==1) { switch(esc) { // categoria de motor case 1: system ("cls"); printf ("\t Categoria Motor.\n"); printf(" 1 - Alto consumo de oleo lubrificante\n"); printf(" 2 - Excesso de fumaca sendo expelida pelo escapamento\n"); printf(" 3 - Baixa potencia\n"); printf("selecione uma opcao\n"); scanf("%i",&sn); if (sn == 1) { printf("Em quantas horas voce ira resolver o problema ?"); printf("o valor por hora é R$ 100,00"); scanf("%f",&val); produto = 100*val; printf("o valor da mao de obra e :R$%.000f \n",produto); } else if (sn == 2) { printf("Em quantas horas voce ira resolver o problema ?"); printf("o valor por hora é R$ 100,00"); scanf("%f",&val); produto = 100*val; printf("o valor da mao de obra e :R$%.000f \n",produto); } else if (sn == 3) { printf("Em quantas horas voce ira resolver o problema ?"); printf("o valor por hora é R$ 100,00"); scanf("%f",&val); produto = 100*val; printf("o valor da mao de obra e :R$%.000f \n",produto); } system("pause"); break; //categoria de suspenção case 2: system ("cls"); printf ("\t Categoria Suspenção .\n"); printf(" 1 - Alto consumo de oleo lubrificante\n"); printf(" 2 - Excesso de fumaca sendo expelida pelo escapamento\n"); printf(" 3 - Baixa potencia\n"); printf("selecione uma opcao\n"); scanf("%i",&sn); if (sn == 1) { printf("Em quantas horas voce ira resolver o problema ?"); printf("o valor por hora é R$ 200,00"); scanf("%f",&val); produto = 200*val; printf("o valor da mao de obra e :R$%.000f \n",produto); } else if (sn ==2) { printf("Em quantas horas voce ira resolver o problema ?"); printf("o valor por hora é R$ 200,00"); scanf("%f",&val); produto = 200*val; printf("o valor da mao de obra e :R$%.000f \n",produto); } else if (sn == 3) { printf("Em quantas horas voce ira resolver o problema ?"); printf("o valor por hora é R$ 200,00"); scanf("%f",&val); produto = 200*val; printf("o valor da mao de obra e :R$%.000f \n",produto); } system("pause"); break; // categoria de freio case 3: system ("cls"); printf ("\t Categoria Freio.\n"); printf(" 1 - Alto consumo de oleo lubrificante\n"); printf(" 2 - Excesso de fumaca sendo expelida pelo escapamento\n"); printf(" 3 - Baixa potencia\n"); printf("selecione uma opcao\n"); scanf("%i",&sn); if (sn == 1) { printf("Em quantas horas voce ira resolver o problema ?"); printf("o valor por hora é R$ 300,00"); scanf("%f",&val); produto = 300*val; printf("o valor da mao de obra e :R$%.000f \n",produto); } else if (sn ==2) { printf("Em quantas horas voce ira resolver o problema ?"); printf("o valor por hora é R$ 300,00"); scanf("%f",&val); produto = 300*val; printf("o valor da mao de obra e :R$%.000f \n",produto); } else if (sn ==3) { printf("Em quantas horas voce ira resolver o problema ?"); printf("o valor por hora é R$ 300,00"); scanf("%f",&val); produto = 300*val; printf("o valor da mao de obra e :R$%.000f \n",produto); } system("pause"); break;} } return (0); }
  14. C não consigo consertar o erro do else if

    então é nessa parte que não cosigo mais ir para frente /* else if (codigo == 4) { calculo = valorproduto + (0.1 * valorproduto); } printf("PRECO FINAL = %.2f\n",calculo); */ nao sei mais como resolver
  15. C não consigo consertar o erro do else if

    #include <stdio.h> #include <stdlib.h> int main () { int Opt; float preco_total,desconto; do{ printf("Centro Automotivo\n"); printf("..................\n\n"); printf("1 - Motor\n"); printf("2 - Suspencao\n"); printf("3 - Freio\n"); printf("4 - Sair\n"); printf("Selecione uma opcao:"); scanf("%d",&Opt); if(Opt == 1) { printf("voce selecionou opcao 1 :\n\t motor \n"); printf(" 1 - Alto consumo de oleo lubrificante\n"); printf(" 2 - Excesso de fumaca sendo expelida pelo escapamento\n"); printf(" 3 - Baixa potencia\n"); printf("selecione uma opcao\n"); desconto = 100; } else if (Opt == 2) { printf ("voce selecicionou a opcao 2:\n\t suspencao\n"); printf(" 1 - Ruidos e batidas nas rodas\n"); printf(" 2 - Vibracoes e direcao puxando\n"); printf(" 3 - Desgaste irregular dos pneus\n"); printf("selecione uma opcao\n"); desconto = 200; } else if (Opt == 3) { printf ("voce selecicionou a opcao 3:\n\t Freio\n"); printf(" 1 - O carro ou pedal vibrar ao pisar no pedal de freio\n"); printf(" 2 - O carro puxar para algum lado quando freia\n"); printf(" 3 - Ouvir algum chiado ou ronco quando pisa no freio"); printf("selecione uma opcao\n"); desconto = 300; } }while(Opt !=4); system ("pause"); return 0; } else if (codigo == 4){ calculo = valorproduto + (0.1 * valorproduto); } printf("PRECO FINAL = %.2f\n",calculo);

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×