Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.

Kaio Lukas

Membros Juniores
  • Total de itens

    5
  • Registro em

  • Última visita

  • Qualificações

    N/D

Reputação

3

Sobre Kaio Lukas

  1. VisualG Contador Inteligente de números

    @devair1010 Puts, era isso mesmo. @Simon Viegas Entendi, obrigado pelas dicas! Eu ainda tenho um pouco de dificuldade na "lógica" do negócio, mas treinando eu pego o jeito. xD Teria algum site onde tem exercícios sobre esse tema? Eu dei uma procurada por cima e não achei nada muito útil.
  2. Olá. Tenho um algoritmo que pede dois valores, um inicial e um final, eu preciso fazer ele contar do menor pro maior, e do maior pro menor, independente do valor digitado. algoritmo "ContagemInteligente" var I, F: Inteiro inicio I <- 0 F <- 0 //Bloco do pedido das variáveis Escreval ("CONTAGEM INTELIGENTE") Escreval ("--------------------") Escreva ("Início: ") Leia(I) Escreva ("Fim: ") Leia(F) //Blocos dos contadores Se (I > F) então Enquanto (I > F) faca I <- I - 1 Escreva (I) FimEnquanto SeNao Se (I < F) então Enquanto (I < F) faca F <- F + 1 Escreva (F) FimEnquanto FimSe FimSe fimalgoritmo Mas sempre que eu rodo o código, acontece o seguinte: Se o Início é MENOR que o final: ele conta infinitamente Se o Início é MAIOR que o final: ele faz tudo certo. Eu não tô conseguindo entender meu erro: Se o I < F então ele soma mais um até o I não ser < que o F. Mas ele conta pra sempre Se (I < F) então Enquanto (I < F) faca F <- F + 1 Escreva (F) FimEnquanto FimSe FimSe adicionado 6 minutos depois Eu dei uma mudada no código: algoritmo "ContagemInteligente" var I, F: Inteiro inicio I <- 0 F <- 0 //Bloco do pedido das variáveis Escreval ("CONTAGEM INTELIGENTE") Escreval ("--------------------") Escreva ("Início: ") Leia(I) Escreva ("Fim: ") Leia(F) //Blocos dos contadores Se (I < F) então Enquanto (I < F) faca I <- I + 1 Escreva (I) FimEnquanto SeNao Se (I > F) então Enquanto (I > F) faca I <- I - 1 Escreva (F) FimEnquanto FimSe FimSe fimalgoritmo Mas agora quando eu digito um número maior no Início, ele repete o número final algumas vezes
  3. Ficou assim! E funcionou certinho! Dúvida: Se eu tiver questionamentos sobre outros exercícios, crio outro tópico ou posso postar nesse mesmo?
  4. Ah, consegui corrigir! hahahaha Entendi onde tava o erro. Obrigado gente. xD
  5. Olá. Eu tenho um exercício que é o seguinte: Eu fiz uma repetição, que ele te pergunta números, no final ele soma esses números, e mostra o maior valor. Porém eu preciso criar uma variável que me mostre o MENOR valor digitado. E nisso eu realmente empaquei. (E se alguém me explicar a parte de >como< ele "acha" o maior valor, eu ficaria agradecido porque eu entendi mais ou menos. algoritmo "semnome" var N, V, S, MV, NV : Real //MV - Maior valor, NV - Menor Valor inicio N <- 1 S <- 0 Enquanto (N <= 5) faca Escreva ("Digite o", N ,"º valor: ") Leia (V) Se (V > MV) então MV <- V FimSe Se (N = 1) então NV <- N SeNao Se (N = NV) então NV <- N FimSe FimSe S <- S + V N <- N + 1 FimEnquanto Escreval ("O total dos valores digitados é:", S) Escreval ("O maior valor digitado foi:", MV) Escreva ("O menor valor digitado foi:", NV) fimalgoritmo Eu suponho que seja algum erro relacionado a essa parte, sempre que ele "mostra" o menor valor, ele sempre o coloca como sendo 1. Se (N = 1) então NV <- N SeNao Se (N = NV) então NV <- N FimSe FimSe Se alguém puder me dar uma luz, eu agradeço. ._.

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×