Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.

Ayron Matos

Membros Juniores
  • Total de itens

    6
  • Registro em

  • Última visita

  • Qualificações

    N/D

Reputação

6

Sobre Ayron Matos

  1. Exercício 6 Escrever um algoritmo que lê uma matriz M(6,6) e calcula as somas das partes hachuradas. Escrever a matriz M e as somas calculadas. (uma série de imagens para criar no algoritmo) uma em especial que eu chamei de TrianguloOesteLeste (que é a que eu estou com dúvida). imagem segue em anexo. Não sei se essa é a forma mais eficiente. O que eu pensei foi em dividir em duas condicionais simétricas: a parte superior e a parte inferior. O que eu fiz foi apenas iniciar mas estou com dúvida em como deixar o espaço correto e como fazer ele escrever do lado leste. o que eu fiz segue abaixo: procedimento TrianguloLesteOeste() var t: inteiro inicio Para i <- 2 ate 5 faca Para j <- 1 ate 6 faca Se (j < 4) e (i > j) então Escreva(M[i,j]:20) FimSe FimPara EscrevaL() FimPara fimprocedimento
  2. Algoritmo de número primo específico: algoritmo "Primo" var n, i, divisor: inteiro inicio Leia(n) LimpaTela Para i <-1 ate n faca Se (n%i=0) então divisor <- divisor + 1 FimSe FimPara Se (divisor=2) então Escreva(n, " é um número primo.") SeNao Escreva(n, " não é um número primo.") FimSe fimalgoritmo adicionado 9 minutos depois Algoritmo dos números primos de 100 a 200: algoritmo "Primosde100a200" var i,j, divisor: inteiro inicio Para i <- 100 ate 200 faca divisor <- 0 Para j <-1 ate i faca Se (i%j=0) então divisor <- divisor + 1 FimSe FimPara Se (divisor=2) então Escreva(i) FimSe FimPara fimalgoritmo adicionado 28 minutos depois Consegui! algoritmo "10PrimeirosPrimosDepoisde100" var primo: vetor[1..10] de inteiro c, i, j, divisor: inteiro inicio i <- 100 c <- 0 Repita i <- i + 1 divisor <- 0 Para j <-1 ate i faca Se (i%j=0) então divisor <- divisor + 1 FimSe FimPara Se (divisor=2) então c <- c + 1 primo[c] <- i Escreva(primo[c]) FimSe Ate (c = 10) Muito obrigado!
  3. @Simon Viegas eu acho que não fiz exatamente como a questão queria mas pelo menos consegui chegar no mesmo resultado. A sintaxe segue abaixo: algoritmo "10PrimeirosPrimosDepoisde100" var primo: vetor[101..149] de inteiro c, divisor: inteiro inicio Para c <- 101 ate 149 faca divisor <- 0 Se (c%2=0) então divisor <- divisor + 1 FimSe Se (c%3=0) então divisor <- divisor + 1 FimSe Se (c%5=0) então divisor <- divisor + 1 FimSe Se (c%11=0) então divisor <- divisor + 1 FimSe Se (c%12=0) então divisor <- divisor + 1 FimSe Se (c%c=0) então divisor <- divisor + 1 FimSe Se (divisor=1) então primo[c] <- c Escreva(primo[c]:4) FimSe FimPara fimalgoritmo
  4. Exercício 6 Escreva um algoritmo que gera os 10 primeiros números primos acima de 100 e os armazena em um vetor X(10) escrevendo, no final, o vetor X. algoritmo "10PrimeirosPrimos" var primo: vetor[1..10] de inteiro c, div, i, j: inteiro inicio Para j <- 1 ate 10 faca Para c <- 1 ate 149 faca div <- 0 Para i <- 1 ate 149 faca Se (c%i=0) então div <- div + 1 FimSe FimPara Se (div = 2) e (c > 100) então primo[j] <- c FimSe FimPara FimPara Para j <- 1 ate 10 faca Escreva(primo[j]:4) fimalgoritmo O visualg não informa qual o problema mas eu suponho que seja as variaveis..
  5. Entendi perfeitamente, muito obrigado!
  6. 4) Faça um algoritmo que gere uma tabela com os números de 1 a 10 e mostre o seu quadrado, cubo, fatorial, número de divisores e uma mensagem dizendo se o número é primo ou não. A cada 20 linhas deve ser escrito o cabeçalho novamente: algoritmo "Tabelade1ate10" var i, r, x, j: inteiro q, c: real funcao fatorial(b:inteiro):inteiro var f, t: inteiro inicio f <- 1 Se (b = 1) então Retorne 1 SeNao Para t <- 1 ate b-1 faca f <- f*t FimPara Retorne f FimSe fimfuncao funcao divisores(b:inteiro):inteiro var div, l: inteiro inicio Para l <- 1 ate b faca Se (b%l=0) então div <- div + 1 FimSe FimPara Retorne div fimfuncao funcao primo(b:inteiro):inteiro var div, l: inteiro inicio Para l <-1 ate b faca Se (b%l=0) então div <- div + 1 FimSe FimPara Se (div = 2) então Retorne "sim" SeNao Retorne "nao" FimSe fimfuncao inicio Escreva("Número Quadrado Cubo Fatorial Divisores Primo") Para i <- 1 ate 10 faca q <- i^2 c <- i^3 r <- fatorial() x <- divisores() z <- primo() Escreva(i, q:7, c:8, r:4, x:6, z:10) FimPara fimalgoritmo Ele finaliza no início da função <fatorial()> e eu não sei por quê... gostaria de entender onde estou errando. obs: desconsiderei a repetição a cada 20 linhas. Achei desnecessário.

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×