Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.

Vanderlei Luiz Kotz

Membros Juniores
  • Total de itens

    1
  • Registro em

  • Última visita

  • Qualificações

    N/D

Reputação

1

Sobre Vanderlei Luiz Kotz

  1. A professora passou essa questão: Questão Aberta: Faça um algoritmo que crie um vetor de registros com os seguintes campos: um número inteiro e um número real. No total, você deve declarar 100 registros. Para cada posição do vetor, verifique: a) Se o número inteiro do registro for par, multiplique seu valor por 2; Se o número inteiro do registro for ímpar, multiplique seu valor por 3; c) Se o número real do registro for positivo, multiplique seu valor por 4; d) Se o número real do registro for negativo, multiplique seu valor por 0; e) Após aplicar as operações dos itens anteriores, some todos os números inteiros dos registros do vetor e imprima o resultado. Mas consegui fazer o registro no visualg mas nao consigo seguir adiante nas letras a, b, c, d, e alguém poderia me dar uma LUZ no fim do tunel Já montei o inicio mas não sei se estou no caminho: algoritmo "CEMNUMEROSINTEIROSEREAIS" // Disciplina : [Linguagem e Lógica de Programação] // Professor : // Função : Usuário informa 100 valores inteiros e 100 valores real e o programa sempre exibe ao termino a soma. // Autor : Vanderlei Luiz Kotz // Data : 14/10/2017 // Seção de Declarações tipo valores=registro num_int: inteiro num_r: real fimregistro var ficha_num: vetor[0..2] de valores // coloquei 3 valores para testar apenas depois altero. i: inteiro soma: inteiro mult_int:inteiro mult_real:real inicio i<-0 para i de 0 ate 1 faca escreva("Informe um número inteiro: ") leia(ficha_num.num_int) escreva("Informe um número real: ") leia(ficha_num.num_r) fimpara mult_int<-0 se(ficha_num.num_int mod 2 = 0)então mult_int=ficha_num.num_int*2 senao mult_int=ficha_num.num_int*3 fimse se(ficha_num.num_r > 0)então ficha_num.num_r= ficha_num.num_r*4 senao ficha_num.num_r=ficha_num.num_r*0 fimse para i de 0 ate 1 faca soma=mult_int+mult_int escreva ("A soma e:")(soma) fimpara fimalgoritmo

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×