Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.

Luiz Felippe Vieira

Membros Juniores
  • Total de itens

    4
  • Registro em

  • Última visita

  • Qualificações

    N/D
  1. VisualG Erro sem motivo aparente

    Funcionou, valeu, nao sabia disso do = e dos parênteses.
  2. VisualG Erro sem motivo aparente

    Algoritmo "bnct" // Um banco concederá um crédito especial aos seus clientes, //variável com saldo médio no último ano. Faça um algoritmo que leia //o saldo médio de um cliente e calcule o valor do crédito de acordo com a //tabela abaixo. Mostre uma mensagem informando o saldo médio e o valor de //crédito (a porcentagem aplicada sobre o saldo médio). Var // Seção de Declarações das variáveis sma:inteiro; zporct,vtporct,trtporct,qrtporcent:real; Inicio // Seção de Comandos, procedimento, funções, operadores, etc... escreval("Qual o saldo médio anual do cliente?") leia(sma) se (sma <= 200) então zporct <- sma * 0.00 escreval("Crédito total oferecido para o saldo de R$",sma," é ",zporct) senao se (sma => 201 e sma=<400) então vtporct <- sma * 0.20 escreval("Crédito total oferecido para o saldo de R$",sma," é ",vtporct) senao se (sma => 401 e sma=<600) então trtporct <- sma * 0.30 escreval("Crédito total oferecido para o saldo de R$",sma," é ",trtporct) senao se (sma => 601) então qrtporcent <- sma * 0.40 escreval("Crédito total oferecido para o saldo de R$",sma," é ",qrtporcent) senao fimse fimse fimse fimse Fimalgoritmo Quando eu coloco valor acima de 201 da o erro.
  3. C Onde eu errei? :3

    Agr ta com erro no Else.
  4. C Onde eu errei? :3

    #include <stdio.h> #include <stdlib.h> //Tendo como dados de entrada a altura e o sexo de uma pessoa, //construa um algoritmo que calcule seu peso ideal, //utilizando as seguintes fórmulas: //Para Homens: (72.7 *h) - 58; //Para Mulheres: (62.1 * h) - 44.7. int main(int argc, char *argv[]) { int opc; float r1,r2,r3; float peso,h opc = 0; printf("Qual seu genero?\n"); printf("1 - Masculino\n"); printf("2 - Feminino\n"); scanf("%d",&opc); if (opc=1); { printf("Digite seu peso:\n"); scanf("%f",&peso); printf("Digite sua altura:\n"); scanf("%f",&h); r1 = 72.7 * h - 58; r2 = r1 - peso; if (peso > r1); { printf("Seu peso ideal é:", r1,"kg"); printf("É preciso perder:",r2,"kg para seu peso ideal"); } else (peso < r1); { printf("Seu peso ideal é:", r1,"kg"); printf("É preciso ganhar:",r2,"kg para seu peso ideal"); } } if (opc=2); { printf("Digite seu peso:\n"); scanf("%f",&peso); printf("Digite sua altura:\n"); scanf("%f",&h); r1 = 62.1 * h - 44.7; r2 = r1 - peso; if (peso > r1); { printf("Seu peso ideal é:", r1,"kg"); printf("É preciso perder:",r2,"kg para seu peso ideal"); } else (peso < r1); { printf("Seu peso ideal é:", r1,"kg"); printf("É preciso ganhar:",r2,"kg para seu peso ideal"); } } system("PAUSE"); return 0; }

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×