Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.

Pesquisar na Comunidade

Mostrando resultados para as tags ''VisualG''.



Mais opções de pesquisa

  • Pesquisar por Tags

    Digite tags separadas por vírgulas
  • Pesquisar por Autor

Tipo de Conteúdo


Categorias

  • Armazenamento
  • Áudio
  • Energia
  • Entrada
  • Feiras e Eventos
  • Gabinetes
  • Memória
  • Museu
  • Placas-mãe
  • Portáteis
  • Processadores
  • Programas
  • Rádio CdH
  • Redes
  • Refrigeração
  • Smartphones
  • Tablets
  • Vídeo
  • Outros

Categorias

  • Blog

Categorias

  • Armazenamento
  • Áudio
  • Câmeras
  • Computadores
  • Consoles
  • Eletrônicos
  • Energia
  • Entrada
  • Gabinetes
  • Impressão
  • Jogos
  • Memória
  • Placas-mãe
  • Portáteis
  • Processadores
  • Programas
  • Redes
  • Refrigeração
  • Smartphones
  • Tablets
  • Vídeo
  • Outros

Categorias

  • Livros disponíveis
  • Livros esgotados

Categorias

  • Cursos

Fóruns

  • Mensagens do Clube do Hardware
    • Regras gerais
    • Boletins do Clube do Hardware
    • Notícias da administração
  • Hardware
    • Recomendações de computadores
    • Placas de vídeo
    • Placas-mãe e chipsets
    • Processadores
    • Problemas de gargalo e desempenho
    • Memórias
    • Armazenamento
    • Refrigeração e superaquecimento
    • Fontes e energia
    • Gabinetes e casemods
    • Placas de som e áudio on-board
    • Periféricos
    • Mac
    • Overclock
    • Hardware - outros
  • Computação móvel
    • Notebooks
    • Tablets
    • Smartphones e apps
  • Redes e Internet
    • Redes e Internet
    • Hospedagem de sites e registro de domínios
  • Segurança da informação
    • Remoção de malware
    • Dúvidas sobre invasões e infecções
    • Programas de proteção
  • Programação e desenvolvimento
    • Java
    • C/C#/C++
    • Pascal/Delphi
    • .NET
    • Bancos de dados
    • Programação web
    • Programação - iniciantes
    • Programação de microcontroladores
    • Programação - outros
  • Software
    • Jogos
    • Pacotes de escritório
    • Computação distribuída (Folding@Home, Bitcoin etc.)
    • Virtualização
    • Design, animação e tratamento de imagens
    • Edição de áudio e vídeo
    • Programas
  • Sistemas Operacionais
    • Recomendação de sistemas operacionais
    • Windows
    • GNU/Linux, BSD, Unix-like e software livre
    • Mac OS
  • Eletrônicos
    • Equipamentos de som, home theaters e gravadores de mesa
    • Televisores e projetores
    • Câmeras e filmadoras
    • Players portáteis
    • Consoles (videogames)
    • GPS
    • Telefonia fixa
    • Eletrônica
    • Retrocomputação
  • Outros
    • Recomendações de serviços e lojas
    • Preços e promoções
    • Notícias
    • Bolsa de empregos, certificações e mercado de trabalho
    • "Causos"
    • Encontros de usuários
    • Feira do Rolo
  • Clube do Hardware
    • Comentários, elogios, críticas e sugestões sobre o Clube do Hardware
    • Comentários de artigos
    • Fórum para testes de funcionalidades

Categorias

  • Hardware
  • Redes
  • Eletrônica
  • Sistemas operacionais

Encontrado 51 registros

  1. Um professor classifica os alunos de suas turmas em quatro grupos de acordo com a média de cada aluno. A Tabela abaixo mostra os quatro grupos e como eles foram definidos de acordo com as notas. Por exemplo, um aluno que teve média 6.0 deve ser incluído no grupo B. A sua tarefa é escrever um algoritmo que leia as notas de várias turmas deste professor e calcule para cada turma a percentagem de alunos em cada grupo. GRUPO MÉDIA D 0.0 <= Média <= 2.5 C 2.5 < Média <= 5.0 B 5.0 < Média <= 7.5 A 7.5 < Média <= 10.0 Entrada: A entrada contém os dados de várias turmas do professor. A primeira linha de uma turma contém um número inteiro N que informa o numero de alunos da turma. As N linhas restantes contém, cada uma, um número real indicando a média de um aluno. O algoritmo deve parar de ler dados quando encontrar N = 0. Considere que somente quantidades de alunos e notas válidas serão fornecidas. Saída: A saída é de cada turma é composta por várias linhas contendo as seguintes informações:  o número de ordem da turma na entrada de dados, por exemplo Turma 1  em seguida 4 linhas com a percentagem de alunos nos grupos. Exemplo de entrada e saída: No exemplo abaixo mostramos os resultados de duas turmas e como poderia ser a interação entre o professor e o programa. Para facilitar o entendimento escrevemos em negrito o texto escrito pelo computador e em fonte normal o texto escrito pelo professor. O programa não precisa fazer esta diferença. EU COMECEI A FAZER MAS AGARREI E NÃO CONSIGO PROSSEGUIR, ALGUÉM ME AJUDA? Algoritmo "semnome" Var n:inteiro media:inteiro soma:inteiro Inicio escreval ("Quantidades de alunos") leia(n) para media de 1 ate n faca Escreva("Digite a media==>") leia(media) se (0.0<=media) e (media<=2.5)então senao Se (media>2.5) e (media<=5.0)então senao se (media>5.0) e (media<=7.5)então senao se (media>7.5) e (media<==10.0)então senao fimse fimse fimse fimse fimpara Fimalgoritmo
  2. Olá pessoal, tudo beleza? Alguém pode dar uma lida no meu código para ver como está? Agradeço desde já =D algoritmo "Criança Esperança" var N, Valor, Confirmar: inteiro inicio EscrevaL("-----------------------") EscrevaL(" CRIANÇA ESPERANÇA ") EscrevaL("-----------------------") EscrevaL() EscrevaL(" Muito obrigado por participar") EscrevaL() EscrevaL(" Para doar 15 reais, pressione [1]") EscrevaL(" Para doar 20 reais, pressione [2]") EscrevaL(" Para doar 30 reais, pressione [3]") EscrevaL(" Para doar 40 reais, pressione [4]") EscrevaL(" Para doar outros valores, pressione [5]") EscrevaL(" Para cancelar, pressione [6]") EscrevaL() Escreva(" Pressione a opção desejada: ") Leia(N) Escolha N Caso 1 Valor := 15 Caso 2 Valor := 20 Caso 3 Valor := 30 Caso 4 Valor := 40 Caso 5 Escreva(" Por favor, digite a quantia que deseja doar:") Leia(Valor) Caso 6 Valor := 0 FimEscolha Se N <> 6 então Enquanto (Confirmar <> 1) e (Confirmar <> 2) faca EscrevaL(" [1] Confirma a doação no valor de R$", Valor:3:2) EscrevaL(" [2] Cancela a doação") Leia(Confirmar) Se Confirmar = 1 então EscrevaL(" Você doou R$", Valor, ",00.") Escreva(" Obrigado pela participação!") Senao Se Confirmar = 2 então EscrevaL(" Você cancelou a participação. Valor doado: R$0,00.") Senao EscrevaL("Opção inválida") Fimse Fimse FimEnquanto Senao EscrevaL(" Você cancelou a participação. Valor doado: R$0,00.") Fimse fimalgoritmo
  3. Olá pessoal, poderiam dar uma olhada no meu código para avaliar como está? Segue: É no VisualG: Algoritmo "Dizer o maior número" //----------------------------------- funcao dizer_maior_numero (x,y: inteiro): inteiro var vetorA: vetor[1..5] de inteiro j : inteiro inicio para j de 1 ate 5 faca leia(vetorA[j]) fimpara repita y := y + 1 se vetorA[x] > vetorA[y] então y := y x := x senao x := y fimse ate y = 5 retorne vetorA[x] fimfuncao //----------------------------------- var a, n : inteiro inicio a := 1 n := 1 escreva(dizer_maior_numero(a,n)) Fimalgoritmo Agradeço desde ja.
  4. VisualG visual g (uri 1001)

    Boa noite, Pessoal sou novo aqui Então e o seguinte eu estava cursando Tecnologia Analise e Desenvolvimento de Sistemas na (Uninove) Acabei saindo no segundo semestre por falta de dinheiro para pagar 2.500 reais mais fazer o que né ! vou voltar agora em 2018 consegui juntar a granda mais agora vamos la como vou voltar estou tentando relembrar o que aprendi de programação e comecei pelo primeiro progrma VISUALG ! na uninove o professor usava o metodo de avaliação do (uri online judge) onde ja há formulas prontas ! resolvemos e postasmos no site mesmo para ele corrigir pelo menos com c# e javascript ! agora preciso de ajuda para fazer isso no VISUALG a formula e a seguinte: Se poderem me ajudar ficaria agradecido boa noite ^^
  5. Olá. Tenho um algoritmo que pede dois valores, um inicial e um final, eu preciso fazer ele contar do menor pro maior, e do maior pro menor, independente do valor digitado. algoritmo "ContagemInteligente" var I, F: Inteiro inicio I <- 0 F <- 0 //Bloco do pedido das variáveis Escreval ("CONTAGEM INTELIGENTE") Escreval ("--------------------") Escreva ("Início: ") Leia(I) Escreva ("Fim: ") Leia(F) //Blocos dos contadores Se (I > F) então Enquanto (I > F) faca I <- I - 1 Escreva (I) FimEnquanto SeNao Se (I < F) então Enquanto (I < F) faca F <- F + 1 Escreva (F) FimEnquanto FimSe FimSe fimalgoritmo Mas sempre que eu rodo o código, acontece o seguinte: Se o Início é MENOR que o final: ele conta infinitamente Se o Início é MAIOR que o final: ele faz tudo certo. Eu não tô conseguindo entender meu erro: Se o I < F então ele soma mais um até o I não ser < que o F. Mas ele conta pra sempre Se (I < F) então Enquanto (I < F) faca F <- F + 1 Escreva (F) FimEnquanto FimSe FimSe adicionado 6 minutos depois Eu dei uma mudada no código: algoritmo "ContagemInteligente" var I, F: Inteiro inicio I <- 0 F <- 0 //Bloco do pedido das variáveis Escreval ("CONTAGEM INTELIGENTE") Escreval ("--------------------") Escreva ("Início: ") Leia(I) Escreva ("Fim: ") Leia(F) //Blocos dos contadores Se (I < F) então Enquanto (I < F) faca I <- I + 1 Escreva (I) FimEnquanto SeNao Se (I > F) então Enquanto (I > F) faca I <- I - 1 Escreva (F) FimEnquanto FimSe FimSe fimalgoritmo Mas agora quando eu digito um número maior no Início, ele repete o número final algumas vezes
  6. Eu estou com alguns problemas pra fazer um programa que tenha um registro dentro de uma matriz com duas dimensões no VisualG. Eu consigo fazer registro com um vetor de boa, o problema só surge quando eu preciso de dois índices pra definir os elementos. Segue o código do meu programa. O programa dá erro na linha que eu peço pra ler Automoveis.MAutomovel[i,j] Algoritmo "MovimentacaoDeLocacao" Tipo Clientela = registro Codigo : inteiro NCliente : caractere Soma : real fimregistro Carros = registro MAutomovel : caractere ValorLoc : real fimregistro Var // Seção de Declarações das variáveis Clientes : Vetor [1..100] de Clientela Automoveis : Vetor [1..100,1..100] de Carros i, j , n , p , class : inteiro Inicio // Seção de Comandos, procedimento, funções, operadores, etc... escreval ("Digite o número de clientes a serem cadastrados :") leia (n) para i de 1 ate n faca Clientes.Codigo[i] := i + 1000 escreval ("Digite o nome do cliente :") leia (Clientes.NCliente[i]) escreval ("Digite o número de automóveis que o cliente pretende cadastrar :") leia (p) para j de 1 ate p faca escreval ("Digite o nome da marca/modelo do ", j ,"° automóvel ") leia (Automoveis.MAutomovel[i,j]) escreval ("Selecione a classificação do automóvel") escreval ("1 - Básico (R$ 80,00) ") escreval ("2 - Intermediário (R$ 150,00) ") escreval ("3 - Executivo (R$ 300,00) ") leia (class) escolha class caso 1 Automoveis.ValorLoc[i,j] := 80,00 caso 2 Automoveis.ValorLoc[i,j] := 150,00 caso 3 Automoveis.ValorLoc[i,j] := 300,00 outrocaso escreval ("Opção inválida!") j := j - 1 fimescolha Clientes.Soma[i] := Clientes.Soma[i] + Automoveis.ValorLoc[i,j] limpatela fimpara limpatela fimpara escreval ("CLIENTES CADASTRADOS") escreval (" ") para i de 1 ate n faca escreval ("Código : C", Clientes.Codigo[i]) escreval ("Nome Do Cliente : ", Clientes.NCliente[i]) para j de 1 ate p faca escreval ("Marca/Modelo do ", j ,"° Automóvel : ", Automoveis.MAutomovel[i,j]) escolha Automoveis.ValorLoc[i,j] caso 80,00 escreval ("Descrição Da Classificação : Básico ") escreval ("Valor Da Locação : R$ 80,00 ", ) caso 150,00 escreval ("Descrição Da Classificação : Intermediário ") escreval ("Valor Da Locação : R$ 150,00 ", ) caso 300,00 escreval ("Descrição Da Classificação : Executivo ") escreval ("Valor Da Locação : R$ 300,00 ", ) fimescolha fimpara escreval ("Valor Total Da Locação : R$ ", Clientes.Soma[i]) fimpara Fimalgoritmo É para um trabalho semestral que eu preciso entregar em no máximo duas semanas, então eu preciso resolver esse problema o mais rápido possível. Conto com a ajuda de vocês e agradeço desde já pela atenção.
  7. Olá. Eu tenho um exercício que é o seguinte: Eu fiz uma repetição, que ele te pergunta números, no final ele soma esses números, e mostra o maior valor. Porém eu preciso criar uma variável que me mostre o MENOR valor digitado. E nisso eu realmente empaquei. (E se alguém me explicar a parte de >como< ele "acha" o maior valor, eu ficaria agradecido porque eu entendi mais ou menos. algoritmo "semnome" var N, V, S, MV, NV : Real //MV - Maior valor, NV - Menor Valor inicio N <- 1 S <- 0 Enquanto (N <= 5) faca Escreva ("Digite o", N ,"º valor: ") Leia (V) Se (V > MV) então MV <- V FimSe Se (N = 1) então NV <- N SeNao Se (N = NV) então NV <- N FimSe FimSe S <- S + V N <- N + 1 FimEnquanto Escreval ("O total dos valores digitados é:", S) Escreval ("O maior valor digitado foi:", MV) Escreva ("O menor valor digitado foi:", NV) fimalgoritmo Eu suponho que seja algum erro relacionado a essa parte, sempre que ele "mostra" o menor valor, ele sempre o coloca como sendo 1. Se (N = 1) então NV <- N SeNao Se (N = NV) então NV <- N FimSe FimSe Se alguém puder me dar uma luz, eu agradeço. ._.
  8. Boa noite! Prezados, estou iniciando a vida de programação na faculdade, estamos vendo sobre o VisualG. Tenho umas linhas básicas para tentar decifrar, podem me ajudar?! Precisava mostrar os resultados dessas expressões. A - ((8 MOD 3) DIV 2 > (3 DIV 2) MOD 8) B - ((15 MOD 7) DIV (15 DIV 7)) C - RAIZQ(25) + 19 - 23 D - (((10 DIV 2) MOD 6) > 5) E - (EXP(5,2) + 3) <= ((200 DIV 10) mod 4) Obrigado pela atenção!!!
  9. Boa noite, alguem pode me ajudar com esse execício? No jogo de Xadrez o cavalo é uma peça que descreve um movimento peculiar que tem o formato de um “L”. Imagine um tabuleiro de xadrez com apenas um cavalo posicionado em uma casa qualquer. Imagine ainda que esse cavalo deve visitar quantas casas for possível (obviamente respeitando sua regra de movimentação), sem repetir nenhuma casa, até que visite todas as casas ou fique preso em alguma casa. Observe o exemplo a seguir. Nele nota-se que o cavalo saiu da posição 1, em seguida visitou a posição 2 e assim sucessivamente até chegar à posição 23, de onde o cavalo não consegue mais visitar outras casas. Usando seus conhecimentos de Construção de Algoritmos, construa um algoritmo em VisuAlg que simule o passeio descrito. Seu algoritmo deve cumprir com os seguintes requisitos mínimos:  o usuário deve poder indicar a posição de partida (casa inicial) do cavalo;  a partir da casa inicial o cavalo deve sempre escolher aleatoriamente a próxima casa a ser visitada;  cada casa visitada deve ser marcada com algum caractere para diferenciá-la de uma casa ainda não visitada;  a cada movimentação do cavalo a configuração do tabuleiro deve ser exibida ao usuário;  ao término do passeio deve ser exibido o número de casas visitadas e o número de casas não visitadas
  10. Pessoal, preciso de uma ajuda para realizar uma atividade. Tenho que criar um variavel para nome, e nela tem que ter o nome e sobrenome da pessoa, porém preciso que ela seja separada assim que detectar um espaço, para que eu possa utilizar o LEIA e funcionar com qualquer nome, independente da quantidade de caracteres. Muito obrigado pela atenção desde já
  11. VisualG Exercicios do Visual G

    Será que alguém pode me ajudar? Faça um programa que leia as medidas de uma sala retangular (largura da parede maior, largura da parede menor e altura da parede), calcule e escreva a soma das áreas das paredes internas e também do teto. Considerando a área calculada, calcule quantas latas de tintas serão necessárias para pintar a sala em questão, sabendo que uma lata de tinta é suficiente para pintar 3m2. Obs.: - Despreze a existência de portas e janelas. - Não se esqueça que a quantidade de latas de tinta deve ser um valor inteiro. A outros na lista anexadas, será que alguém consegue? (20170925162717)Lista02.pdf Outro exercício! (USAR ESCOLHA) Faça um programa que receba dois números, calcule e imprima o resultado das operações listadas a seguir, de acordo com a escolha do usuário: Escolha Operação 1 Média entre os números digitados 2 Diferença do maior pelo menor 4 Divisão do primeiro pelo segundo Se a opção digitada for inválida, mostre uma mensagem de erro e termine a execução. Lembre-se que, na operação 3, o segundo número deve ser diferente de zero. Outro exercício! Dados 3 valores L1, L2, L3, verifique se podem ser valores de lados de um triângulo (cada lado deve ser menor do que a soma dos outros dois) e, se for, determine a sua área. Caso não formem um triângulo, imprima uma mensagem informando isso. Para o cálculo da área do triângulo, considere as seguintes fórmulas: sp = (L1 + L2 + L3)/2. Área= √sp ∗ (sp−L1)∗(sp−L2)∗(sp−L3) Novamente outro O perfil de uma pessoa pode ser determinado a partir da sua data de nascimento, conforme exemplificado a seguir. Dada uma data de nascimento, informe em qual perfil a pessoa se encaixa. O ultimo exercício Faça um programa que leia 3 números e imprima-os de forma crescente (os valores devem também ser trocados nas variáveis).
  12. Bom dia Pessoal! Mais uma vez estou com dificuldade em continuar o código, nunca fiz nenhum com essa dificuldade e empaquei logo no inicio do código e não consigo continuar pois não sei direito as formulas matemáticas e ainda não decorei também para fazer. Gostaria de uma ajuda para chegar ao resultado final, Eu conseguindo fazer e tirar a duvida nesse primeiro os próximos parecidos acho que ficariam mais fácil para fazer. Segue tópico da duvida: // Função : Faça um algoritmo que receba o preço de custo e o preço de // venda de 40 produtos. Mostre como resultado se // houve lucro, prejuízo ou empate para cada produto. Informe media de // preço de custo e do preço de venda. //Parte que ja impaquei bem no inicio: algoritmo "Exercicio22" var pcusto,pvenda,mcusto,mvenda: real x: inteiro inicio para x de 1 ate 40 faca Escreval("Qual o preço de custo do produto? R$") (pcusto) Escreval("Qual o preço de venda do produto? R$") (pvenda) fimalgoritmo Obrigado a todos desde j
  13. Estou tentando resolver o exercício 1968 (A terra desconhecida) do URI online judge, mal consigo sair do início, até agora o que consegui fazer inserir as variáveis (rsrs). Preciso de ajuda pelo menos para entender um pouco mais do exercício, por favor. Obs: Pelo que eu entendi eu vou ter que descobrir quais números entre os números inseridos apresentam n divisores (ex: 2 divisores), então multiplicar a quantidade de números que supre essa condição por "n" (A quantidade de divisores estabelecidas pelo usuário) para poder achar as possibilidades de formação de grupo, onde os cidadão estão enumerados de A a B e a quantidade de grupos e obtida através de quantos líderes há. Os líderes são determinados pelo seu número, caso ele tenha n divisores. Aqui um pouco do que já fiz: Var // Seção de Declarações das variáveis a,b,n: inteiro poss: real Inicio // Seção de Comandos, procedimento, funções, operadores, etc... escreval("os baobás começaram a crescer e tomaram conta da Terra Desconhecida.") escreval("Agora, os cidadãos precisam se mudar urgentemente. Para auxiliar na") escreval("evacuação, todos os cidadãos foram numerados de A a B . Para definir") escreval("quem seriam os líderes dos grupos durante a evacuação, alguém sugeriu") escreval("que os líderes deveriam ser todos aqueles que houvessem recebido um") escreval("número primo. Mas logo outra ideia surgiu: Um número primo é um número") escreval("que possui exatamente 2 divisores. E se os líderes fossem aqueles que") escreval("receberam um número com exatamente N divisores?") escreval("Insira o número N escolhido pelos cidadãos:") leia (N) escreval("Os cidadãos foram enumerados de A a B,insira esses valores,respectivamente:") leia (a,b)
  14. Bom dia galera belezaa! Fiz um exercício do visualG ele está funcionando 70% os outros 30% não consigo saber o que é. Segue o problema para melhor entendimento: // Função : A concessionária de veículos CARANGO VELHO está vendendo os // seus veículos com desconto. Faça um // algoritmo que calcule e exiba o valor do desconto e o valor a ser pago // pelo cliente de vários carros. O desconto // deverá ser calculado de acordo com o ano do veículo. Até 2000 - 12% e // acima de 2000 - 7%. O sistema deverá // perguntar se deseja continuar calculando desconto até que a resposta // seja: \u201c(N) Não\u201d . Informar total de carros com // ano até 2000 e total geral. O 1- problema é o meu código só calcula veículos abaixo do ano 2000, acima do ano 2000 ele não tá calculando. O 2- problema é que eu não consigo exibir o valor do desconto atribuído, só consigo mostrar o valor a ser pago, o quanto foi o desconto não consegui fazer segue o código para ver se alguém consegue me ajudar Obrigado a todos! var valor,descont, valorfinal: real ano: inteiro resp: caracter inicio Escreval("<><><><><><><><><><> CONCESSIONARIA DE VEÍCULOS CARANGO VELHO <><><><><><><><><><>") Escreval("") Repita Escreva("Qual o valor do veiculo? R$:") Leia(Valor) Escreva("Qual o ano do veicúlo desejado?:") Leia(ano) Se ano <= 2000 então valorfinal <- valor - (valor*12/100) senao Se ano > 2000 então valorfinal <- valor - (valor*7/100) descont <- valorfinal - descont Fimse Fimse Escreval(" O valor de desconto é:", descont) Escreval(" O valor a ser pago pelo cliente é:", valorfinal) Escreval("") Escreval("") Escreva("Deseja continuar calculando o desconto? S/N") Leia(resp) Ate (resp = "n") fimalgoritmo
  15. VisualG Construção algoritmo de numeração

    Boa noite sou iniciante no assunto tive uma ideia criar um programa de numeração que funcione assim tenho 60 números dos 60 vou remover 10 certo sobra 50 ja dos 50 quero gerar dele aleatoriamente 30 so que 3 vezes esse mesmo processo dos 30 que ele gero vou fixar nos 3 que ele gerou 10 n certo ai sobra 20 desses 20 que sobrou gerar aleatoriamente mais 10 n por 5 vezes me ajudem por favor eu não sei nem por onde começar acho muito difícil
  16. Fala galera, to com dificuldade para fazer um exercício, tenho q fazer um programa que diz se o CPF é valido ou não, mas sem usar o caracpenum
  17. VisualG VisualG Finalizando o Código

    Fala galera estou com uma dificuldade para calcular o fim do código... Pois bem consigo calcular a soma de cada linha, porém depois o total q seria calcular a soma das 4 linhas não estou conseguindo... Meu código esta assim: algoritmo "semnome" // Função : // Autor : // Data : 21/09/2017 // Seção de Declarações var l,c,somalinha, total : inteiro numeros : vetor [1..4,1..5] de inteiro inicio // Seção de Comandos para l de 1 ate 4 faca para c de 1 ate 5 faca Escreval ("informa o valor da posicao : ",1,"-",c," : ") leia (numeros [l,c]) fimpara fimpara limpatela para l de 1 ate 4 faca somalinha <-0; para c de 1 ate 5 faca somalinha <- somalinha+numeros[l,c] fimpara Escreval ("A soma da linha : ",l, "-", somalinha) fimpara fimalgoritmo
  18. faça um programa que leia três números, mostre-os em ordem decrescente informando se os mesmo são pares ou ímpares. Exemplo: 10 (par), 7 (impar) 4 (par)
  19. Boa dia gente, eu tenho um trabalho para entregar, onde preciso montar um algoritmo em Visualg das seguintes questões: (Por favor preciso do algoritmo o mais rápido possível) 01- É possível calcular a área de um pentágono regular, ou seja, uma figura geométrica com cinco lados iguais, dado o comprimento de um dos lados. Sendo assim, calcule. Escreva um programa que, dado o comprimento de um lado de um pentágono regular, calcule a sua área. *Entrada Haverá um valor C que indica a quantidade de casos de teste. Em seguida, haverá um número inteiro N para cada caso (1 ≤ N ≤ 10000), indicando o comprimento do lado de um pentágono regular. *Saída Para cada caso de teste, imprima o valor correspondente da área do respectivo pentágono, com três casas decimais de precisão. 02- Cici, Cini e Cino viajaram para o Polo Norte, e querem conhecer os principais pontos turísticos de lá. Para ajuda-los, o Papai Noel decidiu emprestar três renas para eles. As renas do Papai Noel tem capacidade de se teletransportarem, fazendo que as viagens entre os pontos turísticos sejam instantâneas. Papei Noel informou que existem N pontos turísticos, e que suas renas podem realizar dois tipos de passeios: Passeio tipo 1: Dada uma sequência de pontos turísticos que deseja visitar, a rena realiza um passeio parando durante um hora em cada ponto da sequência. Por exemplo: Dada a sequência <1, 2, 1>, a rena vai ficar durante uma hora no ponto 1, depois uma hora no ponto 2 e mais uma hora no ponto 1. Passeio tipo 2: Dada uma sequência de pontos turísticos que deseja visitar, a rena realiza um passeio do tipo 1 utilizando uma subsequência não vazia da sequência escolhida. Por exemplo, se a sequência escolhida for <1, 2, 1>, a rena pode fazer qualquer um dos 6 passeios distintos, escolhido aleatoriamente por ela: <1>, <2>, <1, 1>, <1, 2>, <2, 1>, <1,2,1>. Cici e Cini gostaram do fator surpresa do passeio de tipo 2, porém, Cino optou pelo do tipo 1. Como Cici, Cini e Cino possuem preferências diferentes, cada um pode escolher uma sequência diferente de lugares. Sabendo as sequências escolhidas por Cici e Cini, Cino vai escolher a menor sequência em que seja garantido que em pelo menos um local não seja visitado pelos três amigos ao mesmo tempo. Por exemplo: O Papei Noel informou que o Polo Norte possui 3 pontos turísticos distintos. Cici escolhe a sequência <1, 2>. Cini escolhe <2, 3>. Logo, Cino pode escolher as sequências <1> e <3>, mas não pode escolher a sequência <2>, pois existe a chance de os três visitarem o ponto <2> ao mesmo tempo. Entrada A entrada é constituída de múltiplos casos de teste. Cada caso de teste é constituído por 3 linhas. A primeira linha de cada caso de teste contém 3 inteiros, N (1 ≤ N ≤ 50), X e Y (1 ≤ X, Y ≤ 103), representando respectivamente a quantidade de pontos turísticos, o tamanho da sequência escolhida por Cici e o tamanho da sequência escolhida por Cini. A segunda linha contém X inteiros, representando a sequência escolhida por Cici. A terceira linha contémY inteiros, representando a sequência escolhida por Cini. A entrada termina com final de arquivo (EOF). Saída Para cada caso de teste, imprima uma linha contendo o tamanho da menor sequência e o número de sequências que Cino pode escolher, separados por um único espaço. É garantido que um inteiro de 64 bits com sinal seja suficiente para armazenar a resposta. 03- Senhor Coelho é conhecido mundialmente pela fabricação de quadrados mágicos de dimensôes 3 × 3. Um quadrado é chamado mágico quando a soma dos elementos de uma determinada linha, coluna ou diagonal é sempre igual. Infelizmente, assaltantes invadiram recentemente a oficina do Sr. Coelho e roubaram alguns dos números de seus quadrados mágicos. Felizmente os meliantes não conseguiram roubar mais do que 3 números de cada quadrado. Desesperado, pois devia entregar os quadrados naquele dia, o Sr. Coelho veio procurar a sua ajuda para tentar completar os quadrados com os números faltantes. Escreva um programa que, dado um quadrado mágico com alguns números faltando, determine qual era o quadrado mágico original. Entrada A entrada contém um único conjunto de testes, que deve ser lido do dispositivo de entrada padrão (normalmente o teclado). A entrada contém três linhas, cada uma contendo três inteiros N (0 ≤ N ≤ 20000). O número zero representa os digitos que foram roubados. Existem no máximo três números zero na entrada. Saída Seu programa deve imprimir, na saída padrão, três linhas, cada uma contendo três inteiros, descrevendo a configuração original do quadrado mágico. 04- No último dia 12 de outubro comemoramos no Brasil o Dia das Crianças. Quem dera nós adultos vivêssemos mais no mundo das crianças, pois o inverso não tem dado certo, não mesmo. Nós adultos dividimos o mundo em nações, e são as crianças que mais sofrem com as guerras. Nós adultos criamos um sistema de distribuição de riqueza, e são as crianças que mais sofrem com a fome. Mas há uma Terra Desconhecida, não muito distante daqueles que ainda conservam um pouco da sua imaginação, que pertence às crianças. Lá não há guerra, não há pobreza, não há fome. Lá as crianças brincam dia e noite. Mas uma catástrofe está ocorrendo com a Terra Desconhecida. Uma catástrofe! Os carneiros que habitavam a Terra Desconhecida acabaram ficando velhos, ou doentes, ou engolidos por jiboias. Com isso, os baobás começaram a crescer e tomaram conta da Terra Desconhecida. Agora, os cidadãos precisam se mudar urgentemente. Para auxiliar na evacuação, todos os cidadãos foram numerados de A a B (é óbvio que essa ideia foi dos adultos — eles adoram essas coisas!). Para definir quem seriam os líderes dos grupos durante a evacuação, alguém sugeriu que os líderes deveriam ser todos aqueles que houvessem recebido um número primo (é óbvio que essa ideia foi de uma criança — crianças têm muita imaginação e adoram se deleitar com coisas que dispensam maiores explicações!). Mas logo outra ideia surgiu: — Um número primo é um número que possui exatamente 2 divisores. E se os líderes fossem aqueles que receberam um número com exatamente N divisores? Todas as crianças adoraram a ideia. Já os adultos ficaram um longo tempo debatendo sobre como o número Ndeveria ser escolhido. Quando finalmente o número N foi escolhido, cada cidadão que não fosse líder de um grupo deveria escolher o grupo que quisesse para nele entrar. Nenhuma outra restrição foi imposta aos grupos. Nada impedia, por exemplo, que um grupo consistisse apenas do seu líder. Note que, dependendo do valor de N, nem haveria grupo algum. Sabendo dos valores de A, B e N, solte a criança dentro de você e tente descobrir o número total de possibilidades para a formação dos grupos. Se, por exemplo, A = 5, B = 8 e N = 4, situação em que os líderes são os cidadãos 6 e 8, há 4 possibilidades: ambos os cidadãos 5 e 7 escolhem entrar para o grupo liderado pelo cidadão 8; o cidadão 5 escolhe entrar para o grupo liderado pelo cidadão 6 e o cidadão 7 escolhe entrar para o grupo liderado pelo cidadão 8; o cidadão 5 escolhe entrar para o grupo liderado pelo cidadão 8 e o cidadão 7 escolhe entrar para o grupo liderado pelo cidadão 6. Entrada A única linha da entrada consiste unicamente dos inteiros positivos A, B e N (A ≤ B; B, N ≤ 107). Saída Imprima uma linha contendo unicamente um valor que represente o número de possibilidades para a formação dos grupos. Como esse número pode ser muito grande, imprima apenas o resto que ele deixa quando dividido por 109^ + 7
  20. Boa Tarde Pessoal Tudo bem! Estou querendo aprender um pouco de programação, e estou treinando no visualg para futuramente começar a aprender html5, javascript e css. Estou com dificuldade no exercício abaixo alguém poderia resolve-lo para mim no visualg colocando qual é a resposta no programa para eu aprender como faz? Segue questão: // Função : Faça um algoritmo que receba o preço de custo de um produto e // mostre o valor de venda. Sabe-se que o preço de // custo receberá um acréscimo de acordo com um percentual informado pelo usuário. Obrigado a todos!
  21. Oi, sou novo no fórum e não sei exatamente se posso criar isso aqui, mas preciso de ajuda num código que estou tentando fazer comecei a me interessar em algoritmos esses dias vendo vídeos no youtube, é o primeiro código que tento fazer sozinho, um tipo de "par ou ímpar" quero fazer um tipo de "proteção" que quando o usuário digitar uma letra ao invés de um número o comando repita até ele digitar um número válido algoritmo "PAR OU ÍMPAR?" var numUsuario,numComputer,total: real escolhaUsuario: inteiro usuario,computer: caractere inicio escreval ("Para escolher par digite [1]") escreval ("Para escolher ímpar digite [2]") leia (escolhaUsuario) limpaTela escolha (escolhaUsuario) caso 1 usuario <- "PAR" computer <- "IMPAR" caso 2 usuario <- "IMPAR" computer <- "PAR" fimEscolha escreval ("Digite um número de 0 a 10") leia (numUsuario) limpaTela enquanto numUsuario > 10 faca escreval ("Número inválido. Digite um número de 0 a 10") leia (numUsuario) limpaTela fimEnquanto numComputer <- randi(10) total <- numUsuario + numComputer escreval ("SUA ESCOLHA FOI: ",numUsuario) escreval ("A ESCOLHA DO COMPUTADOR FOI: ",numComputer) escreva (total) fimalgoritmo quero fazer algo como isso: "enquanto numUsuario > 10 faca ...." só que ao invés de "> 10" quero fazer com qualquer letra "se o computador ler uma letra ele vai repetir a mensagem 'Número inválido. Digite um número de 0 a 10' e quando ele digitar algo válido o código segue" ele não está completo, pode ter algumas variáveis soltas ou rascunhos
  22. Construa um algoritmo para calcular as raízes de uma equação de 2º grau a partir dos seus coeficientes A, B e C. Lembre-se da possibilidade de raízes iguais e de não haver raiz real. valeu
  23. Estou fazendo um exercício no qual preciso dar a sequencia Fibonacci, eu já entendi a sequencia da mesma, mas eu não consigo pegar o numero anterior resultado para fazer a soma. var n: inteiro //n1 cont: inteiro //contador s: inteiro //n2 f: inteiro //sequencia inicio // Seção de Comandos cont <- 0 f <- 0 s <- 1 REPITA f <- f + s s <-f escreva(f) cont <- cont+1 ATE cont>5 fimalgoritmo Se alguém souber como posso fazer agradeço desde já.
  24. Bom dia, estou começando na linguagem de Portugol e meu Visualg está dando um erro um tanto quanto estranho. Escreva("Informe 3 numeros:") leia(a,b,c) SE (a>b e b>c) então ESCREVA("ORDEM: ", a, b, c) FIMSE SE (a>b e b<c) então ESCREVA("ORDEM: ", a, c, b ) FIMSE SE (b>a e a>c) então ESCREVA("ORDEM: ", b, a, c) FIMSE SE (b>a e a<c) então ESCREVA("ORDEM: ", b, c, a) FIMSE SE (c>a e a>b) então ESCREVA("ORDEM: ", c, a, b ) FIMSE SE (c>a e a<b) então ESCREVA("ORDEM: "), c, b, a) FIMSE Quando eu executo o Visualg afirma que esta faltando um então na primeira linha, mas não está, queria saber o porque.
  25. Boa noite alguém pode me ajudar com este algoritmo, onde está o erro Algoritmo "O menor número digitado" Var ContaNumero, NumeroDigitado, SomaNumero, MenorNumero: inteiro Inicio ContaNumero <- 1 Somanumero <- 0 Enquanto ContaNumero <= 2 Faca Escreva("Digite o", ContaNumero,"º número: ") Leia(NumeroDigitado) Se ( NumeroDigitado < MenorNumero) então MenorNumero <- NumeroDigitado FimSe ContaNumero <- ContaNumero + 1 SomaNumero <- SomaNumero + NumeroDigitado FimEnquanto EscrevaL("O menor número digitado foi ", MenorNumero) Escreva("Resultado da soma de todos os números é de ",SomaNumero) Fimalgoritmo

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×