Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.

Pesquisar na Comunidade

Mostrando resultados para as tags ''VisualG''.



Mais opções de pesquisa

  • Pesquisar por Tags

    Digite tags separadas por vírgulas
  • Pesquisar por Autor

Tipo de Conteúdo


Categorias

  • Armazenamento
  • Áudio
  • Energia
  • Entrada
  • Feiras e Eventos
  • Gabinetes
  • Memória
  • Museu
  • Placas-mãe
  • Portáteis
  • Processadores
  • Programas
  • Rádio CdH
  • Redes
  • Refrigeração
  • Smartphones
  • Tablets
  • Vídeo
  • Outros

Categorias

  • Blog

Categorias

  • Armazenamento
  • Áudio
  • Câmeras
  • Computadores
  • Consoles
  • Eletrônicos
  • Energia
  • Entrada
  • Gabinetes
  • Impressão
  • Jogos
  • Memória
  • Placas-mãe
  • Portáteis
  • Processadores
  • Programas
  • Redes
  • Refrigeração
  • Smartphones
  • Tablets
  • Vídeo
  • Outros

Categorias

  • Livros disponíveis
  • Livros esgotados

Categorias

  • Cursos

Fóruns

  • Mensagens do Clube do Hardware
    • Regras gerais
    • Boletins do Clube do Hardware
    • Notícias da administração
  • Hardware
    • Recomendações de computadores
    • Placas de vídeo
    • Placas-mãe e chipsets
    • Processadores
    • Problemas de gargalo e desempenho
    • Memórias
    • Armazenamento
    • Refrigeração e superaquecimento
    • Fontes e energia
    • Gabinetes e casemods
    • Placas de som e áudio on-board
    • Periféricos
    • Mac
    • Overclock
    • Hardware - outros
  • Computação móvel
    • Notebooks
    • Tablets
    • Smartphones e apps
  • Redes e Internet
    • Redes e Internet
    • Hospedagem de sites e registro de domínios
  • Segurança da informação
    • Remoção de malware
    • Dúvidas sobre invasões e infecções
    • Programas de proteção
  • Programação e desenvolvimento
    • Java
    • C/C#/C++
    • Pascal/Delphi
    • .NET
    • Bancos de dados
    • Programação web
    • Programação - iniciantes
    • Programação de microcontroladores
    • Programação - outros
  • Software
    • Jogos
    • Pacotes de escritório
    • Computação distribuída (Folding@Home, Bitcoin etc.)
    • Virtualização
    • Design, animação e tratamento de imagens
    • Edição de áudio e vídeo
    • Programas
  • Sistemas Operacionais
    • Recomendação de sistemas operacionais
    • Windows
    • GNU/Linux, BSD, Unix-like e software livre
    • Mac OS
  • Eletrônicos
    • Equipamentos de som, home theaters e gravadores de mesa
    • Televisores e projetores
    • Câmeras e filmadoras
    • Players portáteis
    • Consoles (videogames)
    • GPS
    • Telefonia fixa
    • Eletrônica
    • Retrocomputação
  • Outros
    • Recomendações de serviços e lojas
    • Preços e promoções
    • Notícias
    • Bolsa de empregos, certificações e mercado de trabalho
    • "Causos"
    • Encontros de usuários
    • Feira do Rolo
  • Clube do Hardware
    • Comentários, elogios, críticas e sugestões sobre o Clube do Hardware
    • Comentários de artigos
    • Fórum para testes de funcionalidades

Categorias

  • Hardware
  • Redes
  • Eletrônica
  • Sistemas operacionais

Encontrado 87 registros

  1. Ola Pessoal, Boa noite, sou novo aqui no fórum, mas vi que sempre que possível podemos tirar algumas duvidas.. Comecei a aprender programação sozinho e estou usando como auxilio o VISUALG Para desenvolver meus algoritmos, Tenho material de apoio e sempre tento resolver sozinho ( a maioria das vezes sofro mas consigo) Minha intenção é simplesmente entender qual meu erro logico no seguinte problema. Desenvolvi este algoritmo que calcula o adicional noturno de um funcionário com base em algumas informações fornecidas, o problema é que quando o programa pede ao usuário para digitar o salario, se este digitar usando um ponto (.) ex (1.800) o programa retorna o resultado do adicional noturno com um zero antes como um numero decimal, Ex( 0.315) No entanto se o usuário digita o salario sem o ponto, o programa retorna o resultado correto sem o Zero Como deveria editar algoritmo para que o resultado seja sempre coerente, independente do que o usuário digite? Var // Seção de Declarações das variáveis valorhora: real adicionalporhora: real horascontratuais: inteiro salario: real jornada: inteiro diastrabalhados: inteiro folgas: inteiro adicionalnoturnototal: real nome: caracter jornadadeadicional: inteiro qtdhorasadicionais: real horasadicionaismes: inteiro Inicio // Seção de Comandos, procedimento, funções, operadores, etc... Escreval("Oi, Para iniciar digite seu nome") leia ( nome) escreval("") escreval (nome," Digite seu salario") leia (salario) escreval("") escreval(nome," Digite suas folgas no mes") leia (folgas) escreval("") escreval(nome," Digite sua jornada total na noite de trabalho") leia (jornada) escreval("") escreval("O adicional noturno eh valido das 22:00 ate as 5:00 portanto ") escreval ("digite quantas horas de Adicional notunro você se encaixa") leia(jornadadeadicional) escreval("") diastrabalhados <- 30 - folgas horascontratuais <- diastrabalhados*jornada valorhora <- salario/horascontratuais adicionalporhora <- valorhora*0.2 horasadicionaismes <- diastrabalhados*jornadadeadicional adicionalnoturnototal <- horasadicionaismes*adicionalporhora Escreval ("Ola ",nome," voce trabalha ",horascontratuais," horas por mes,com um salario base de ",salario) escreval("") escreval ("Portanto sua hora de trabalho vale ",valorhora," R$ Logo, seu adicional noturno sera no valor de ",adicionalnoturnototal," R$ mensais") escreval("") Fimalgoritmo
  2. como posso fazer um código para testar se um e-mail é valido no visualg usando função as regras são as seguintes: Um e-mail é válido quando possui apenas algarismos alfanuméricos, “_”, “-“ e “.”, 1 “@” e ao menos 1 ponto após o “@”. Quando não possuir arroba, iniciar com um caractere diferente de letra ou ”_”, não possuir ao menos 1 ponto após o “@” ou possuir caracteres especiais além dos válidos. por favor me ajudem
  3. Alguém poderia me ajudar? Não achei nada relacionado a isso.
  4. 1. Monte um algoritmo para contabilizar os acertos de um determinado jogo, levando em conta a explicação a seguir: a.) Alimente uma matriz de ordem 10 com números aleatórios entre 1 e 100 b.) Alimente um vetor de 10 posições com números aleatórios entre 1 e 100 c.) Contabilize a pontuação de acertos Ao final, exiba a matriz, o vetor e quantos acertos foram realizados.
  5. Bom eu tenho que fazer um trabalho pra faculdade, e eu só me prendi nisso(o algoritmo que venho pedir ajuda) por questão de insistência. Não preciso fazer ele, posso fazer outra forma, mas eu acredito que vá funcionar. O problema que tenho, é que na hora de calcular, o desconto acaba saindo diferente da porcentagem que peço. Queria que, caso possam, me mostrem o que fiz errado. Tenho que entregar ele hoje. To preso a dias vendo forma de arrumar e não consigo. Então, se alguém me ajudar a tempo, uso ele. Se não ajudarem ou for "tarde demais", fica o aprendizado apenas. Indo direto ao ponto, eu quero aplicar um valor de 5 porcento em valores totais acima de 200 e 10 porcento acima de 1000. Mas na hora de aplicar o resultado, ele tá multiplicando a porcentagem junto. Desde já, agradeço. Segue o algoritmo (ta bem porco, porque alterei tanto, que acabei não cuidando a estetica: algoritmo "semnome" // Função : // Autor : // Data : 25/11/2017 // Seção de Declarações var valor1, valor2: inteiro resultado1, media, desconto, valor_desc, total: real inicio escreva ("informe um valor: ") leia (valor1) escreva ("informe o segundo valor: ") leia (valor2) resultado1 <- (valor1)*2 + (valor2)*2 //Total com relação ao valor da manutenção, vezes as horas trabalhadas escreval ("O total foi de: ", resultado1) media <- (resultado1) SE(media>=200) então desconto <- media*5/100 total<-(media-desconto) escreval ("seu desconto foi de: ", desconto, "%", " e total a pagar foi de ", media-desconto) SENAO SE (media>=1000) então desconto <- media*10/100 escreval ("seu desconto foi de: ", desconto, " e o total a pagar foi de", media-desconto) SENAO Se(media < 200)então escreval ("o total a pagar sem desconto, foi de:", resultado1) FIMSE FIMSE FIMSE fimalgoritmo
  6. Bom dia! Segue Exercício, porém o que esta de errado na minha estrutura pois minha matriz não fica simétrica. Me ajudem!!!! Faça um algoritmo para ler uma matriz A de ordem 5x5 de números inteiros e verificar se a matriz é ou não simétrica. Dizemos que uma matriz é simétrica quando todo elemento aij é igual ao elemento aji, para todo i, j ≤ 5 var simetrica: logico I: inteiro J: inteiro N: inteiro matrizA : vetor [1..5,1..5] de real inicio //Secão de comandos simetrica <- verdadeiro para I de 1 ate 5 faca para J de 1 ate 5 faca leia(matrizA[I,J]) fimpara fimpara escreval("MATRIZ A") simetrica <- verdadeiro para i de 1 ate 5 faca para j de 1 ate 5 faca escreva(matrizA[I,J]," ") fimpara escreval(" ") fimpara simetrica <- verdadeiro para I de 1 ate 5 faca para J de 1 ate 5 faca se ( matrizA[I,J] <> matrizA[J,I] ) então simetrica <- falso fimse fimpara se ( simetrica = verdadeiro ) então escreval ("A matriz é simétrica!") senao escreval("A matriz não é simétrica!") fimse fimpara fimalgoritmo
  7. VisualG Erro sem motivo aparente

    Algoritmo "bnct" // Um banco concederá um crédito especial aos seus clientes, //variável com saldo médio no último ano. Faça um algoritmo que leia //o saldo médio de um cliente e calcule o valor do crédito de acordo com a //tabela abaixo. Mostre uma mensagem informando o saldo médio e o valor de //crédito (a porcentagem aplicada sobre o saldo médio). Var // Seção de Declarações das variáveis sma:inteiro; zporct,vtporct,trtporct,qrtporcent:real; Inicio // Seção de Comandos, procedimento, funções, operadores, etc... escreval("Qual o saldo médio anual do cliente?") leia(sma) se (sma <= 200) então zporct <- sma * 0.00 escreval("Crédito total oferecido para o saldo de R$",sma," é ",zporct) senao se (sma => 201 e sma=<400) então vtporct <- sma * 0.20 escreval("Crédito total oferecido para o saldo de R$",sma," é ",vtporct) senao se (sma => 401 e sma=<600) então trtporct <- sma * 0.30 escreval("Crédito total oferecido para o saldo de R$",sma," é ",trtporct) senao se (sma => 601) então qrtporcent <- sma * 0.40 escreval("Crédito total oferecido para o saldo de R$",sma," é ",qrtporcent) senao fimse fimse fimse fimse Fimalgoritmo Quando eu coloco valor acima de 201 da o erro.
  8. Boa tarde galera. Estou com dificuldade em 2 situações no código abaixo. 1-Gostaria que o valor da hora trabalhada já aparecesse automaticamente e não que fosse preciso digitar o valor. 2-Aplicar um desconto no valor final do serviço. Algoritmo "centro automotivo" Var a,b,opcao,op:inteiro c,d, soma: inteiro desconto: inteiro //--------------------------------------------------------------------- procedimento menu_principal Inicio //menu principal limpatela escreval ("CENTRO AUTOMOTIVO") escreval("Informe a opção de reparo") escreval ("1 - Motor") escreval ("2 - Suspensão") escreval ("3 - Freio") escreval ("4 - sair") escreva("=> ") Fimprocedimento //--------------------------------------------------------------------- //funcao da opcao 1 procedimento menu_motor inicio limpatela escreval ("Opcao informada: MOTOR") escreval ("1- Alto consumo de óleo lubrificante") escreval ("2- Excesso de fumaça sendo expelida pelo escapamento") escreval ("3- Baixa potência") escreval ("4- Voltar") escreval ("Selecione o problema relatado pelo cliente") escreva("=> ") fimprocedimento //---------------------------------------------------------------------- //funcao da opcao 2 procedimento menu_suspensao inicio limpatela escreval ("Opcao Suspensão") escreval ("1- Ruidos e batidas nas rodas") escreval ("2- Vibrações e direção puxando") escreval ("3- Desgaste irregular dos pneus") escreval ("4- Voltar") escreval ("Selecione uma opção") escreva("=> ") fimprocedimento //--------------------------------------------------------------------- // funcao opcao 3 procedimento menu_freio inicio limpatela escreval ("Opcao Freio") escreval ("1- Carro ou pedal vibrando ao pisar no pedal do freio") escreval ("2- O carro puxa para algum lado quando freia") escreval ("3- Chiado ou ronco quando pisa no freio") escreval ("4- Voltar") escreval ("Selecione uma opção") escreva("=> ") fimprocedimento //--------------------------------------------------------------------- //--------------------------------------------------------------------- procedimento alto_consumo //Motor inicio escreval("Problema informado: Alto consumo") escreval("Custo por Hora/Atividade R$ 100,00") escreval("Informe o valor da hora:") leia (c) escreval("Quantidade de horas utilizadas no serviço:") leia (d) escreval("Valor total dos serviços R$",c*d) escreval("Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento excesso_de_fumaca // Motor inicio escreval("Problema informado: Excesso de fumaça") escreval("Custo por Hora/Atividade R$ 100,00") escreval("Informe o valor da hora:") leia (c) escreval("Quantidade de horas utilizadas no serviço:") leia (d) escreval("Valor total dos serviços R$",c*d) escreval("Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento baixa_potencia //Motor inicio escreval("Problema informado: Baixa potência do motor") escreval("Custo por Hora/Atividade: R$ 100,00") escreval("Informe o valor da hora:") leia (c) escreval("Quantidade de horas utilizadas no serviço:") leia (d) escreval("Valor total dos serviços R$",c*d) escreval("Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento ruidos_e_batidas_nas_rodas //Suspensão inicio escreval("Problema informado: Ruidos e batidas nas rodas") escreval("Custo por Hora/Atividade: R$ 200,00") escreval("Informe o valor da hora:") leia (b) escreval("Quantidade de horas utilizadas no serviço: ") leia (d) escreval("Valor total dos serviços R$",b*d) escreval("Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento Vibracoes_e_direcao_puxando //Suspensão inicio escreval("Problema informado: Vibrações e Direção puxando") escreval("Custo por Hora/Atividade: R$ 200,00") escreval("Informe o valor da hora:") leia (b) escreval("Quantidade de horas utilizadas no serviço: ") leia (d) escreval("Valor total dos serviços R$",b*d) escreval("Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento desgaste_irregular_dos_peneus //Suspensão inicio escreval("Problema informado: Pneus desgastando de forma irregular") escreval("Custo por Hora/Atividade: R$ 200,00") escreval("Informe o valor da hora:") leia (b) escreval("Quantidade de horas utilizadas no serviço: ") leia (d) escreval("Valor total dos serviços R$",b*d) escreval("Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento carro_ou_pedal_vibra_ao_pisar //Freio inicio escreval("Problema informado: Carro ou pedal vibrando ao pisar no freio") escreval("Custo por Hora/Atividade: R$ 300,00") escreval("Informe o valor da hora:") leia (b) escreval("Quantidade de horas utilizadas no serviço: ") leia (d) escreval("Valor total dos serviços R$",b*d) escreval("Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento carro_puxa_para_algum_lado //Freio inicio escreval("Problema informado: Veículo com tendencia de saída para os lados") escreval("Custo por Hora/Atividade: R$ 300,00") escreval("Informe o valor da hora:") leia (b) escreval("Quantidade de horas utilizadas no serviço: ") leia (d) escreval("Valor total dos serviços R$",b*d) escreval("Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento Chiado_ou_ronco_quando_pisa //Freio inicio escreval("Problema informado: Chiado ou ronco ao acionar pedal do freio") escreval("Custo por Hora/Atividade: R$ 300,00") escreval("Informe o valor da hora:") leia (b) escreval("Quantidade de horas utilizadas no serviço: ") leia (d) escreval("Valor total dos serviços R$",b*d) escreval("Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- Inicio repita menu_principal leia(Opcao) limpatela escolha opcao caso 1 repita menu_motor leia(op) escolha op caso 1 alto_consumo caso 2 excesso_de_fumaca caso 3 baixa_potencia caso 4 escreval("voltando . . . Tecle Enter") leia(a) fimescolha ate op=4 caso 2 repita menu_suspensao leia(op) escolha op caso 1 Ruidos_e_batidas_nas_rodas caso 2 Vibracoes_e_direcao_puxando caso 3 desgaste_irregular_dos_peneus caso 4 escreval("voltando . . . Tecle Enter") leia(a) fimescolha ate op=4 caso 3 repita menu_freio leia(op) escolha op caso 1 carro_ou_pedal_vibra_ao_pisar caso 2 carro_puxa_para_algum_lado caso 3 Chiado_ou_ronco_quando_pisa caso 4 escreval("voltando . . . Tecle Enter") leia(a) fimescolha ate op=4 caso 4 escreval("você pediu para sair, saindo . . . !") fimescolha ate opcao=4 Fimalgoritmo
  9. Fala pessoal, precisava de ajuda em dois exercicios no visualG. Tentei começar mas nao consegui desenvolver acabei ficando travado... Se alguem puder ajudar. 1)Faça um programa que leia 4 numeros inteiros e apresente: a)Média dos impares b)Maior numero par c)Diferença de maior menos o menor numero 2)Faça um programa que leia o nome e idade de 3 individuos e apresente: a)Maior idade b)Nome da pessoa mais nova c)Média das idades. Se alguem pude ajudar, tmj!
  10. Então pessoal quero fazer um quis, se a pessoa errar tem que voltar para a mesma questão, tentei com repita + não deu certo, e no final se a pessoa acerta igual ou maior que 7 acertos então mostrar na tela aprovado se menos então mostrar reprovado. inicio escreval("1)Victor desenhou o triângulo determinado pelas coordenadas") escreval("dos pontos cartesianos A(7;5), B(3;2) e C(7;2)") escreval("Ao calcular a área e o perímetro desse triângulo,") escreval("os valores obtidos foram, respectivamente,") escreval("(imaginando que a dez colunas verticais e dez horizontais)") escreval("utilizem o teorema de Pitágoras :") escreval("a) 3 e 3") escreval("b) 3 e 6") escreval("c) 6 e 6") escreval("d) 6 e 12") escreval("e) 12 e 12") leia(resposta) se resposta="d" então escreval("resposta correta") fimse
  11. Galera, estou tentando fazer um programa que peça um numero qualquer entre 1 e 10 e faça a tabuada Este é meu código: algoritmo "tabuada" var i,num:inteiro inicio escreva("escreva um numero de 1 a 10: ") leia(num) para i de 0 ate 10 faca escreva (num "x" i"=" i*num) fimpara fimalgoritmo Porém tem um erro na linha "escreva (num "x" i"=" i*num)'' Poderiam me ajudar?
  12. Eu faço um curso de informatica para internet, e neste curso as explicações são muito vagas, metade temos que descobrir sozinhos, ate então estava tudo bem ate aparecer essa questão: O meu problema é nesta questão, meu professor ja me deu uma breve explicada de como faz, so que com essa explicação dele continuou muito complicado, eu tenho que fazer um algoritmo que identifique o numero de entrada que sera o numero de linhas, e de uma piramide com o numero de linhas, meu professor deu ate a estrutura do algoritmo que é a seguinte: Eu sei que tem que continuar os paras, mais ja tentei de varias formas e não consegui, eu so consigo fazer a pirâmide crescente e a decrescente separadas, mais não consigo fazer uma so piramide que seja metade crescente e outra metade decrescente. Alguém pode me ajudar? ja quebrei muito minha cabeça e n consegui.
  13. Ola pessoal preciso muito de ajuda estou fazendo atividades de faculdade de engenharia e deram essas atividade de algoritmos com esse programa estava indo bem ate chegar nessas matrizes e embaralhar a cabeça. segue a pergunta e o algoritmo que comecei a executar se possivel ver se corresponde a pergunta agradeço. Faça um algoritmo para ler uma matriz 5x5 de números inteiros e ler um número inteiro x. A seguir, o algoritmo deve multiplicar os elementos da segunda coluna da matriz por x e exibir a matriz modificada algoritmo "Exercicio 1" // Autor: Luciano Tadeu Grecco // Data : 17/11/2017 var vetA:vetor[1..5,1..5] de real vetB:vetor[1..5,1..5] de real i,j,x:inteiro inicio // Seção de Comandos para i de 1 ate 5 faca para j de 1 ate 5 faca escreva(“Digite os numeros: [“,i, ” + “, j, ” ] “) leia(vetA[i,j]) fimpara fimpara para i de 1 ate 5 faca para j de 1 ate 5 faca escreva(vetA[i,j]*x) fimpara escreval(“”) fimpara para i de 1 ate 5 faca para j de 1 ate 5 faca vetB[i,j]<- (vetA[i,j]^5) fimpara fimpara para i de 1 ate 5 faca para j de 1 ate 5 faca escreva(vetB[i,j]*x) fimpara escreval(“”) fimpara fimalgoritmo
  14. Algoritmo "centro automotivo" Var a,b,opcao,op:inteiro c,d, soma: inteiro desconto: inteiro //--------------------------------------------------------------------- procedimento menu_principal Inicio //menu principal limpatela escreval ("centro automotivo") escreval("Selecione uma opção") escreval ("1 - Motor") escreva("=> ") Fimprocedimento //--------------------------------------------------------------------- //funcao da opcao 1 procedimento menu_motor inicio limpatela escreval ("Opcao Motor") escreval ("1- Alto consumo de óleo lubrificante") escreval ("2- Excesso de fumaça sendo expelida pelo escapamento") escreval ("3- Baixa potencia") escreval ("4- voltar") escreval ("selecione uma opção") escreva("=> ") fimprocedimento //--------------------------------------------------------------------- //--------------------------------------------------------------------- procedimento alto_consumo inicio escreval("esta aqui no alto consumo") escreval ("valor por horas/atividades é de R$ 100,00 , por hora") escreval ("digite o valor da atividade:") leia (c) escreval ("Em quantas horas vai resolver o problema: ") leia (d) escreval ("o problema vai ser resolvido por R$",c*d) leia (desconto) se desconto >= 1000 então escreval("voce recebeu desconto de 10%") escreval("o valor final da mão de obra :", ) fimse se( desconto > 200) e (desconto < 1000) então escreval("voce recebeu desconto de 5%") escreval("o valor final da mão de obra :", ) fimse escreval(" Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento excesso_de_fumaca inicio escreval("esta aqui no excesso de fumaça") escreval ("valor por horas/atividades é de R$ 100,00 , por hora") escreval(" Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento baixa_potencia inicio escreval("esta aqui no baixa potencia") escreval ("valor por horas/atividades é de R$ 100,00 , por hora") escreval(" Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- Inicio repita menu_principal leia(Opcao) limpatela escolha opcao caso 1 repita menu_motor leia(op) escolha op caso 1 alto_consumo caso 2 excesso_de_fumaca caso 3 baixa_potencia caso 4 escreval("voltando . . . Tecle Enter") leia(a) fimescolha ate op=4 ate opcao=4 Fimalgoritmo não sei como fazer com que o programa faça desconto se ele passar de 200 e for menor qur 1000 será de 5% e se for acima de 1000 10% help
  15. Algoritmo "centro automotivo" Var a,b,opcao,op:inteiro //--------------------------------------------------------------------- procedimento menu_principal Inicio //menu principal limpatela escreval ("centro automotivo") escreval("Selecione uma opção") escreval ("1 - Motor") escreval ("2 - Suspenção") escreval ("3 - Freio") escreval ("4 - sair") escreva("=> ") Fimprocedimento //--------------------------------------------------------------------- //funcao da opcao 1 procedimento menu_motor inicio limpatela escreval ("Opcao Motor") escreval ("1- Alto consumo de óleo lubrificante") escreval ("2- Excesso de fumaça sendo expelida pelo escapamento") escreval ("3- Baixa potencia") escreval ("4- voltar") escreval ("selecione uma opção") escreva("=> ") fimprocedimento //--------------------------------------------------------------------- //funcao opcao 2 procedimento menu_suspencao inicio limpatela escreval ("Opcao Suspenção") escreval ("1- Ruidos e batidas nas rodas") escreval ("2- Vibrações e direção puxando") escreval ("3- Desgaste irregular dos pneus") escreval ("4- voltar") escreval ("selecione uma opção") escreva("=> ") fimprocedimento //--------------------------------------------------------------------- // funcao opcao 3 procedimento menu_freio inicio limpatela escreval ("Opcao Freio") escreval ("1- O carro ou pedal vibra ao pisar no pedal do freio") escreval ("2- O carro puxa para algum lado quando freia") escreval ("3- Chiado ou ronco quando pisa no freio") escreval ("4- voltar") escreval ("selecione uma opção") escreva("=> ") fimprocedimento //--------------------------------------------------------------------- procedimento alto_consumo inicio escreval("esta aqui no alto consumo") escreval ("valor por horas/atividades é de R$ 100,00 , por hora") escreval(" Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento excesso_de_fumaca inicio escreval("esta aqui no excesso de fumaça") escreval ("valor por horas/atividades é de R$ 100,00 , por hora") escreval(" Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento baixa_potencia inicio escreval("esta aqui no baixa potencia") escreval ("valor por horas/atividades é de R$ 100,00 , por hora") escreval(" Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento Ruidos_e_batidas_nas_rodas inicio escreval("está aqui no procedimento ruido e batidas nas rodas") escreval ("valor por horas/atividades é de R$ 200,00 , por hora") escreval(" Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento Vibracoes_e_direcao_puxando inicio escreval("eata aqui no procedimento vibrações e direção puxando") escreval ("valor por horas/atividades é de R$ 200,00 , por hora") escreval(" Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento desgaste_irregular_dos_peneus inicio escreval("esta aqui no prcedimento desgaste irregular dos peneus") escreval ("valor por horas/atividades é de R$ 200,00 , por hora") escreval(" Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento carro_ou_pedal_vibra_ao_pisar inicio escreval("esta aqui no procedimento carro ou pedal vibra ao pisar no freio") escreval ("valor por horas/atividades é de R$ 300,00 , por hora") escreval(" Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento carro_puxa_para_algum_lado inicio escreval("esta aqui no procedimento carro puxa para algum lado") escreval ("valor por horas/atividades é de R$ 300,00 , por hora") escreval(" Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento Chiado_ou_ronco_quando_pisa inicio escreval("esta aqui no procedimento chiado ou ronco quando pisa") escreval ("valor por horas/atividades é de R$ 300,00 , por hora") escreval(" Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- Inicio repita menu_principal leia(Opcao) limpatela escolha opcao caso 1 repita menu_motor leia(op) escolha op caso 1 alto_consumo caso 2 excesso_de_fumaca caso 3 baixa_potencia caso 4 escreval("voltando . . . Tecle Enter") leia(a) fimescolha ate op=4 caso 2 repita menu_suspencao leia(op) escolha op caso 1 Ruidos_e_batidas_nas_rodas caso 2 Vibracoes_e_direcao_puxando caso 3 desgaste_irregular_dos_peneus caso 4 escreval("voltando . . . Tecle Enter") leia(a) fimescolha ate op=4 caso 3 repita menu_freio leia(op) escolha op caso 1 carro_ou_pedal_vibra_ao_pisar caso 2 carro_puxa_para_algum_lado caso 3 Chiado_ou_ronco_quando_pisa caso 4 escreval("voltando . . . Tecle Enter") leia(a) fimescolha ate op=4 caso 4 escreval("você pediu para sair, saindo . . . !") fimescolha ate opcao=4 Fimalgoritmo como criar um calculo que seja de valor de mao de obra mais a soma de horas trabalhadas se a hora é 100 reais e eu trabalho 3 horas = 300 e com isso o desconto se for acima de 200 e abaixo de 1000 seja 5% de desconto se for acima de 1000 tenha 10% de desconto help
  16. Pessoal olá. To tentando fazer um algoritmo no VisualG 3 para armazenar dados dos motoristas e depois apresentar as porcentagens de mulheres, de maiores de 25 anos, etc. O algoritmo que fiz está rodando normalmente só que eu preciso que quando o usuário colocar o ano de nascimento do motorista igual a zero o algoritmo se encerre e apresente os dados até ali coletados. O enunciado da questão é esse : O Departamento de Trânsito de Itajubá compilou dados de acidentes de trânsito na cidade no último ano. Para cada motorista envolvido num acidente, os seguintes dados foram registrados: ano de nascimento do motorista, sexo ('M' ou 'F'), código de registro (1 para Itajubá e 0 para outras Cidades). Escrever um algoritmo para ler este conjunto de dados para vários motoristas (mínimo 10) e depois imprimir as seguintes estatísticas: a) Percentagem de motoristas com menos de 25 anos b)Percentagem de mulheres c) Percentagem de motoristas maiores de 18 anos, mas menores de 25 anos d) Percentagem de motoristas com registro feito fora de Itajubá. OBS: Um ano de nascimento igual a 0 indica o fim dos dados para o algoritmo. utilize Vetor de Registros (Use VISAULG 3) ** eu coloquei numero de motoristas = 3 apenas pra ficar mais fácil de testar. Algoritmo "Dep. de Transito" tipo transito = registro nascimento: inteiro sexo: caractere codigo: inteiro fimregistro Var motorista : vetor [1..3] de transito Faixa1,Faixa2,Mulher,Homem,Itajuba, Outra, Totalcodigo: Inteiro Pum, Pdois, Ptres, Pquatro, Pcinco, Pseis : real x,i : inteiro Inicio Escreval("DEPARTAMENTO DE TRÂNSITO DE ITAJUBÁ-MG") Escreval ("Cadastro dos Motoristas") para x de 1 ate 3 faca Repita escreva("Ano de nascimento: ") leia(motorista[x].nascimento) ate (motorista[x].nascimento = 0) ou (motorista[x].nascimento <=1999) Repita escreva("Sexo (M p/ Homem e F p/ Mulher): ") leia(motorista[x].sexo) ate (motorista[x].sexo = "M") ou (motorista[x].sexo = "F") Repita escreva("Código da cidade (0 ou 1): ") leia(motorista[x].codigo) ate (motorista[x].codigo = 1) ou (motorista[x].codigo = 0) escreval(" ") fimpara // Verificando as faixas de idades Para x de 1 ate 3 Faca Se motorista[x].nascimento <= 1995 então Faixa1 <- Faixa1 + 1 Fimse Se (motorista[x].nascimento > 1995) e (motorista[x].nascimento <= 1999) então Faixa2 <- Faixa2 + 1 Fimse Se motorista[x].sexo = "F" então Mulher <- Mulher + 1 Fimse Se motorista[x].sexo = "M" então Homem <- Homem + 1 Fimse Se motorista[x].codigo = 1 então Itajuba <- Itajuba + 1 Fimse Se motorista[x].codigo = 0 então Outra <- Outra + 1 Fimse Totalcodigo <- Itajuba + Outra Pum <- (Faixa1*100)/Totalcodigo Pdois <- (Faixa2*100)/Totalcodigo Ptres <- (Mulher*100)/Totalcodigo Pquatro <- (Homem*100)/Totalcodigo Pcinco <- (Itajuba*100)/Totalcodigo Pseis <- (Outra*100)/Totalcodigo Fimpara // MOSTRA NA TELA LIMPATELA Escreval("Motoristas maiores de 25 anos: ", Pum:5:2, " %") Escreval("Motoristas entre 18 e 25 anos: ", Pdois:5:2, " %") Escreval("Motoristas Mulheres: ", Ptres:5:2, " %") //Escreval("Motoristas Homens: ", Pquatro:5:2, " %") //Se caso necessitasse da porcentagem de homens. //Escreval("Motoristas de Itajuba: ", Pcinco:5:2, " %") //Se caso necessitasse da porcentagem de itajuba. Escreval("Motoristas com registro fora de Itajubá: ", Pseis:5:2, " %") Fimalgoritmo
  17. 1)(Sabe-se que o quilowatt de energia custa 0,05% do valor do salário mínimo (R$ 1000) e o consumo (kW) dessa residência ao longo do ano foi: Janeiro 150 Fevereiro 52 Março 45 Abril 28 Maio 65 Junho 87 Julho 12 Agosto 100 Setembro 120 Outubro 45 Novembro 67 Dezembro 230 Sabe-se, que se o valor consumido for maior que 60 kW, deve ser aplicada uma taxa extra (bandeira amarela) igual a 2% do valor da conta, e se for maior que 100 kW, deve ser aplicada mais uma taxa (bandeira vermelha) igual a 5% do valor da conta (antes da bandeira amarela). Essas taxas devem ser somadas ao valor total da conta. Faça um programa que calcule e mostre a. o valor a ser pago por essa residência a cada mês; b. Se no mês de dezembro o consumo médio foi menor que 85 quilowatts, então deve ser dado um desconto de natal de 50% nesse mês; 2) Faça um algoritmo que utilize variáveis em formas de matrizes e vetores, que receba as notas de VÁRIOS alunos , calcule a média e a média na final (se necessário) para cada aluno e armazene esses valores em uma matriz. A única informação que deve ser visualizada é o nome do aluno, sua média (ou média final) e se ele está aprovado ou reprovado.
  18. Oi, se alguém puder me ajudar, estou fazendo um algoritmo para cadastro em Visualg, meu algoritmo funciona bem, porém estou tentando incrementar ele com vetores para permitir mais de 1 cadastro.. Só não entendi o que estou fazendo de errado, na area das variaveis declaradas aparece até certo o cliente[rg] para cada espaço em memória, mas o mesmo nao esta acontecendo com as outras variaveis. Algoritmo "semnome" tipo cadastro_cliente=registro nome: caractere rg: caractere cpf: caractere cendereco: caractere data_nascimento: caractere carteira_hab: caractere fimregistro Var // Seção de Declarações das variáveis clientes: vetor [1..10] de cadastro_cliente codigoC, menu: inteiro nome, rg, cpf, cendereco, data_nascimento, carteira_hab, x: caractere inicio codigoC <- 1 repita escreval ("1. Cadastrar Cliente") leia (menu) escreval ("") escolha menu caso 1 se (codigoC <= 10) então repita escreval ("Digite o nome: ") leia (clientes[codigoC].nome) escreval ("Digite o RG: ") leia (clientes[codigoC].rg) escreval ("Digite o CPF: ") leia (clientes[codigoC].cpf) escreval ("Digite o endereço: ") leia (clientes[codigoC].cendereco) escreval ("Digite a data de nascimento: ") leia (clientes[codigoC].data_nascimento) escreval ("Digite a carteira de habilitação: ") leia (clientes[codigoC].carteira_hab) escreval ("") se (codigoC < 1 ) então codigoC <- codigoC + 1 escreval ("Gostaria de cadastrar outro cliente? (S/N)") leia (x) escreval ("") senao codigoC <- codigoC + 1 x <- "N" fimse ate (x = "N") senao escreval ("Operação inválida: não é possível exceder o limite de 10 clientes cadastrados :)") escreval ("") fimse caso 2 ..........
  19. Olá pessoal, venho estudando lógica de programação mas gostaria que me indicassem alguns porque algumas dúvidas vem surgindo. Abraços
  20. Olá, estou fazendo um curso de informática e neste curso foi proposta uma atividade de desenvolver um algoritmo para dar bônus a 4 funcionários dependendo dos dependentes desse funcionário, enfim, fiz o programa e ele funcionou o problema é que o cônjuge pode ser um dependente então eu fiz uma condição para que se o funcionário fosse solteiro ele não pudesse receber o bônus do cônjuge, mas sempre que o funcionário é solteiro a idade dos dependentes é lida duas vezes, não altera o fluxo do programa simplesmente muda o valor da variável, mas considero isso um erro e li e re-li o algoritmo e não consegui resolver isso. Parte do algoritmo que contém o erro: enquanto (quant_dependentes>contador) faca repita escreva ("Tipo do Dependente (C= Cônjuge | X= Outros): ") leia (tipo_dependente) ate (tipo_dependente="C") ou (tipo_dependente="X") se (tipo_dependente="C") e (estado_civil="C") então enquanto (contador_conjuge<1) faca escreva ("Idade do Cônjuge: ") leia (idade_conjuge) bonus_funcionario1 := bonus_funcionario1 + 20 contador_conjuge := contador_conjuge + 1 contador := contador + 1 fimenquanto senao repita escreva ("Idade do Dependente: ") leia (idade_dependente) ate (idade_dependente>0) contador := contador + 1 se (idade_dependente<=17) então bonus_funcionario1 := bonus_funcionario1 + 15 fimse fimse fimenquanto Algoritmo inteiro: algoritmo "Bônus Funcionário" // Função : Dar bônus aos funcionários // Autor : João Vitor de A. Vinezof // Data : 10/11/2017 // Seção de Declarações var funcionario1, funcionario2, funcionario3, funcionario4: literal idade_conjuge, dependente, tipo_dependente, idade_dependente, estado_civil: literal bonus_funcionario1, bonus_funcionario2, bonus_funcionario3, bonus_funcionario4: inteiro contador, contador_conjuge, quant_dependentes: inteiro inicio // Seção de Comandos //Definindo os valores dos acumuladores e contadores bonus_funcionario1 := 40 bonus_funcionario2 := 40 bonus_funcionario3 := 40 bonus_funcionario4 := 40 contador := 0 contador_conjuge := 0 //Funcionário 01 escreval ("Dados do funcionário 1:") escreva ("Nome: ") leia (funcionario1) repita escreva ("Estado Civil (C= Casado | S= Solteiro): ") leia (estado_civil) ate (estado_civil="C") ou (estado_civil="S") repita escreva ("Possuí Dependentes? (N= Não | S= Sim): ") leia (dependente) ate (dependente="N") ou (dependente="S") se (dependente="S") então repita escreva ("Quantos? ") leia (quant_dependentes) ate (quant_dependentes>0) fimse enquanto (quant_dependentes>contador) faca repita escreva ("Tipo do Dependente (C= Cônjuge | X= Outros): ") leia (tipo_dependente) ate (tipo_dependente="C") ou (tipo_dependente="X") se (tipo_dependente="C") e (estado_civil="C") então enquanto (contador_conjuge<1) faca escreva ("Idade do Cônjuge: ") leia (idade_conjuge) bonus_funcionario1 := bonus_funcionario1 + 20 contador_conjuge := contador_conjuge + 1 contador := contador + 1 fimenquanto senao repita escreva ("Idade do Dependente: ") leia (idade_dependente) ate (idade_dependente>0) contador := contador + 1 se (idade_dependente<=17) então bonus_funcionario1 := bonus_funcionario1 + 15 fimse fimse fimenquanto escreval contador := 0 contador_conjuge := 0 quant_dependentes := 0 //Funcionário 02 escreval ("Dados do Funcionário 2:") escreva ("Nome: ") leia (funcionario2) repita escreva ("Estado Civil (C= Casado | S= Solteiro): ") leia (estado_civil) ate (estado_civil="C") ou (estado_civil="S") repita escreva ("Possuí Dependentes? (N= Não | S= Sim): ") leia (dependente) ate (dependente="N") ou (dependente="S") se (dependente="S") então repita escreval ("Quantos? ") leia (quant_dependentes) ate (quant_dependentes>0) fimse enquanto (quant_dependentes>contador) faca repita escreva ("Tipo do dependente (C= Cônjuge | X= Outros): ") leia (tipo_dependente) ate (tipo_dependente="C") ou (tipo_dependente="X") se (tipo_dependente="C") e (estado_civil="C") então enquanto (contador_conjuge<1) faca repita escreva ("Idade do Cônjuge: ") leia (idade_conjuge) ate (idade_conjuge>0) bonus_funcionario2 := bonus_funcionario + 20 contador_conjuge := contador_conjuge + 1 contador := contador + 1 fimenquanto senao repita escreva ("Idade do Dependente: ") leia (idade_dependente) ate (idade_dependente>0) contador := contador + 1 se (idade_dependente<=17) então bonus_funcionario2 := bonus_funcionario2 + 15 fimse fimse fimenquanto contador := 0 contador_conjuge := 0 quant_dependentes := 0 escreval //Funcionário 03 escreval ("Dados do Funcionário 3: ") escreva ("Nome: ") leia (funcionario3) repita escreva ("Estado Civil (C= Cônjuge | S= Solteiro): ") leia (estado_civil) ate (estado_civil="C") ou (estado_civil="S") repita escreva ("Possuí Dependentes? (N= Não | S= Sim): ") leia (dependente) ate (dependente="N") ou (dependente="S") se (dependente="S") então repita escreva ("Quantos? ") leia (quant_dependentes) ate (quant_dependentes>0) fimse enquanto (quant_dependentes>contador) faca repita escreva ("Tipo do Dependente (C= Cônjuge | X= Outros): ") leia (tipo_dependente) ate (tipo_dependente="C") ou (tipo_dependente="X") se (tipo_dependente="C") e (estado_civil="C") então enquanto (contador_conjuge<1) faca repita escreva ("Idade do Cônjuge: ") leia (idade_conjuge) ate (idade_conjuge>0) bonus_funcionario3 := bonus_funcionario3 + 20 contador_conjuge := contador_conjuge + 1 contador := contador + 1 fimenquanto senao repita escreva ("Idade do Dependente: ") leia (idade_dependente) ate (idade_dependente>0) contador := contador + 1 se (idade_dependente<=17) então bonus_funcionario3 := bonus_funcionario3 + 15 fimse fimse fimenquanto contador := 0 contador_conjuge := 0 quant_dependentes := 0 escreval //Funcionário 04 escreval ("Dados do Funcionário 4:") escreva ("Nome: ") leia (funcionario4) repita escreva ("Estado Civil (C= Casado | S= Solteiro): ") leia (estado_civil) ate (estado_civil="C") ou (estado_civil="S") repita escreva ("Possuí Dependentes? (N= Não | S= Sim): ") leia (dependente) ate (dependente="N") ou (dependente="S") se (dependente="S") então repita escreva ("Quantos? ") leia (quant_dependentes) ate (quant_dependentes>0) fimse enquanto (quant_dependentes>contador) faca repita escreva ("Tipo do Dependente (C= Cônjuge | X= Outros): ") leia (tipo_dependente) ate (tipo_dependente="C") ou (tipo_dependente="X") se (tipo_dependente="C") e (estado_civil="C") então enquanto (contador_conjuge<1) faca repita escreva ("Idade do Cônjuge: ") leia (idade_conjuge) ate (idade_conjuge>0) bonus_funcionario4 := bonus_funcionario4 + 20 contador_conjuge := contador_conjuge + 1 contador := contador + 1 fimenquanto senao repita escreva ("Idade do Dependente: ") leia (idade_dependente) ate (idade_dependente>0) contador := contador + 1 se (idade_dependente<=17) então bonus_funcionario4 := bonus_funcionario4 + 15 fimse fimse fimenquanto limpatela escreval (funcionario1,": Benefício de R$",bonus_funcionario1) escreval (funcionario2,": Benefício de: R$",bonus_funcionario2) escreval (funcionario3,": Benefício de: R$",bonus_funcionario3) escreval (funcionario4,": Benefício de: R$",bonus_funcionario4) fimalgoritmo Desde já, Obrigado.
  21. Olá! Estou fazendo um trabalho para o meu curso, onde tenho que indicar o número de alunos de uma sala, a cidade, nome , idade e as notas com a sua média, estou conseguindo fazer, mas me atrapalho na hora de calcular a média, se alguém puder me ajuda agradeço desde já! Segue meu algoritmo: algoritmo "semnome" // Função : Calcular a méida de um número determinado de alunos. // Autor : Patrick Renan Weber // Data : 08/11/2017 var numeroalunos: inteiro idade: inteiro cidade: caractere nomes: vetor [1..100] de caractere notas: vetor [1..4] de real media: vetor [1..100] de real loopnomes: inteiro loopnotas: inteiro inicio para loopnomes de 1 ate numeroalunos faca escreva("Digite o nome do aluno(a) de número ", loopnomes, " de ", numeroalunos, " : ") leia(nomes[loopnomes]) escreva("Qual a idade do aluno(a) ", (nomes[loopnomes]), " : ") leia(idade) escreva("Em qual cidade ",(nomes[loopnomes]), " mora? ") leia(cidade) PARA loopnotas de 1 ate 4 FACA escreva("Digite a nota ",Loopnotas," do aluno(a) ", nomes[loopnomes], ": ") leia(notas[loopnotas]) FIMPARA media[loopnomes]:=(notas[loopnotas,1] + notas[loopnotas,3] + notas[loopnotas,3] + notas[loopnotas,4])/4 se media>= 6 então escreva ("O aluno foi aprovado com a média ", media, " parabéns!") senao escreva ("O aluno foi reprovado com a média ", media, " não foi desta vez") fimse limpatela fimpara fimalgoritmo
  22. Boa tarde estou tentando fazer um registro no Visualg mas não estou obtendo respostas do programa, quero saber o que estou fazendo de errado. Obrigado desde já. Algoritmo "a" TIPO // Seção de Declarações de Tipos Reg_Endereco = registro Rua, Cidade, UF: caractere No, CEP: inteiro fimregistro Registro_Pagamento = registro NOME, RG: caractere CPF: caractere //HT: vetor[0..5] de inteiro HT1, HT2, HT3, HT4, HT5, HT6 : real SALARIO: real //ENDERECO: Reg_Endereco Rua, Cidade, UF: caractere No, CEP: inteiro fimregistro VAR i: inteiro fun1, fun2: Registro_Pagamento HT: vetor [0..5] de real INICIO Escreva("Entre o NOME do empregado (ate 30 caracteres):") Leia(fun1.NOME) Escreva("Entre com o CPF do empregado (11 dígitos): ") Leia(fun1.CPF) Escreva("Entre com o RG do empregado (ate 10 caracteres): ") Leia(fun1.RG) Para i de 0 ate 5 passo 1 faca Escreva("Entre as horas trabalhadas na semana dia[",i,"]":) Leia(HT[ i ]) fimpara fun1.HT1 <- HT[ 0 ] fun1.HT2 <- HT[ 1 ] fun1.HT3 <- HT[ 2 ] fun1.HT4 <- HT[ 3 ] fun1.HT5 <- HT[ 4 ] fun1.HT6 <- HT[ 5 ] Escreva("Entre o salario: ") Leia(fun1.SALARIO) Escreva("Entre com a rua (20 caracteres): ") Leia( fun1.Rua) Escreva("Entre com a cidade (15 caracteres): ") Leia( fun1.Cidade) Escreva("Entre com o UF (2 caracteres): ") Leia( fun1.UF) Escreva("Entre com o numero: ") Leia(fun1.No) Escreva("Entre com o CEP: ") Leia(fun1.CEP) fun2 <- fun1 Limpatela Escreval ("Nome: ":15, fun2.NOME) Escreval ("Cpf: ":15, fun2.CPF) Escreval ("Rg:":15, fun2.RG) Escreval("HT[1]: ":15, fun2.HT1) Escreval("HT[2]: ":15, fun2.HT2) Escreval("HT[3]: ":15, fun2.HT3) Escreval("HT[4]: ":15, fun2.HT4) Escreval("HT[5]: ":15, fun2.HT5) Escreval("Salario Hora = ":15, fun2.SALARIO) Escreva ("Rua: ":15, fun2.Rua) Escreva ("No: ":15, fun2.No) Escreva ("CEP: ":15, fun2.CEP) Escreva ("Cidade: ":15, fun2.Cidade) Escreva ("UF: ":15, fun2.UF) Fimalgoritmo
  23. Algoritmo "centro automotivo" Var // Seção de Declarações das variáveis opcao: inteiro procedimento menu_principal Inicio //menu principal escreval ("centro automotivo") escreval("Selecione uma opção") escreval ("1 - Motor") escreval ("2 - Suspenção") escreval ("3 - Freio") escreval ("sair") Fimprocedimento //funcao da opcao 1 procedimento menu_motor inicio escreval ("Opcao Motor") escreval ("1- Alto consumo de óleo lubrificante") escreval ("2- Excesso de fumaça sendo expelida pelo escapamento") escreval ("3- Baixa potencia") escreval ("4- voltar") escreval ("selecione uma opção") escreval ("valor por horas/atividades é de R$ 100,00 , por hora") fimprocedimento //funcao opcao 2 procedimento menu_suspencao inicio escreval ("Opcao Suspenção") escreval ("1- Ruidos e batidas nas rodas") escreval ("2- Vibrações e direção puxando") escreval ("3- Desgaste irregular dos pneus") escreval ("4- voltar") escreval ("selecione uma opção") escreval ("valor por horas/atividades é de R$ 200,00 , por hora") fimprocedimento // funcao opcao 3 procedimento menu_freio inicio escreval ("Opcao Suspenção") escreval ("1- O carro ou pedal vibra ao pisar no pedal do freio") escreval ("2- O carro puxa para algum lado quando freia") escreval ("3- Chiado ou ronco quando pisa no freio") escreval ("4- voltar") escreval ("selecione uma opção") escreval ("valor por horas/atividades é de R$ 300,00 , por hora") fimprocedimento inicio // seleção de comandos repita menu_principal escreva("=>") leia (Opcao) limpatela escolha (opcao) caso 1 //motor menu_motor escreva("=>") leia(opcao) limpatela caso 2 //suspenção menu_suspencao escreva("=>") leia (opcao) limpatela caso 3 // freio menu_freio escreva("=>") leia (opcao) limpatela caso 4 //sair fimescolha ate opcao = 0 fimalgoritmo
  24. Urgente!! Preciso de ajuda com 3 exercícios. 1) Escreva um programa que lê um valor inteiro (maior do que 1 e menor ou igual a 10) e exibe a tabuada (até 10) de multiplicação do número lido. Funcao LeNumero(n1, n2:inteiro):inteiro; Lê um número inteiro no intervalo especificado (n1, n2) e o devolve. Cada vez que for digitado um número inválido (fora do intervalo especificado) a função deve exibir a mensagem "Número inválido. Digite novamente!" Procedimento Tabuada( n :inteiro); Recebe como parâmetro um número inteiro e exibe na tela a tabuada de multiplicação de 10 do número lido. Exemplo: número lido 5 5 * 1 = 5 5 * 2 = 10 .... 5 * 10 = 50 2)Escreva um programa composto de uma função MAX e o programa principal como segue: a) A função MAX recebe como parâmetros de entrada dois números inteiros e retorna o maior. Se forem iguais retorna qualquer um deles; -b) O programa principal lê 4 séries de 4 números a,b,c e d. Para cada série lida imprime o maior dos quatro números usando a função MAX. 3)Faça um programa que leia um número inteiro e gere todos os números primos entre 1 e este número fornecido, exibindo-os na tela. O programa deve ter uma sub-rotina (procedimento ou função) que determina se um determinado número é ou não primo. Números primos são aqueles que são somente divisíveis por 1 ou por eles mesmos. Agradeço!
  25. Escreva um algoritmo que receba números inteiros positivos (UTILIZE O ENQUANTO OU O REPITA). Determine o menor e o maior número através de procedimentos (Crie um procedimento para cada um). Calcule a soma e média dos números utilizando funções (Crie uma função para cada). O programa somente será finalizado quando o usuário digitar um número negativo (não deve ser considerado nas comparações). Meu programa : var a,b : Inteiro n:inteiro funcao mediadenumeros (num :inteiro): real retorne ( inicio fimfuncao procedimento maior (x,y:inteiro) inicio enquanto (n>=0) faca maior <- x menor <- y se (x > y) então escreval ("Este número" x, "e maior que", y) senao se (y > x ) então escreval ("Este número" y, "e maior que", x) senão escreval ("São Iguais!") fimse fimse fimprocedimento inicio Escreva ("Número digitado de X : ") leia (a) Escreva ("Número dititado de Y : ") leia (b) maior (a,b) fimalgoritmo Estou com muitas dificuldades para elaborar esse exercício.

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×