Ir ao conteúdo
  • Cadastre-se

Procv para mais de uma coluna


henbononi

Posts recomendados

Olá a todos.

Venho aqui trazer uma dúvida que pelo que li não tem como ser resolvida, mas acho que nada é impossível até o pessoal do clubedohardware falar que é. :D

Segue em anexo uma imagem de uma tabela no excel, onde eu queria utilizar o PROCV. Nela na coluna G tem a fórmula, mas o valor procurado não estará apenas em uma coluna, mas estará em apenas uma das outras (A, B, C, D, E ou F). Não aparecerá na A e na C, por exemplo. APENAS EM UMA DELAS.

Tentei colocar no valor procurado =ou(A7;B7;C7;D7;E7;F7) mas não deu.

Alguém sabe se isso tem como acontecer???

Abs a todos !!!

post-945124-13884964826618_thumb.jpg

Link para o comentário
Compartilhar em outros sites

Bom Dia!

Veja se entendi direito e me tire umas duvidas....

Na imagem tem o PROCV como ex: =PROCV(A7;Plan2!A2:B475;2;FALSO)

vamos as perguntas...

mas o valor procurado não estará apenas em uma coluna

no caso aqui o que vai variar é o A7 q poderia ser B7 C7 D7... sempre na mesma linha, certo?

e outra coisa, no ex: a linha que tem o valor procurado, so tem ele, na mesma

lnha nas outras colunas nao tem nada, é assim, ou tem outros valores????

porque se na linha inteira existir so o valor procurado as outras for em branco como na imagem,

você pode usar esta formula!

=PROCV(MAIOR(A7:F7;1);Plan2!A2:B475;2;FALSO)

aguardando:rolleyes:

Link para o comentário
Compartilhar em outros sites

Contribuindo...

Caso haja valores nas demais células, a fórmula abaixo verifica de A a F qual código traz resposta; se nenhum, fica em branco.

=SEERRO(PROCV(A7;Plan2!$A$2:$B$475;2;0);SEERRO(PROCV(B7;Plan2!$A$2:$B$475;2;0);SEERRO(PROCV(C7;Plan2!$A$2:$B$475;2;0);SEERRO(PROCV(D7;Plan2!$A$2:$B$475;2;0);SEERRO(PROCV(E7;Plan2!$A$2:$B$475;2;0);SEERRO(PROCV(F7;Plan2!$A$2:$B$475;2;0);""))))))

Link para o comentário
Compartilhar em outros sites

Arquivado

Este tópico foi arquivado e está fechado para novas respostas.

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

APRENDA A MONTAR COMPUTADORES!

montagem2022-capa-peq.jpg

 

CLIQUE AQUI E BAIXE AGORA MESMO!