Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Entre para seguir isso  
Kelvim

[Resolvido] Formula se

Recommended Posts

Boa noite

Estou com um problema. Gastaria de saber se tem como usar a formula para responder a seguinte questão.

A B

1

2 18,5 19,5

3 X

Eu quero que a Formula Se selecione o valor se responder a questão.

Se a célula A3 for >=A2 ou <= B2 a formula retornara o valor que estiver na célula A3 caso não a mesma retornara a resposta erro.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Oi, Kelvim,

Você pode aplicar a seguinte fórmula para resolver o problema:

=SE(OU(A3>=A2;A3<=B2);A3;"Erro")

No entanto, acredito que existe um problema de lógica na sua questão. Você quer que a fórmula retorne o valor contido em A3 apenas se a A3 >= A2 OU A3 <= B2. Como a condição definida é "maior ou igual a um número" OU "menor ou igual a outro número", qualquer valor que você colocar em A3, independentemente dos valores contidos em A2 e B2, sempre será verdadeira, ou seja, nunca dará a resposta "Erro", conforme você espera.

Se o que você necessita é que a fórmula retorne o valor contido em A3 apenas nos casos em que o valor de A3 esteja entre A2 e B2, você precisará da seguinte fórmula:

=SE(E(A3>=A2;A3<=B2);A3;"Erro")

Abaixo, exemplo para clarificar o problema de lógica.

Dado o seguinte intervalo, suponha-se que queira saber se um número X pertence ao intervalo.

8 9 10 11 12 13 14

X = 15

Com o OU, será verificado: 15 é maior ou igual a 8? Sim. 15 é menor ou igual a 14? Não. Como a condição é um OU o outro, ou seja, apenas uma resposta deve ser positiva, a resposta será verdadeira.

Com o E, será verificado: 15 é maior ou igual a 8? Sim. 15 é menor ou igual a 14? Não. Como a condição é um E o outro, ou seja, as duas respostas devem ser positivas, a resposta será falsa.

Editado por vinibpeixoto
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom dia

Adorei a explicação acredito que a segunda condição de SE sera a que eu preciso.

Muito obrigado.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caso o autor do tópico necessite, o mesmo será reaberto, para isso deverá entrar em contato com a moderação solicitando o desbloqueio.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
Visitante
Este tópico está impedido de receber novos posts.
Entre para seguir isso  





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×