Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Entre para seguir isso  
kushiaka

[Resolvido] Ligar dois leds diferentes em um I/O do pic

Recommended Posts

Ola pessoal.

estou fazendo um projeto com o PIC 16f84a e gostaria de uma ajuda para ligar 2 LED's em uma unica saída. quando a saída foi 1 liga um LED verde e quando a saída for 0 liga um LED vermelho.

desde já agradeço.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Apenas coloque os leds invertidos um em relação ao outro.

Falou

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • mas preciso usar o mesmo terra para os 2.

    um rele serviria para mim, mas não queria coloca-lo pois acho muito feio uma placa cheia de reles. ligaria a saída do PIC para acionar o rele, +5v (com resistor) no comum do rele e NF ligaria no vermelho e NA no verde. mas prefero fazer algum circuitinho para fazer essa transação

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • Assim ó:

    led_invertido.png~original

    Falou

    sim, eu entendi o que tinha dito. Obrigado.

    só que eu preciso usar um daqueles led bicolor de 3 contato (verde, GND, vermelho). e infelizmente nesse esquema n da para ligar.

    o ideal seri fazer um circuito como se fosse um rele. eu tentei fazer um usando transistores e lei de corrente junto a resistores, só que um dos leds não se apagava por total.

    eu precisava montar um circuito simulando um rele. só que com transitores.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Caro colega de pic não entendo nada mais aqui tem um circuíto para você tomar como base

    invertetra.jpg

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Colega Moyano, sua ideia é boa mas no caso dele não dá certo pois o LED é catodo comum. Ou seja, os ground são juntos.

    Falou

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    O circuito da esquerda do colega Moyano é uma boa.

    Meu pitaco:

    led_invertido_2.png~original

    Falou

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • muito obrigado a todos pela ajuda, pelos meus conhecimentos em eletronica ( que não são muitos) creio que esse do "MatheusLPS" possa melhor se encaixar. amanha pela manha vou comprar os componentes e testar. assim que fizer os testes eu posto o resultado.

    Mais uma vez muito obrigado a todos

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Se você tiver algum outro transistor NPN e um PNP por aí pode usar. Não precisa ser necessariamente o que eu usei não.

    No lugar dos resistores de 100 ohms, utilize resistores de uns 330 ohms.

    Falou

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • Muito Obrigado MatheusLPS

    funcionou direitinho, era isso mesmo que eu queria. só troquei o R4 por um de 560r, pois estava com interferencia (se bem que pode ser por causa da protoboard) e o led vermelho não apagava. eu usei os transistores BC 558 e 548.

    Muito obrigado a todos que responderam.

    att

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Caso o autor do tópico necessite, o mesmo será reaberto, para isso deverá entrar em contato com a moderação solicitando o desbloqueio.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
    Visitante
    Este tópico está impedido de receber novos posts.
    Entre para seguir isso  





    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×