Ir ao conteúdo
  • Cadastre-se
Visitante

Ajuda para Terminar o Oráculo da Família

Recommended Posts

Visitante

Olá, comecei a fazer um algorítimo ao estilo do Akinator http://pt.akinator.com/ e agora falta criar mais perguntas para finalizar. Gostaria da ajuda para terminar esse programa. Sugestões para melhorar também são bem-vindas. Segue o codigo que fiz no visualg:

algoritmo "oraculo"
// Função : Oráculo da Família
// Autor : Guilherme Ferreira
// Data : 18/08/2013
// Seção de Declarações
var
res,s,n,personagem,sexo,f,m,sangue,ss,sn:caracter
cat1f,cat1m,cat2f,cat2m,cat3f,cat3m:caracter
grupo:caracter

inicio

ss<- "Mesmo Sangue"
sn<- "Sangue diferente"
m<- "Maculino"
f<- "Feminino"

escreval("Sou o Oráculo e vou descobrir")
escreval("qual o familiar que você está pensando!")
escreval("clique em (ENTER) para jogar")
leia(res)
limpatela
escreval("Essa pessoa usa roupa feminina? (s) ou (n)")
leia(res)

escolha res
caso "s"
sexo <- f
caso "n"
sexo <- m
outrocaso
escreval("Apenas (s) ou (n)?")
leia(res)
escolha res
caso "s"
sexo <- f
caso "n"
sexo <- m
outrocaso
escreval("Resposta Inválida!")
fimescolha
fimescolha
limpatela
escreval("O seu personagem e você são filhos da mesma mãe? (s) ou (n)")
leia(res)

escolha res
caso "s"
sangue <- ss
caso "n"
sangue <- sn
outrocaso
escreval("Apenas (s) ou (n)?")
leia(res)
escolha res
caso "s"
sexo <- f
caso "n"
sexo <- m
outrocaso
escreval("Resposta Inválida!")
fimescolha
fimescolha

limpatela
se (sexo=m) e (sangue=ss) então
escreval("Essa pessoa tem mãos verdes?")
leia (res)
limpatela
escreval("Ela gosta de filmes de ficção?")
leia (res)
limpatela
escreval("Você pensou no seu irmão.")
fimse
se (sexo=f) e (sangue=ss) então
escreval("Essa pessoa tem mais de 99 anos?")
leia (res)
limpatela
escreval("Ela curte seus comentários no Facebook?")
leia (res)
limpatela
escreval("Você pensou na sua irmã.")
fimse

se (sexo=m) e (sangue=sn) então
escreval("O seu personagem é conhecido como (tio)? (s) ou (n)")
leia (res)

limpatela
se (res="s") então
escreval("Essa pessoa tem o habito de fumar?")
leia (res)
limpatela
escreval("Ela gosta de jogar bolita?")
leia (res)
limpatela
escreval ("Você pensou no seu tio.")
fimse
se(res="n")então
escreval("Essa pessoa é careca?")
leia (res)
limpatela
escreval("Ela gosta de filmes de terror?")
leia (res)
limpatela
escreval ("Você pensou no seu primo.")
fimse
fimse

se (sexo=f) e (sangue=sn) então
escreval("O seu personagem é conhecido como (tia)? (s) ou (n)")
leia (res)

limpatela
se (res="s") então
escreval ("Você pensou na sua tia.")
fimse
se(res="n")então
escreval ("Você pensou na sua prima.")
fimse
fimse


// Seção de Comandos
fimalgoritmo

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×