Ir ao conteúdo
  • Cadastre-se
Molly9494

Urgente sobre logica de programação

Recommended Posts

Não estou entendo o que fiz de errado nesse algoritimo

Faça um algoritmo que receba o salário de um funcionário chamado Carlos. Sabe-se que o funcionário João tem um salário equivalente a um terço do salário de Carlos. Carlos aplicará seu salário integralmente no caderno de poupança, que está rendendo 2% ao mês e João aplicará seu salário integralmente no fundo de renda fixa, que está rendendo 5% ao mês. Calcule e mostre a quantidade de meses necessários para que o valor pertencente a João iguale ou ultrapasse o valor pertencente a Carlos.

var
sal_carlos, sal_joao, meses, rend_carlos, rend_joao, cont : real
inicio
// Seção de Comandos
escreval("Informe o salário do Sr. Carlos:")
leia(sal_carlos)
sal_joao <- sal_carlos/3
rend_carlos <-sal_carlos/100*2
rend_joao <-sal_joao/100*5
meses <- 0
escreval("Salário de Jõao é",sal_joao)
enquanto rend_joao<rend_carlos faca
rend_carlos*meses
rend_joao*meses
meses<-meses+1
fimenquanto
se (rend_joao>rend_carlos) então
escreval("Para ultrapassar o valor pertencente à Jõao levou:",meses)
escreval("meses")
fimse
se (rend_joao=rend_carlos) então
escreval("Para igualar o valor pertencente à Carlos Jõao levou:",meses)
escreval("meses")
fimse

Compartilhar este post


Link para o post
Compartilhar em outros sites

Você tá comparando apenas o rendimento, mas eu interpretei de outra forma: será que não tem que comparar os salários + rendimentos para saber quando o valor pertencente a João iguale ou ultrapasse o valor pertencente a Carlos?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Amigo, identifiquei alguns erros que acho válido te passar.

Seu código está assim:

var
sal_carlos, sal_joao, meses, rend_carlos, rend_joao, cont : real
inicio
// Seção de Comandos
escreval("Informe o salário do Sr. Carlos:")
leia(sal_carlos)
sal_joao <- sal_carlos/3
rend_carlos <-sal_carlos/100*2
rend_joao <-sal_joao/100*5
meses <- 0
escreval("Salário de Jõao é",sal_joao)
enquanto rend_joao<rend_carlos faca
rend_carlos*meses
rend_joao*meses
meses<-meses+1
fimenquanto
se (rend_joao>rend_carlos) então
escreval("Para ultrapassar o valor pertencente à Jõao levou:",meses)
escreval("meses")
fimse
se (rend_joao=rend_carlos) então
escreval("Para igualar o valor pertencente à Carlos Jõao levou:",meses)
escreval("meses")
fimse

Primeiro erro: Você deve colocar parenteses quando for fazer a variável receber algum valor que têm algum cálculo, porque como o cálculo tem * e / ele se confunde em o que fazer primeiro, então coloque : rend_carlos <-sal_carlos/(100*0,02).

Segundo erro: não é 100*2, é 100*0,02 para representar porcentagens.

Terceiro erro: coloque fim no seu algoritmo (fimalgoritmo)

Falou... espero que tenha ajudado....

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×