Ir ao conteúdo
  • Cadastre-se
Entre para seguir isso  
ggdd

[Resolvido] Subtração 2 vetores

Recommended Posts

Boa noite galera! Quando faço deste modo, para cada vez que um vetor subtrair com outro vetor ele mostra o resultado como 0, tem outro jeito, que mostra o resultado no final, mas gostaria de estar vendo toda vez que digita-se um valor para um vetor e para o outro, subtrai-se na hora, e mostra-se o resultado! Alguém pode mostrar o erro? Aguardo, grato!

algoritmo "semnome"
// Função :
// Autor :
// Data : 02/11/2013
// Seção de Declarações
var
va: vetor [1..2] de inteiro
vb: vetor [1..2] de inteiro
vd1: vetor [1..2] de inteiro
i,result:inteiro
inicio
//vetore A
para i de 1 ate 2 passo 1 faca
vd1[i] <- va[i]-vb[i]
i <- 1
escreval ("digite o valor para o vetor A")
leia (va[i])
//vetor B
escreval ("digite o valor para o vetor B")
leia (vb[i])
escreval ("result",vd1[i])
fimpara
fimalgoritmo

Compartilhar este post


Link para o post
Compartilhar em outros sites

Você está subtraindo antes de preencher os dois vetores, mais outra coisa, você está atribuindo o valor um ao i, ''i <- 1'', logo toda vez que ele preencher o vetor vai colocar na posição 1(seu algoritmo faz isso o tempo todo), já que você subtraiu antes de começar a preencher, logo todos os valores serão zero.

''Trocando em miúdos'':O melhor seria preencha todos os vetores e depois fazer a subtração.

No aguardo.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caso o autor necessite, o mesmo será reaberto, para isso deverá entrar em contato com a moderação solicitando o desbloqueio.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Visitante
Este tópico está impedido de receber novos posts.
Entre para seguir isso  





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×