Ir ao conteúdo
  • Cadastre-se
Entre para seguir isso  
ggdd

[Resolvido] Vetores apresentar último valor ao primeiro

Recommended Posts

Aproveitando o mesmo, estou fazendo este exercício para apresentar o valor de um vetor x em y normal, como mostre abaixo; e mostre o ultimo valor do vetor x no y, ordem normal e decrescente, teria alguma dica para dar? Aguardo!

Código:
algoritmo "semnome"
// Função :
// Autor :
// Data : 02/11/2013
// Seção de Declarações
var
vx: vetor [1..2] de inteiro
vy: vetor [1..4] de inteiro
i: inteiro
inicio
// vetor X
para i de 1 ate 2 passo 1 faca
escreval ("digite o valor")
leia (vx[i])
fimpara

escreval

//vetor na ordem crescente no Vetor Y
para i de 1 ate 2 passo 1 faca
vy [i] <- vx[i]
escreval ("crescentes:",vy[i])
fimpara

escreval

//vetor na ordem decrescente no Vetor B
para i de 1 ate 2 passo 1 faca
vy[i+1] <- vx[i]
escreval ("decrescente:",vy[i],vx[i])
fimpara

Compartilhar este post


Link para o post
Compartilhar em outros sites

Tudo bem, vamos ver como posso lhe ajudar... :goff:

toda vez que você quiser mexer na organização(ordenação de vetores) de um vetor tem

que utilizar uma lógica ou uma função.

1º Antes de de tudo visualize, tente entender o problema a nível macro e micro.

2º Toda vez que você se deparar com um problema novo planeje(quando ele tiver fácil normalmente você terá ele em mente).

3º ''Ponha a mão na massa'', comece a escrever o código.

4º Faça o teste de mesa e compile.

Obs1: Por que você declarou o vetor com um nome e colocou para ler com um nome diferente?

Obs2: Existem algoritmos prontos para fazer tal coisa, mas se quiser pode tentar deduzir.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Ok Kurumim 7, irei estar verificando, pois como o exercício pede-se para por do último para o primeiro, ira variar no código! Obrigado!

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caso o autor necessite, o mesmo será reaberto, para isso deverá entrar em contato com a moderação solicitando o desbloqueio.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Visitante
Este tópico está impedido de receber novos posts.
Entre para seguir isso  





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×