Ir ao conteúdo
  • Cadastre-se
piterog

Configuração para 8051 para acionar Led

Recommended Posts

Pessoal!

Eu fiz esse esquema no proteus, mas quero conseguir na vida real.. de nada me adianta funcionar no proteus e não dar certinho na vida real!

Me expliquem uma coisa, porque da saida do ULN precisar da malha resistiva para funcionar?

Assim como está feito para o display de 7 segmentos está correto?

Mesmo pegando o o datasheet do ULN2003 (ainda sou marinheiro de primeira viagem) pelo o que eu entendi ele deixa a saida com 50v é isso?

a partir daí posso calcular resistores para que em cada segmento do display eu consiga os 20mA?

Os resistores de pull-up e pull-down são usados quando?

A saída do 8051 é coletor aberto?

Obrigado!

Desculpa pessoal! Havia esquecido de colocar o circuito!

IMAGEM

qsle.png

ARQUIVO

ARQUIVO

Compartilhar este post


Link para o post
Compartilhar em outros sites

Veja,usando o ULN2003 eu tambem não tenho prática,mas seu circuito não precisa dele para funcionar no Hardware real.

Compartilhar este post


Link para o post
Compartilhar em outros sites

No caso eu usando uma fonte pra ligar um led por ex!

E deixando '0' no microcontrolador o led vai acender correto?

Mas qual a corrente de entrada máxima do uC, essa corrente é por porta ou é por canal?

Obrigado!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Eu geralmente uso lógica Negativa,isto é,eu uso a mesma fonte que alimenta o Micro(5v geralmente) e deixo o Led ligado na PORTA e outro terminal no terra e acendo com nivel na PORTA Positivo(nivel alto).

Sobres as correntes,voce tem que procurar estas informações no datasheet do micro,mas o esquema que voce postou pode ser usado diretamente sem o ULN, a menos que o micro trabalhe com 3.3v.

Tem muitos,muitos exemplo aqui no forum destas ligações.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Sim entendi! Mas achei que usando diretamente, sem transistor nem nada não iria funcionar!

Segundo meu professor cada porta do uC consegue disponibilizar 10mA, aí não iria funcionar com o LED!

Vou testar sem o ULN para ver!

Valeu!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×