Ir ao conteúdo
  • Cadastre-se
Entre para seguir isso  
MppS

[Resolvido] Ajuda Vetor em Algoritmo

Recommended Posts

Olá!

Estou tentando fazer um exercício no visualg, tenho que fazer um vetor que recebe 10 números e mostra o maior e o menor. Fiz o código mas acho que estou errando na inicialização da variável. Segue o código

algoritmo "semnome"

var

x: vetor[0..10] de inteiro
conta: inteiro
maior: inteiro
menor: inteiro

inicio

maior <-0
menor <-0

para conta de 1 ate 10 faca
escreva("Entre com um numero: ")
leia(x[conta])

se (x[conta] > maior) então
maior<-x[conta]
fimse

se (x[conta] < menor) então
menor<-x[conta]
fimse

fimpara

escreval("O maior numero e:",maior)
escreval("O menor numero e:",menor)

fimalgoritmo

Ele roda mas o número menor sempre dá 0! Eu já tentei iniciar a variável menor assim menor<-100 mas se eu colocar 100 e o usuário digitar somente números maiores que 100 no final do programa ele mostra o número menor como sendo 100 até mesmo se eu não digitar 100 nos valores que pede!!! Então eu gostaria de saber como inicio essa variável para que o usuário possa digitar qualquer numero sem ter um máximo.

Se alguém puder esclarecer essa dúvida por favor!

Obrigado desde já!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá, é porque você inicializou a variável menor em zero.

inicialize ela com um numero bem alto.. exemplo: menor <-999999

e no seu vetor x: vetor[0..10] de inteiro troque o zero pelo 1

que vai funcionar.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Certo dif mas e se o usuário digitar um número maior que isso?! rsrsrs Não tem como dar uma valor a essa variável que o usuário possa digital qualquer número e não dê erro?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Até tem.

talvez teria que fazer deste modo:


var
menor, maior, i: inteiro
vetorx: vetor[1..10] de inteiro
inicio
leia (vetorx[1])
maior <- vetorx[1]
menor <- vetorx[1]

para i de 1 ate 10 faca
leia(vetorx[i])
se (vetorx[i]>maior) então
maior <- vetorx[i]
fimse
se(vetorx[i]<menor) então
menor <- vetorx[i]
fimse
fimpara

escreval("Menor: ", menor)
escreval("Maior: ", maior)

fimalgoritmo

veja se funciona.. fiz de cabeça sem testar.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Muito obrigado dif , rodou legal, era isso mesmo que eu queria fazer com a variável e não sabia como! Obrigado! Resolvido!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caso o autor necessite, o mesmo será reaberto, para isso deverá entrar em contato com a moderação solicitando o desbloqueio.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Visitante
Este tópico está impedido de receber novos posts.
Entre para seguir isso  





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×