Ir ao conteúdo
  • Cadastre-se
o francês

Formula para mudar resultado de substração

Recommended Posts

Bom dia Gente,

Estou precisando ajudas:

1º Tenho na coluna i3 as quant de produtos que eu vendi,

na j3 a quant. desses produtos que tenho em estoque . porém não tenho todos os produtos , uns vou ter que comprar outros baixar do meu estoque.

A formula simples que eu uso é: l3-j3 . Lógico quando o j3 é maior o resultado é negativo. Nesse caso gostaria que a resposta seja "ESTOQUE" no caso contrario ou seja quando j3 é menor , o resultado seria normal . Ex.: l3=5 j3=10 resultado "ESTOQUE" se for o contrario, resultado 5. ok?

2º muita vez os produtos não são movimentados então aparece "#VALOR!", seria que tem jeito de não aparecer nada.?

Aguardo ansioso uma solução.

Agradeço

o francês

Compartilhar este post


Link para o post
Compartilhar em outros sites

Francês,

Utilize a função =SE para fazer esse critério.

Exemplo: =SE("FRANCÊS"="FRANCÊS";A-B;"ESTOQUE")

Para não aparecer esse erro, "#VALOR!" você pode utilizar a função "SEERRO" .

No caso ficaria assim:=SEERRO(SE("FRANCÊS"="FRANCÊS";A-B;"ESTOQUE");"")

No momento não posso te ajudar com um exemplo mais pode seguir essa linha de raciocínio que dará o rsultado tranquilamente.

Abrs,

Compartilhar este post


Link para o post
Compartilhar em outros sites

Me desculpa, mas não consegui montar a formula . Não tem jeito de você colocar o dados que eu mandei ? ou seja: I3 = PRODUTOS VENDIDOS J3 ESTOQUE DISPONÍVEL. RESULTADO PRODUTO A COMPRAR CASO NÃO TIVER EM ESTOQUE OU A NÃO COMPRAR CASO TIVER EM ESTOQUE.

Obrigado

Compartilhar este post


Link para o post
Compartilhar em outros sites

Que bom que você esta me atendendo novamente.

Sei que meu português é confuso, mas você entendeu quase tudo. A única coisa é quando falei "normal" não é para aparecer a palavra mas o resultado normal ou seja no seu exemplo "5".

Nesse caso a formula ficara como?

Abs

o francês

Compartilhar este post


Link para o post
Compartilhar em outros sites

É só substituir o normal pela fórmula.

Fica assim:

=SE(J3>I3;"ESTOQUE";SE(I3>J3;-I3-J3;""))

Copiar colar e arrastar para as demais linhas.

Dê retorno.

Compartilhar este post


Link para o post
Compartilhar em outros sites

O Felix me mandou esta formula: =SEERRO(SE(I3-J3>0;I3-J3;"ESTOQUE");"")

parece que esta funcionando bem também.

Tenho um problema nas formulas anteriores que você fez. As colunas codigo, quant seguem muito bem a coluna indice mas nã a coluna estoque. Dá para arrumar ? Codigo

=SEERRO(ÍNDICE(A2:$A$900;CORRESP(LIN(A1);F2:$F$900;0));"")

quant.:=SE(H3="";"";SOMASE(A3:A1000;H3;E3:E1000))

estoq.=SE($A3="";"";PROCV($A3;ESTOQUE!$A$3:J1277;5;0))

indice =SE(A3="";"";SE(CONT.SE($A$3:A3;A3)>1;"";MÁXIMO($F$1:F2)+1))

Obrigado

Andre

Eu de novo;

Nem a formula do Felix funciona nem a sua!! Com certeza estou fazendo alguma coisa errado.

Me ajuda por favor.

Obrigado,

André

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom dia,

No Excel 7 è possível passar de uma coluna para outra somente os valores negativos, como valores positivo?

Sendo que a coluna esta numa outro planilha porém no mesmo arquivo.

Obrigado

o francês

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom dia!!

Eu não entendi muito bem.

Considerando que seus dados estão $B$2:$D$10....

=ÍNDICE($B$2:$D$10;MENOR(SE($B$2:$D$10<0;LIN($B$2:$D$10)-MÍNIMO(LIN($B$2:$D$10))+1;"");LIN(A1));COL(A1))

filalize com as teclas Ctrl+Shift+Enter

Compartilhar este post


Link para o post
Compartilhar em outros sites

Eu acho que consegui usar sua formula, obrigado. você sabe eu tenho 78 anos e para mim o Excel é complicado, nunca aprendi estou me baseando no Google , na suas dicas e de um livro que comprei. Mesmo assim... Meu projeto esta ficando joia.

Agora só falta o problema da coluna com valores negativo. Isso é para poder dar baixo ao estoque utilizado na planilha de compra.

Obrigado novamente

Abs

André

ÍNDICE($B$2:$D$10;MENOR(SE($B$2:$D$10<0;LIN($B$2:$D$10)-MÍNIMO(LIN($B$2:$D$10))+

Essa formula é em resposta a que?

Se esta formula é para as quant. em estoque acompanhar o código do produto, a coluna com o estoque de origem é "ESTOQUE" coluna E do destino é "1°compra" coluna "J".

Acho que fiz confusão, deve ser a formula para passa valores negativos de um coluna para outra .

È?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Oi Zinhovba,

Eu fiz confusão entre quem é quem. Me desculpa.

Sua formula é um pouco complicada para mim que sou um amador. Tem jeito de simplificar e de me explicar? a coluna que tem os valores negativos é K da planilha "1° compra" a coluna que tem que receber esses valores é E da planilha ESTOQUE.

Qualquer coisa eu estou a sua disposição e me desculpa novamente

Abs

André o francês

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×