Ir ao conteúdo
  • Cadastre-se
diisenese

Leds rítmicos com filtro passa-baixo

Recommended Posts

Fala galera, beleza? Então gente, eu montei um pequeno circuito de 2 conjuntos de seis leds cada. Cada um pisca em uma frequencia da música. Porém tem um problema, no momento em que eu coloco os capacitores em paralelo com o resistor na base do transistor, a qualidade do alto-falante piora demaaais.
 
Eu li, nesse post do Binho11 aqui http://forum.clubedohardware.com.br/topic/756063-resolvido-circuito-led-rítmico/?p=4228476, que para não piorar a qualidade som e impedir uma tensão de retorno, eu preciso colocar diodos entre os fios do circuito e do alto falante. Mas quando eu faço isso, é como se o diodo eliminasse a existencia do capacitor. A qualidade do alto-falante volta ao normal, mas os leds voltam a piscar como se não existisse nenhum filtro passa-baixo. Alguem me ajuda por favor, não consegui pensar em nenhuma solução. Outra coisa, os transistores são TIP 31C. Coloquei outros porque não achei esses no multisim

 

post-657628-0-44690900-1389143930_thumb.

Compartilhar este post


Link para o post
Compartilhar em outros sites

ninguém tem uma solução? 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Experimente aumentar o valor dos resistores em série com a base, passe eles para 1K Ohms.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Cara, acho que você resolveu o problema. Realmente a qualidade do alto falante ficou melhor, quase voltou ao normal. Se eu aumentar mais o resistor a qualidade volta ao normal?

 

Ah, e só deu certo sem os diodos

Compartilhar este post


Link para o post
Compartilhar em outros sites

@diisenese

 

Parece que o seu amplificador é de baixa potência. tipo um MP3 player ou parecido, Só esse caso justifica a piora no som de seu aparelho. E nesse caso, a impedãncia do seu alto-falante é bem mais alta do que para o qual esse circuito foi projetado.

 

Use um transistor de maior ganho, tipo BC mesmo, Os TIP não tem ganho suficiente para isso.

 

Os diodos , se seu volume é pequeno, tem de ser trocados por 1N4148.

 

Se você aumentar o valor do resistor de entrada, tem também de experimentar valores de capacitores menores. E pode ser que perca muito do efeito.

 

E por último, tem de ter os diodos, pois eles fazem a carga do capacitor; se deixar o sianl alternado entrar, vai ter carga e descarga, atrapalhando muito o efeito original. Ou seja, o circuito não foi projetado para sinais de baixo volume, tem de ter um volume razoável no alto-falante para ele funcionar. E não pode ser fone de ouvido.....

 

Fazendo uma conta simples, se não tiver pelo menos uns 0,7 volts na base do transistor ele não vai acender nada. Os diodos são fundamentais para ter o efeito correto. Se você usar diodos de sinal, tipo 1N4148, vai perder mais 0,7 Volts em cima dele. E se o seu alto-falante for de 8 ohms ( que é para o qual o circuito foi projetado ) , significa que teria de entregar pelo menos  (1,4 x 1,4 )/ 8 = 0,25 Watts . Se for um aparelho pequeno, não consegue mesmo.

 

Paulo

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@aphawk

 

Tá, calma ae, vamo lá hahaha

 

Que amplificador você ta falando? Se você se referiu ao alto-falante, ele é um alto-falante normal de computador, um tanto vagabundo, mas da para o gasto.

 

Usei o TIP31C porque em todos os circuitos de leds rítmicos que encontrei, todos usam o tip 13c porque falam que ele aguenta até 150 leds. Que não é o meu caso, claro.

 

E o circuito e o alto falante estão ligados por um adaptador p2 (http://produtos.ricopecas.com.br/img/products/adaptador-p2-stereox2-jack-j2-stereo-loud_1_600.jpg) na entrada de áudio do pc. Eu sempre deixo o volume do PC em 100% e só diminuo/aumento o volume no alto-falante. Então independente do volume do alto-falante, os leds estão sempre piscando pois o volume do pc está no máximo. Mas eu entendi o que você disse, fiz um teste abaixando o volume do pc e os leds pararam de piscar logo no 50%.

 

Mesmo com os resistores maiores e os capacitores menores, vai perder muito o efeito? Porque em testes aqui, aumentar o valor do resistor foi a única solução para a qualidade do som não piorar e os leds continuaram muito bem.

 

E como eu disse, independente do valor do resistor e capacitor, o diodo está anulando o efeito do filtro passa-baixo.

 

E eu não tenho um conhecimento tão grande, então não fiz tantas contas para isso, mas eu não projetei o circuito pensando que o alto-falante tem 8 ohms nem nada disso, como voce chegou nessa conclusão?

 

Outra coisa, com um transistor de maior ganho, os leds irão piscar mais fortes?

 

Obrigado pela resposta  :)

 

edit: troquei o TIP 31C pelo BC548 e senti que os leds estão piscando com um pouco mais de brilho, porém, se eu abaixar o volume do pc para 50%, os leds se apagam do mesmo jeito

Compartilhar este post


Link para o post
Compartilhar em outros sites

@diisenese,

Pois é.... Matei a charada ! você está pegando o sinal da saida do computador, quando o certo seria abrir a sua caixa acustica e pegar o sinal diretamente em cima do alto- falante !

O seu problema é que a saída de som dos computadores é de impedância relativamente alta, e o seu circuito possui impedãncia baixa, prejudicando o sinal que também está sendo aplicado em sua caixa acustica amplificada.

O que voce poderia fazer é fazer um pequeno amplificador com um LM386, e ligar o seu circuito diretamente na saída dele, assim funcionaria certinho, com diodo e tudo !

Esse CI é bem baratinho, e o circuito é muito simples !

Paulo

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@aphawk

 

Desculpe a ignorância, mas eu não entendi exatamente o por que de colocar meu circuito na saída do LM386, os leds estão piscando do jeito que queria mesmo.

 

E o que eu queria realmente era que ele piscasse independente do volume na caixa de som. Se eu pegasse o sinal da caixa de som, os leds só piscariam no máximo com o volume no máximo, e a caixa de som iria distorcer a música por que não é a das melhores. E se eu fosse pegar o sinal da caixa de som plugando um P2 na caixa, nenhum som iria tocar, o sinal seria direcionado para o meu circuito.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom, se voce está achando o comportamento dos leds legal, não precisa mudar.

Eu apenas quis manter o funcionamento original do circuito, que é uma boa separação das frequências indicadas pelos dois jogoa de leds.

Paulo

Compartilhar este post


Link para o post
Compartilhar em outros sites

@aphawk

 

aaaah entendi.. se eu colocar o LM386 as frequências vão ficar melhores separadas? 

 

Também funciona se eu colocar um novo conjunto de led? Por que eu estava pensando em mudar o circuito para 3 conjuntos de 4 leds, um para os graves, outro para os médios e outro para os agudos

Compartilhar este post


Link para o post
Compartilhar em outros sites

Se você usar o LM386, sua saida de alto-falante vai ter nível bem maior, assim o circuito original vai funcionar direitinho.

Não vai ficar bom colocar um para médios.... Esses circuitos são apenas simples RC , o certo mesmo seria você usar um filtro de verdade, mas vai complicar o circuito, ok ?

Paulo

Compartilhar este post


Link para o post
Compartilhar em outros sites

Não vai ficar bom colocar um para médios.... Esses circuitos são apenas simples RC , o certo mesmo seria você usar um filtro de verdade, mas vai complicar o circuito, ok ?

 

 

 

Sério? :/ queria tanto tres conjuntos piscando junto com a musica. Ficaria bem legal.

 

E o circuito do LM 386 seria esse daqui? http://1.bp.blogspot.com/-hSeE7berm6E/UbodVT_KyXI/AAAAAAAAAV8/xhvJqjK2cYI/s1600/lm386%2Bcircuit.jpg Só que em vez do alto-falante, eu coloco o meu circuito

Compartilhar este post


Link para o post
Compartilhar em outros sites

O que você quer fazer se chama Color Organ. Isso foi muito comum na década de 80. Apesar de eu ter nascido no final dela e não ter visto isso ocorrer. :D

Encontrei alguns circuitos com esse intuito:

Versão fácil:

FFT21FFGQ5PW15T.gifFE28XNJGQ5QB0E1.LARGE.gif

Texto completo sobre o circuito acima (vale a pena ler os comentários onde muitas dúvidas são tiradas):

http://www.instructables.com/id/LED-Color-Organ-Triple-Deluxe/?ALLSTEPS

Versão aprimorada feita com filtros ativos:

ledcolororgan-schem_r2.gif

Texto sobre o circuito acima (Ler os comentários é imprescindível para compreender o circuito). E tem um vídeo também. O cara é uma comédia. o efeito final fica interessante.

http://makezine.com/2010/10/18/circuit-skills-led-color-organ-spon/

Falou

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

@MatheusLPS,

 

Esse último é exatamente a maneira que se fazia um analisador de espectro nos anos 80 .....

 

O primeiro é bem prático e já dá um bom resultado, eu cheguei a montar um muito parecido na época das discotecas kkkkk !

 

Paulo

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@aphawk

 

Então. Já vi muitos circuitos para fazer analisador de espectro assim. O problema é o tamanho que o circuito final fica. Se bem que temos muitos chips com 4 ou mais AMPOP  dentro.

 

Falou

Compartilhar este post


Link para o post
Compartilhar em outros sites

@MatheusLPS

 

caraaaamba mano.. muito bom, obrigado. Realmente, o tamanho do circuito fica mt grande, mas isso sim é um filtro que o aphawk tava falando, em vez de apenas filtro RC. Eu vou ler os dois links e se eu tiver alguma dúvida eu posto aqui. Mas eu só tenho uma dúvida básica mesmo. A diferença de resultado é muito grande do primeiro circuito que voce postou para o meu circuito?

E o primeiro circuito não deixa de ser filtros RC né?

 

@aphawk

 

Quanto ao LM386, como ele está amplificando o circuito, os leds ainda vão piscar mesmo se o volume do pc estiver abaixo de 50%?

 

EDIT:

 

Outra coisa, por que em certos circuitos que eu vi de leds rítmicos/color organ todo mundo prefere deixar os leds em série? Não é melhor deixar em paralelo por que se um led pifar, os outros continuam piscando.

Compartilhar este post


Link para o post
Compartilhar em outros sites

@diisenese,

 

Bom, ele tem um ganho bom, de cerca de 40 se não me engano, então deve piscar mesmo com volume abaixo de 10% ..... o problema é que se você usar um volume tipo 30%, o sinal já vai sair distorcido na saída do LM386, então acho melhor voce colocar um pequeno trim-pot de uns 47K para fazer o ajuste de volume do LM386 para o nível que voce costuma usar, ok ?

 

Os Leds em série permitem a gente utilizar um resistor limitador de menor tamanho, e fica com bem menos perda !

 

A diferença é grande entre os circuitos sim, mas também tem muita diferença de complexidade, não é ?

 

Paulo

Compartilhar este post


Link para o post
Compartilhar em outros sites

@diisenese, o que passei, o mais fácil, continua sendo RC. Mas tem uma construção mais robusta em relação daquele que você postou.

 

Veja que interessante. Vi novamente, e o autor da quele circuito que postei, fez uma atualização 1 ano depois da publicação do mesmo.

 

Veja:

 

http://www.instructables.com/files/orig/F29/Q85R/HD4V45C0/F29Q85RHD4V45C0.pdf

 

Artigo:

 

http://www.instructables.com/id/Color-Organ-Triple-Deluxe-II/?ALLSTEPS

 

Vou montar um desse para ver o resultado.

 

Falou

Compartilhar este post


Link para o post
Compartilhar em outros sites

@aphawk @MatheusLPS

 

Aaah entendi. Bom, vou refazer o circuito com os leds em série e baseado naquele primeiro circuito do Color Organ porque quero 3 canais de frequência e eu gostei bastante do resultado com a quinta sinfonia do bethoven remixada. E eu vi a versão mais atualizada, realmente ficou muito bom mesmo, fiquei até com inveja. E a PCB preta é muito bonita.

 

Outra coisa, vocês podem me dizer se os filtros no Q2, Q3 e Q4 são filtros passa-baixa ou passa-alto. Pois estou me confundindo já que no meu circuito eu deixei o capacitor em paralelo indo para o terra. E também se eu preciso mudar algo já que eu pretendo instalar no meu pc, e vou usar os 12 V da fonte. E o porque dele usar transistores PNP em vez de NPN como o BC548

Compartilhar este post


Link para o post
Compartilhar em outros sites

@aphawk @MatheusLPS

 

galera, estão ai?

Compartilhar este post


Link para o post
Compartilhar em outros sites

@diisenese,

Se voce observar bem o link com a atualização, que o Matheus postou, vai ver que mudou o circuito.

O autor disse que teve problemas com o circuito original, e modificou. Monte este novo !

Repare que agora ele usa tudo transistor NPN.

Tecnicamente, a parte de graves e de médios são filtros passa-faixas, e a parte de agudos é um passa-altas, ok ?

Paulo

Compartilhar este post


Link para o post
Compartilhar em outros sites

@aphawk @MatheusLPS

 

Gente, dei uma atualizada no meu circuito, gostaria de saber se agora está melhor e ainda tenho algumas duvidas.

 

Eu li que com um capacitor de 10 uF e um resistor de 1,2 K, o ganho do LM386 já iria para 50. E como o aphawk falou que com um ganho de 30 já iria distorcer, eu não coloquei um trim-pot de 47 K, coloquei um trim-pot de 2 K.

 

E gostaria de saber o por que eu preciso de um potenciometro de 10 K antes da entrada do amp-op.

 

E também se eu preciso colocar algo a mais onde estão os filtros passa-baixas.

 

É isso, valeu :D

post-657628-0-56837900-1391056686_thumb.

Compartilhar este post


Link para o post
Compartilhar em outros sites

@diisenese,

 

Tem coisa estranha aí no teu LM386...

 

Use este circuito aqui :

 

http://web.mit.edu/6.s28/www/schematics/lm386.htm

 

 

use VR1 um trim-pot de 10K

 

e em série com C1, use um resistor de 100K. Se o ganho ficar muito baixo, troque este resistor por 47K.

 

Paulo

Compartilhar este post


Link para o post
Compartilhar em outros sites

@aphawk

 

Olha, eu usei o circuito deste site aqui, é bem parecido http://www.quartzo.net/arquivo/quartzo/info/lm386/lm386.html

 

O "VR1" do meu circuito já é o trim-pot de 10K, que no caso é o R13.

 

Por que eu tenho que usar esse VR1 se o ganho já é entre o pino 1 e 8?

 

E em todos os circuitos eles só consideram como se fosse um sinal de áudio, mas na verdade são dois, o canal direito e o esquerdo. Está certo a entrada dos dois sinais no amp-op?

post-657628-0-47294400-1391115978_thumb.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×